Unable to change mouse cursor theme and size

Bug #786325 reported by Beholdarkness on 2011-05-21
120
This bug affects 26 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
Unity
Invalid
Undecided
Unassigned
compiz (Ubuntu)
Low
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 11.04 Natty Narwhale

When attempting to change mouse cursor size and/or theme in Natty the theme and/or size do not change. A workaround for this is entering the following line into a Terminal but the user is still UNABLE to change the size of the cursor.
sudo update-alternatives --config x-cursor-theme

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: gnome-control-center 1:2.32.1-0ubuntu15
ProcVersionSignature: Ubuntu 2.6.38-9.43-generic 2.6.38.4
Uname: Linux 2.6.38-9-generic i686
NonfreeKernelModules: fglrx
Architecture: i386
Date: Sat May 21 23:12:18 2011
ExecutablePath: /usr/bin/gnome-appearance-properties
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
ProcEnviron:
 LANGUAGE=nb_NO:en
 LANG=nb_NO.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)

Beholdarkness (beholdarkness) wrote :
Beholdarkness (beholdarkness) wrote :

UPDATE:

When cursor is hovering some windows such as Gnome Terminal and Google-Chrome the cursor appears with the correct size as set in Appearance Properties, but over the desktop it is larger than decided in Appearance Properties.

Some areas in Google-Chrome such as this text input field will have the desired cursor size, links in Chrome will also have the desired size, also areas with text will have the desired size but not areas that are empty which now appears to be the only area where the mouse pointer appears with the wrong size in Chrome.

In Ubuntu Calculator the mouse cursor appears as it should when hovering over the display but appears in wrong size when hovering the button area.

Beholdarkness (beholdarkness) wrote :

This is a bug in Compiz. Compiz 9 has no option to change mouse themes. I disabled Compiz to play the game Football Manager and the mouse cursor theme and size was correct.

affects: ubuntu → compiz (Ubuntu)
Changed in compiz (Ubuntu):
status: New → Confirmed

This bug is not so much that you're unable to change the theme, just that it's applied inconsistently. I can change it, but when going over the Launcher, it changes to the default.

Steps to reproduce:

1.) Open 'Appearance' from the dash
2.) Hit the 'Customise' button or Alt+u shortcut
3.) Select the Pointer tab on the right
4.) Change the pointer to e.g. redglass and make it any size you like

Expected result:

Cursor theme applies throughout the UI

Actual result:

On the Appearance window it will still be default, but go over Firefox for example and it becomes what you set it to. Go over the launcher and it will be default.

Changed in compiz (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Beholdarkness (beholdarkness) wrote :

Yes, the theme changes inconsistently. When I first filed the bug report I thought it didn't change at all but learning that it did (inconsistently) I updated. While this isn't critical, it's annoying and I couldn't find any reports of this at the time.

jay armstrong (jayarmstrong) wrote :

I'd like to see it get higher priority as it's an accessibility issue for anyone with bad eyesight or even just a large screen.

Schorsch (schorschi-schorsch) wrote :

I really do agree. It's really worth a higher priority.
I think Bug #753405 is al dublicate oh this bug. It was affected to gnome-control-center

Yann Salmon (yannsalmon) wrote :

I agree with comments #7 and #8 regarding priority. I know people who simply cannot use a system with such a small cursor as the default one.

samuel butts (samuel-butts) wrote :

need to get more people to click this "affects you" - it effects everyone! very annoying it is too!

Smittix (jamessmith1) wrote :

Totally agree, this bug has been on and off in a few releases. It definitely needs a higher priority. It's one of the first things I customize and I'm sure I am not alone.

J Ivany (jjivany) wrote :

this might be temporary fix; sudo dconf read /org/gnome/desktop/interface/cursor-theme>>sed||/usr/share/icons/default/index.theme

Uri Shabtay (uri.shabtay) wrote :

amazing how this bug isn't getting the right attention.. in 10.10 - everything is ok, and the bug is gone. yet in 10.04 - surprise.

same as in Natty and Oneiric (without mentioning the lack of customizebility)

George Fragos (fragos) wrote :

The application of cursor theme isn't consistently handled in 11.10. Changes made with dconf indeed don't impact the normal cursor pointer but do take effect in some cases like when hovering over a link or within a text entry field both the cursor size and theme set in dconf are used not for the cursor displayed while moving around the screen.

A C C E S S I B I L I T Y

It definitely has an unlucky effect for people with bad eyesight.

accessibility -> suggest this for 100 papercuts !

ethanay (ethan-y-us) wrote :

echo Flames_in_Paradise

this is NOT a "low priority" bug -- this is a huge setback for anyone with vision impairments. It is a fundamental ACCESSIBILITY issue. Just because you can see the pointer just fine in its default setting doesn't mean that many of your target audience can! Please have a little sensitivity toward your user base.

Was present in Lucid and Natty, and also in Precise ! And even worse, it happens also in the Xubuntu variant even if it hasn't Compiz installed !

+1 ehanay and Flames_In_Paradise !
I have bad eyesight and I badly need a large-sized cursor that works everywhere ! When I was under Lucid, I used to disable Compiz, but now in Precise, that's impossible ! Even worse : I tried once to switch to "Xfce session", then I ended up locked out from my session until I booted a recovery mode session to remove .xsession-errors and .Xauthority from my home folder !

Related: My cursor is stuck at "spinning" when hovering over desktop. This makes it difficult to even click links / applications, as the point of contact is different.

Narate Taerat (naratesk) wrote :

I have the same issue here.

ethanay (ethan-y-us) wrote :

Why does it work for this guy:
https://www.youtube.com/watch?v=2hu9JrdSXB8

and not the rest of us?

Eleni Maria Stea (hikiko) wrote :

I'll change this bug's status to Invalid, since we didn't manage to reproduce it in recent Ubuntu releases that use compiz (tried mate + unity) and moreover it's quite old. If you still experience this problem though please feel free to re-open it and update the description. Thank you!

Changed in compiz:
status: New → Invalid
Changed in compiz (Ubuntu):
status: Triaged → Invalid
Eleni Maria Stea (hikiko) wrote :

Mmm, I noticed a similar issue happening in wily but it's not compiz related because it's happening on unity DE only (not mate): sometimes the mouse pointer size changes like in the attached video. I link unity to this bug report.

Rodrigo Lledó (rodhos-hp) wrote :

Please fill another bug report with the video attached since it's a different bug.

Changed in unity:
status: New → Invalid
Changed in unity (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers