Drag-Drop works only on --replace (ubuntu-classic session)

Bug #783926 reported by Shashank on 2011-05-17
62
This bug affects 12 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: compiz

Cannot drag-drop things between different applications on startup (Ubuntu-Classic Session).
Eg: When I drag a .mp3 file to the banshee tab in the bottom panel, it just stays with a + sign over the banshee icon, banshee does not get selected while dragging the file. If I drop it there, it gets added to the panel.

However, if i do 'compiz --replace' in the terminal, it starts working after that.
And I have to replace after every boot.

My compiz was in the default settings so I don't think any changes might be the reason for that.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: compiz 1:0.9.4+bzr20110415-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,snap,gnomecompat,move,imgpng,shift,mousepoll,vpswitch,resize,regex,grid,place,session,wall,animation,expo,ezoom,switcher,workarounds,staticswitcher,fade,scale]
CompositorRunning: compiz
CurrentDmesg:
 [ 18.876033] input: ImPS/2 Generic Wheel Mouse as /devices/platform/i8042/serio1/input/input3
 [ 19.529445] ppdev: user-space parallel port driver
 [ 21.976028] EXT4-fs (sdb5): re-mounted. Opts: errors=remount-ro,commit=0
 [ 93.238776] exe (1876): /proc/1876/oom_adj is deprecated, please use /proc/1876/oom_score_adj instead.
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1024x768 800x600 800x600 848x480 640x480
 edid-base64:
Date: Tue May 17 16:26:23 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation 82G33/G31 Express Integrated Graphics Controller [8086:29c2] (rev 10) (prog-if 00 [VGA controller])
   Subsystem: Elitegroup Computer Systems Device [1019:2639]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
MachineType: Maxtone MaxG31PR(HIS)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_IN:en
 LANG=en_IN
 LC_MESSAGES=en_IN.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=bcde998f-837e-4483-b61b-a30b58b24fe1 ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Renderer: Unknown
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/05/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 080014
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: MaxG31PR(HIS)
dmi.board.vendor: Maxtone
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: Maxtone
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr080014:bd08/05/2008:svnMaxtone:pnMaxG31PR(HIS):pvr1.0:rvnMaxtone:rnMaxG31PR(HIS):rvr1.0:cvnMaxtone:ct3:cvr1.0:
dmi.product.name: MaxG31PR(HIS)
dmi.product.version: 1.0
dmi.sys.vendor: Maxtone
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Shashank (shashanksingh28) wrote :
description: updated
description: updated
description: updated
OzzyFrank (ubuntu-ozzyfrank) wrote :

Yes, I have the same problem here, being if I want to drag and drop items from one folder to another that isn't visible, by holding it over the corresponding taskbar button till the folder appears, all I get is the + sign, and if I let go, a launcher to the file or folder is created. This is using the Classic desktop in 11.04, and is the same with Thunar. Thanks for the compiz --replace tip, as that rectified it (I assume until the next reboot).

Doug McMahon (mc3man) on 2011-05-21
Changed in compiz (Ubuntu):
status: New → Confirmed
Philipp Gassmann (phiphi.g) wrote :

also rearranging the taskbar items does not work

Florian Rubach (fr-4) wrote :

This is a most disturbing one

fig_wright (fig-wright) wrote :

Also have this bug. It's very annoying and hit productivity.

Matteo Biagi (matteobiagi87) wrote :

I had not brought this issue until the other day when I updated the packages.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers