Liferea opens other windows in the foreground and loses focus - regression from Gnome 2/3

Bug #782758 reported by TomasHnyk on 2011-05-14
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: compiz

How to reproduce the bug:
1. Make sure you are using Unity
2. Install liferea
3. Open a link from liferea

What happens:
A browser windows is opened, goes into foreground and steals focus from Liferea (if using Opera as a browser to open links, if Opera is minimized, this bug does not occur - with Firefox it seems to occur always).

What should happen:
the link should open in the background. It did happen with metacity so I think this is a regression. It also works this way with Gnome Shell. The use case is skimming all new items, opening them and then reading them later.

Note: this happens only if Focus Prevention Level in Focus & Raise Behaviour in General Options in ccsm is set to low or off(which is the default though) - if it is set to normal or higher, this does not occur, so maybe it is a compiz thing? Anyway, this behaviour came with Unity.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: liferea 1.6.4-1ubuntu7
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
Date: Sat May 14 20:28:49 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_US.UTF-8
 LC_MESSAGES=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: liferea
UpgradeStatus: No upgrade log present (probably fresh install)

TomasHnyk (sup) wrote :
TomasHnyk (sup) wrote :

Marking as invalid, everything sorted itself out an I cannot longer reproduce this.

Changed in liferea (Ubuntu):
status: New → Invalid
TomasHnyk (sup) wrote :

Turns out I only forget I set Focus Prevention Level to normal in CCSM, this still persists.

Changed in liferea (Ubuntu):
status: Invalid → New
TomasHnyk (sup) wrote :

This is not a problem of Liferea itself, it works fine with Gnome fallback (metacity I guess) and Gnome-shell (mutter). Hence a problem in compiz.

affects: liferea (Ubuntu) → compiz (Ubuntu)
summary: - Liferea opens links in the foreground and steals focus
+ Liferea opens links in the foreground and loses focus
TomasHnyk (sup) on 2011-11-20
description: updated
TomasHnyk (sup) on 2011-11-25
summary: - Liferea opens links in the foreground and loses focus
+ Applications open other windows in the foreground and loses focus -
+ regression from Gnome 2/3
TomasHnyk (sup) on 2011-11-25
description: updated
summary: - Applications open other windows in the foreground and loses focus -
+ Liferea opens other windows in the foreground and loses focus -
regression from Gnome 2/3
affects: compiz (Ubuntu) → unity (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2012-04-04
affects: unity (Ubuntu) → compiz (Ubuntu)
Omer Akram (om26er) on 2012-06-18
Changed in unity:
status: New → Confirmed
Mario Vukelic (mario-vukelic) wrote :

I am not sure I'm experiencing the exact same bug, but might be, because I see the same behavior.

PERCEIVED PROBLEM:
When opening a link from Liferea, Thunderbird, Tomboy (tested, but possibly all apps are affected which open links in Firefox), the Firefox window goes to foreground and steals the focus.

WHEN DOES THIS HAPPEN
This problem only appears when the app used to open the link is on the same Workspace as Firefox. When they are on separate Workspaces, Firefox stays in the background.

I know I noticed the problem after I upgraded to 12.04. It's possible that it started there or with a subsequent particular new version in Firefox's fast release cycle.
For several years before it had worked the way I wanted even after the switch to Unity (i.e., Firefox stayed in background), but it's entirely possible that I had Firefox on a different Workspace all this time - I did change some of my work habits after getting used to Unity.

DESIRED BEHAVIOR
I like to have apps I'm currently interested in on the same Workspace. Unity encourages this because Alt+Tab only affects windows on the same Workspace; else you need to use the awkward and little familiar Ctrl+Alt+Tab.
But if I do this, the focus switch is annoying because I like to scan the RSS feeds in, e.g., Liferea to open whatever catches my interest, but I'll read the actual web pages later, after I'm done with Liferea. The current behavior forces me to switch back to Liferea all the time.

TomasHnyk (sup) wrote :

I think this is the same bug, the behaviour is identical.

Omer Akram (om26er) on 2012-08-16
affects: unity → compiz
Changed in compiz:
status: Confirmed → Invalid
Changed in compiz (Ubuntu):
status: Confirmed → Invalid
Eleni Maria Stea (hikiko) wrote :

This bug is quite old and affects unsupported Ubuntu releases. Since I couldn't reproduce it anymore I changed its status to Invalid. If you still have it in one of the supported Ubuntu releases please feel free to re-open the bug and update the description. Thank you.

TomasHnyk (sup) wrote :

This still applies on current liferea on Ubuntu 15.04. I think this is related to: https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/455241

Changed in compiz:
status: Invalid → Confirmed
Changed in compiz (Ubuntu):
status: Invalid → Confirmed
Mario Vukelic (mario-vukelic) wrote :

Confirming, I also still have the same behavior in 15.04 as in my earlier comment from 2012

Mario Vukelic (mario-vukelic) wrote :

Now I have the same problem n gnome-shell 3.30 on a fresh install Cosmic, but worse because keeping Liferea on a separate workspace is not helping anymore - it switches to the Firefox workspace. I realize that this should become a new bug report and not for Compiz anymore, but maybe one of the people previously affected by this can confirm if they are seeing it too?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers