Ubuntu

Compiz freezes after screen goes blank

Reported by nesur on 2011-05-10
68
This bug affects 15 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: compiz

In a fresh Natty install, Compiz freezes after the screen goes blank when I close the laptop lid. However, this ONLY occurs if in Screensaver settings the option "Lock screen when screensaver is active" is DISABLED. This is how to trigger it:

1. Untick "Lock screen when screensaver is active" in screensaver preferences dialog.
2. Close laptop lid.
3. Open laptop lid.
4. The screen reappears, all the applications are shown and the mouse cursor moves. However, there is no interaction possible between the user and the applications. The mouse cursor does not change shape when it is hovered over different parts of the applications windows. Everything is unresponsive. I tried to "blindly" enter my password, but this changes nothing.
5. Ctr+Alt+F1 works, and there I can kill compiz (with -9 kill switch) via the command line. Once killed, everything goes back to normal.

If the user enables "Lock screen when screensaver is active" option, the expected behavior is obtained:
1. Tick "Lock screen when screensaver is active" in screensaver preferences dialog.
2. Close laptop lid.
3. Open laptop lid.
4. A dialog asking for password appears. I enter my password and
5. The screen reappears, all the applications are responsive and everything works

This occurs with both Unity and Ubuntu Classic desktop.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: compiz-core 1:0.9.4+bzr20110415-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
DRM.card0.DP.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.DP.2:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI.A.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1366x768
 edid-base64: AP///////wAGrzwgAAAAAAESAQOAHxF4Cgnll1dUkyciUFQAAAABAQEBAQEBAQEBAQEBAQEBIBxWgFAAIzAwIDYANa4QAAAYAAAADwAAAAAAAAAAAAAAAAAgAAAA/gBBVU8KICAgICAgICAgAAAA/gBCMTQwWFcwMiBWMCAKALQ=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Tue May 10 19:05:40 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
ExecutablePath: /usr/bin/compiz
GraphicsCard:
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:1862]
   Subsystem: ASUSTeK Computer Inc. Device [1043:1862]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
MachineType: ASUSTeK Computer Inc. U80A
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=9d24d5d1-a21f-4734-9346-3bb73bfc2aac ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Renderer: Unknown
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
XsessionErrors:
 (<unknown>:2111): dee-WARNING **: Transaction from com.canonical.Unity.FilesPlace.SectionsModel is in the past. Ignoring transaction.
 (<unknown>:2111): dee-WARNING **: Transaction from com.canonical.Unity.FilesPlace.GroupsModel is in the past. Ignoring transaction.
 (<unknown>:2111): dee-WARNING **: Transaction from com.canonical.Unity.FilesPlace.GlobalGroupsModel is in the past. Ignoring transaction.
dmi.bios.date: 10/21/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 210
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: U80A
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: ATN12345678901234567
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr210:bd10/21/2009:svnASUSTeKComputerInc.:pnU80A:pvr1.0:rvnASUSTeKComputerInc.:rnU80A:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
dmi.product.name: U80A
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

nesur (uribepnr) wrote :
nesur (uribepnr) wrote :

I just want to add that this is not related to suspend or hibernation. The computer is configured to only blank the screen when the lid is closed.

David Gillies (daveg) wrote :

I'm running a desktop machine (Sandy bridge onboard graphics) and I've been affected by this bug too. I can confirm that enabling "Lock screen when screensaver is active" that the problem goes away.

kill3 (kille9494) wrote :

I am having the same problem with HP G62 laptop. I guess I'll have to use "Lock screen when screensaver is active" too. Which is little annoying because I have set Ubuntu not ask password even when logging in...

micred (tict) wrote :

Please consider merging to Bug 762918.

Changed in compiz (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 762918, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

Evan Cummings (exmortis223) wrote :

fix: Just uninstalled gnome-screensaver which is disabled in 12.04 as far as I can tell anyway.

My suspend now works properly with closing of lid.

sudo apt-get purge gnome-screensaver

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers