Compiz Screenshot renders blue overlay on screenshots

Bug #771875 reported by Bruce Pieterse on 2011-04-27
536
This bug affects 114 people
Affects Status Importance Assigned to Milestone
Compiz
Medium
MC Return
Compiz Core
Medium
MC Return
compiz (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: compiz

I enabled the "Screenshot" feature under extras in CompizConfig Settings Manager with the default settings (no directory and no launch application blank).

I have taken numerous screenshots and I have tried disabling an enabling the plugin again, but unfortunately the blue overlay is included in the screenshot.

Please see screenshots attached.

Related branches

Bruce Pieterse (octoquad) wrote :
Bruce Pieterse (octoquad) wrote :
Bruce Pieterse (octoquad) wrote :

I would also like to add that this bug was not present on the current version of compiz in Ubuntu 10.10. I upgraded to 11.04 two days ago.

compiz:
  Installed: 1:0.9.4+bzr20110415-0ubuntu2
  Candidate: 1:0.9.4+bzr20110415-0ubuntu2
  Version table:
 *** 1:0.9.4+bzr20110415-0ubuntu2 0
        500 http://za.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status

Bruce Pieterse (octoquad) wrote :

The problem lies with the Ubuntu Unity Plugin. When disabled it works perfectly.

Mark White (mark-somsip) wrote :

Exactly reproduceable here under the same conditions - upgraded from 10.10 to 11.04 2 days ago, and screenshots taken with <super>button1 pick up the blue hightlighting when saved.

psypher (psypher246) wrote :

I have the same issue on Natty final and fully updated. also found duplicate bug: 771875 with some more info attached. I can confirm that turning off unity works, but then of course unity is off and my launcher disappears. This is very annoying, I use this feature every day

Pépou (yannickw24) wrote :

Same for for, this is a very useful feature for me and i can't use it anymore with unity.

Matthias Niess (mniess) on 2011-05-12
Changed in compiz (Ubuntu):
status: New → Confirmed
peddy (peddy22) wrote :

This bug is very funny and even more irritating. It affects me too, upgrading from 10.10 to 11.04.

frederyk (frederyk) wrote :

This bug is driver independent. I could reproduce it at an eee 701 (intel), at a lenovo s12 (nvidia) and at a desktop (ati).

psypher (psypher246) wrote :

I just reproduced this bug using shutter when using the window capture option, instead of blue there is an orange overlay (like the compiz snap colours)

Please can this bug be assigned so that someone starts looking at this urgently, this is a critical feature I use in daily work.

Thanks

Erin Heimer (heimer16) wrote :

Bug seems to have something to do with the quickness of grabbing the screenshot. When I take it really quickly, while still moving the mouse, it comes up with the blue transparency. When I pause the mouse for a second before letting go of the button, I get a good screenshot without blue overlay.

Pépou (yannickw24) on 2011-06-13
Changed in compiz (Ubuntu):
status: Confirmed → In Progress
status: In Progress → Confirmed
Screatch (screatch) wrote :

Confirming, same problem. Ubuntu 11.04 clean install with all updates.
Erin Heimer workaround does not seem to always work.

Blue overlay happens randomly for me. Sometimes i get screenshots with this overlay, sometimes normal screenshots.

Cyclops (songsofdistantearth) wrote :

+1

Berserk (bers-com) wrote :

hate this

Chris Bauer (cfbauer) wrote :

Pausing for awhile (I tested about 20 seconds) doesn't have any affect on the blue tint display for me.

Eric Mill (konklone) wrote :

Pausing doesn't help me either, for what it's worth.

Chris Bryant (krsnadas) wrote :

Same as everyone else, I'm not able to get a screenshot without the blue overlay.

Paul Hoell (hoellp) wrote :

I also found this bug in up-to-date oneiric with compiz version 1:0.9.5.92+bzr2791-0ubuntu2

It seems to work better with a pause, but not consistently. Also if i release the mouse button very fast, i get the attached pic.

Btw, i remapped the key for screenshot to Super+Shift+Mouse so it doesn't conflict with Unity. That was the only change.
I'm on a new installation of oneiric with the old /home, but i already deleted all compiz and unity related config a few times after installation because of other problems.

This effects me too.

Klaus Reichl (klaus-reichl) wrote :

Note: if "screenshot" is bound to a different key (I tried with <Super>Button3), bug is gone.
So I think the "highlight" feature (bound to <Super>Button1) is somehow in the way and should be switched off before "taking the picture".

Berserk (bers-com) wrote :

Have same bug in ubuntu 11.10.

Binding to another keys didn't help.

katsuo-san (yann-milin) wrote :

I have the same bug using OpenSuse 11.4, compiz 0.9.2.1-5.5

When I disable the "Force full redraws (buffer swap) on repaint" switch in the "Workarounds" plugin, screenshots are working fine again.

Matthias Niess (mniess) wrote :

That workaround doesn't solve it for Unity ace fulscreen redraws are not enabled by default. But it might hint at where the problem really is.

nicolas (nclmar) wrote :

Same here.
Temporarily , is there a way to remove the overlay not just from the screenshots but while taking screenshots, too? The border is sufficient, and the issue won't be visible anymore.

David (david-fransson) wrote :

Same problem here, and I'm trying to convince my GF that Ubuntu is teh shit. So far things have mostly been shit though and she's not impressed.

Nicolas is right though. The coloured overlay isn't necessary and a box or border only would be enough and not cause any problems even if the bug is "still there"..

Bart Heinsius (bheinsius) wrote :

My (novice) Ubuntu users loved this feature because of its simplicity, and now it's unusable for them.
I think the use and value of this simple tool is underestimated.

Bart Heinsius (bheinsius) wrote :

Workaround: add gnome-screenshot --area to the Unity launcher following instructions at http://www.techdrivein.com/2011/05/top-6-quicklists-for-ubuntu-1104-natty.html

On Sun 06 Nov 2011 18:38:40 SAST, Bart Heinsius wrote:
> Workaround: add gnome-screenshot --area to the Unity launcher following
> instructions at http://www.techdrivein.com/2011/05/top-6-quicklists-for-
> ubuntu-1104-natty.html
>

Hi Bart,

Thanks for the workaround. Since I submitted this bug almost six months
ago I'm amazed that no one has attended to it or provided this work
around.

--
Best of luck,

Bruce

psypher (psypher246) wrote :

I decided to just use Shutter to get around this problem. Although I am a bug hunter and this feature used to be awesome and would prefer that it's fixed. I just tried the feature in Oneiric and is still persisting. It has actually broken something just activating it. As soon as I clicked on screenshot in compiz config my entire unity crashed and restarted and now super+d does not work anymore. Cannot use the desktop shortcut at all. So something is seriously wrong with this feature that unity has broken.

Pépou (yannickw24) wrote :

Please do something ! This bug is present since 8 month and still nothing !!!

Such a silly bug.
Don't want to step on anyone's toes, but this shouldn't be that hard to fix, should it?

Screatch (screatch) wrote :

These are the small bugs that spoil the impression about Ubuntu.

Its really small and really annoying bug and i can't understand why this can't be fixed.
There are atleast 2 ways i see how this get's no attention whatsoever for 9 months.

a. Add small delay before each screenshot, 5-15ms, so the overlay will be gone by the time screenshot will actually be done.
b. Remove the blue overlay, border is sufficient

Is there anyway someone can pleaase release a patch? :)

I am using compiz screenshot for my scripts and using gnome-screenshot is the shitty workaround for me.
scrot could work, but i love having script on Super + Btn 1 which i suspect won't be able to implement the way i want for scrot.

yagocasti (yagocasti) wrote :

Same problem.

"Importance : undecided"
"assigned to : unassigned"

Come on, pleaaaase !

Klaus Reichl (klaus-reichl) wrote :

Did a debug session today, since I think, this lightweight safeing of parts of the screen is really a plus over complicated screenshot programs.

Here what I found (I've started with compiz code today, so no real know-how about the code yet):
Checkout from launchpad bzr precise, but this does not matter.

1) plugins/screenshot/src/screenshot.cpp is extending the selection with the overlay, which at the end is to blame for the problem
(having the selected rectangle as overlay on the final screenshot).

If the "glRecti (...);" is commented out in "ShotScreen::glPaintOutput", the overlay is not drawn, only a rectangle around the selection, and the overlay is not seen on the screenshot. This could be a hacked solution to the problem towards having a "good" picture on the screenshot (however, that's not what is expected).

2) plugins/screenshot/src/screenshot.cpp is NOT explicitly taking care about removing the selection overlay. I don't know, which
piece of code does this, however, this seems the problem, since the code assumes that during " ShotScreen::paint" where the picture is taken using "glReadPixels", the overlay is already removed, which is not the case.

3) When debugging the thing using breakpoints in the states (ShotScreen::terminate, ShotScreen::paint) one sees that the break on terminate shows the selection high-lighted, the break on paint has no more hightlight, but the "glReadPixels" is still getting the bits with the hightlight on (I know that debugging X is dangerous wrt. results seen on the screen, I just report this for addional information).

Theory:

1) glReadPixels need some precondition (I tried glFlush without success) to get the current stuff read

2) glReadPixels and stuff around to safe the data need to be deferred until the selection is unhighlighted

Is there somebody with compiz knowhow, who could bring light into this issue?
cuK

Klaus Reichl (klaus-reichl) wrote :

Hi,

Was sick, so no progress, except ...

Tried 2) from my last post "defer taking the picture", but no success, hmmm???

Even after a delay of 10 seconds, the glReadPixels deliverers the drawn frame around the selection. And to be clear here,
you don't see them any more on the screen so where is the cache?

So my analysis continued:

1) The GL stuff somewhere caches what screenshot.cpp draws on the screen to show the selection

2) The ??? removes the selection after shot has been taken on the screen

3) But not on the cache glReadPixels is working on (even 10 secs later it is still there)

So, somebody knows what ??? is and how to force the selection drawing being deleted programatically within screenshot.cpp before glReadPixels.

cuK

Alex Korobkin (korobkin) wrote :

Indeed, commenting out line 280 and rebuilding compiz-plugins package in plugins/screenshot/src/screenshot.cpp solves the problem. Tested Ubuntu 12.04 64-bit Alpha.

Matthias Niess (mniess) wrote :

@korobkin, this is great! Could you create a patch to attach to this bug? Maybe we can get a freeze-exception to get this in?

Makario Lewis (makariolewis) wrote :

I agree, I was really wishing this would be fixed in 12.04; if a patch is working, perhaps we can still squeeze it in before release time?

Atheg (hoganaj) wrote :

This is really bad.

Matthias Niess (mniess) wrote :

I tried the fix in #37 and it didn't work. The only thing it changes is that it removes the dark-blue border around the light-blue box.

Alex Korobkin (korobkin) wrote :

Weird, it removed the blue tint selection for me altogether. I will try to make a patch.

The attachment "patch-workaround. Simply stops blue rectangle from being drawn." of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Matthias Niess (mniess) on 2012-04-03
tags: added: precise regression reproducible ubuntu
Berserk (bers-com) wrote :

same bug in 12.04

erenon (erenon2) wrote :

On the latest Ubuntu, 12.04, you can use the Shift+PrintScreen key combination to get the same functionality. After pressing Shift+Print, your coursor will change to a crosshair. After selecting an area, the usual promt will show up.

Berserk (bers-com) wrote :

2erenon
It's not same functionality. With compiz plugin i can create and share screenshot by special script, not only save its on disk.

Tomasz Przybysz (topr) wrote :

Bug still exists with 12.04.
Workaround mentioned at post #11 sometime works (I guess you have to hold the mouse still when releasing button after the 'pause'). Anyway, such workaround is not convenient enough for normal usage.

Pépou (yannickw24) wrote :

+1 Tomasz. Bug still here with ubuntu 12.04.

MC Return (mc-return) on 2012-06-14
tags: added: compiz-0.9
Y. Leretaille (yleretaille) wrote :

Just upgraded from 11.04 to 12.04, activated the screenshot plugin and got the error. This is very annoying! I use this plugin alot and it is very usefull because it's yet simple but still configurable in many different ways.

Changed in compiz-plugins-main:
assignee: nobody → Matthias Niess (mniess)
Changed in compiz (Ubuntu):
assignee: nobody → Matthias Niess (mniess)
affects: compiz-plugins-main → compiz-core
Changed in compiz-core:
assignee: Matthias Niess (mniess) → nobody
Changed in compiz:
status: New → Confirmed
Changed in compiz-core:
status: New → Confirmed
Changed in compiz:
assignee: nobody → Matthias Niess (mniess)

Just upgraded to 12.04 (mainly b/c I was hoping this bug'd be fixed). Nope, still there ;(

Daniel van Vugt (vanvugt) wrote :
Changed in compiz:
milestone: none → 0.9.8.0
status: Confirmed → In Progress
Matthias Niess (mniess) wrote :

@arne: until this is fixed please try shift+print. Gnome-screenshot now duplicates the functionality of the plugin.

@Matthias: by 'print', you mean pressing the 'prntscrn' button? If yes, then this won't help me -- my keyboard lacks that key...

Matthias Niess (mniess) wrote :

@arne: systemsettings -> keyboard -> shortcuts -> screenshot.

Changed in compiz:
milestone: 0.9.8.0 → 0.9.8.1
MC Return (mc-return) wrote :

This now seems to be fixed in trunk (see bug 1047788).

Matthias Niess (mniess) on 2012-09-08
Changed in compiz:
assignee: Matthias Niess (mniess) → nobody
Changed in compiz (Ubuntu):
assignee: Matthias Niess (mniess) → nobody
Changed in compiz:
milestone: 0.9.8.2 → 0.9.8.4
Changed in compiz:
assignee: nobody → Alex Korobkin (korobkin)
Changed in compiz:
milestone: 0.9.8.4 → 0.9.9.0
MC Return (mc-return) wrote :

This bug is definitely fixed in Compiz trunk, most probably in Quantal as well (as the GLES merge fixed it).

Zsolt Lauter (lauterzsolti) wrote :

The bug still exists in Quantal.

MC Return (mc-return) wrote :

@lauterzsolti: Is your selection rectangle opaque or transparent ?

@mc-return
mine is opaque

xubuntu 12.10
compiz 0.9.8.4
nvidia 310.14 (xorg edgers)

MC Return (mc-return) wrote :

@pqwoerituytrueiwoq:
Yes, that is bug 1047788 then. ;)
Question: Does it work for you with 0.9.8.4 (except for the transparency issue) ?

if by works you mean it saves a files yes, if you ment useful no
it saves a purple square image that is the correct dementions

MC Return (mc-return) wrote :

@all using Quantal and the unity-team staging PPA:

Please test if this specific bug is fixed in trunk for you also (overlay visible on screenshot).
Note that the fix for bug 1047788 (overlay opaque instead of being transparent) is not yet merged.

@all others affected:

Please do not use the staging PPA, it is not recommended, other bugs are likely to occur.

@pqwoerituytrueiwoq:

Probably some later fix, not yet in official stable repos, solved this issue then.
We will see for sure once we get more reports from others and test results here...

MC Return (mc-return) on 2012-10-22
Changed in compiz:
assignee: Alex Korobkin (korobkin) → MC Return (mc-return)
Changed in compiz-core:
assignee: nobody → MC Return (mc-return)
status: Confirmed → In Progress
MC Return (mc-return) wrote :

@all using Quantal and the unity-team staging PPA:

Please test if this specific bug is fixed in trunk for you also (overlay visible on screenshot).
The fix for bug 1047788 has been merged into lp:compiz at revision 3440, so the screenshot plug-in should now work 100% again.

problem still exist for me, just the screenshot it not 100% useless, bug 1047788 is fixed, now we are back to this bug

MC Return (mc-return) wrote :

@pqwoerituytrueiwoq: Please try to disable "Framebuffer object" in the OpenGL Plugin and retry making screenshots.

that worked :)
if you modify the plugin to act like the xfce4 screenshoter's area select i dont think that would need to be disabled
the xfce4 screenshoter shades the outside of the selected area instead of the inside

Changed in compiz:
importance: Undecided → Medium
Changed in compiz-core:
importance: Undecided → Medium
Changed in compiz:
milestone: 0.9.9.0 → 0.9.9.2
josthohad (johannes-t-hadsund) wrote :

@MC Return (mc-return) well yes that works. but tacking the picture i only see a blue non-transparent squarer above the area of the screen, from which I want to save the picture.

dgoosens (dgoosens) wrote :

I am very sorry if I ask a moronic question, but this blue overlay issue is driving me nuts.
I run Ubuntu 12.04 LTS .

Has this bug been solved ?
If so, why am I still encountering the issue ?
If I have to apply a patch or something, could someone clearly indicate me how I should to this or point me to some instructions about this ?

Thanks a lot in advance

MC Return (mc-return) wrote :

@josthohad: Well, seems you are using Quantal... The fix for bug 1047788 has been committed for 0.9.8 already, but not yet released. You could upgrade to Raring or wait for the next SRU: Compiz 0.9.8.8 "SRU-2".

@dgoosens: Well, it is just partially solved. On Raring it is solved, if support for "Framebuffer object" in the OpenGL Plugin is disabled, otherwise it still happens. Unfortunately no solution for 12.04 in sight yet.

Changed in compiz:
milestone: 0.9.9.2 → 0.9.10.0
MC Return (mc-return) wrote :

I am working on a solution for this problem, so that folks who want to use the screenshot plugin without having to turn off framebuffer object, will get the ability to do so.

Attached is a sneak preview of the new CCSM settings coming to screenshot :)
Note that this is WIP and might look slightly different until landing...

Please see the attachment, it is pretty self-explanatory.

MC Return (mc-return) wrote :

This is how the version, which will land in Compiz 0.9.10 looks now.

As you can see you not only are able to change colors and opacity of the screenshot selection outline and inside, but can also completely disable the rendering of it, so you will get perfect screenshots even with fbos turned on.

We are confident we can fully fix the "the-screenshot-selection-overlay-is-visible-on-screenshots-if-fbos-are-enabled" bug
soonish as well, but these options are nice to have anyways...

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:compiz at revision 3679, scheduled for release in compiz, milestone 0.9.10.0

Changed in compiz:
status: In Progress → Fix Committed
Adolfo Jayme (fitojb) on 2013-05-02
Changed in compiz (Ubuntu):
importance: Undecided → Low
Felipe (t3chn0k) wrote :

I'm a new user of Linux, and I'm using Ubuntu 12.04 LTS. I liked it very much, but this blue layer on my screenshots is really annoying.

Trying to fix this, as some other annoying bugs, I downloaded the 3684 revision tarball. Unfortunately, I don't know how to install it. I'm unpacking the tgz, creating a directory called "build" inside "0.9.10" and running "cmake ..", but I keep getting errors such as:

OpenGLESv2 not found
-- package 'gconf-2.0' not found
-- Could NOT find Lcov (missing: LCOV_EXECUTABLE GENHTML_EXECUTABLE)
-- Could NOT find gcovr (missing: GCOVR_EXECUTABLE)
-- checking for modules 'x11;xext;xdamage;xcomposite;x11-xcb;xrandr;xinerama;xext;ice;sm;libxml-2.0;libxslt;glib-2.0;gio-2.0;glibmm-2.4;libstartup-notification-1.0 >= 0.7'
-- package 'x11-xcb' not found
-- package 'libxml-2.0' not found
-- package 'libxslt' not found
-- package 'glibmm-2.4' not found

I would like to install the latest revision of Compiz to fix this bug (and others), can someone please help me?

Felipe (t3chn0k) wrote :

Ok, I could install gconf-2.0 by "apt-get install gconf-2.0-dev", but I still don't know how to install OpenGLESv2.

MC Return (mc-return) on 2013-05-25
Changed in compiz-core:
status: In Progress → Fix Committed
Stephen M. Webb (bregma) on 2013-07-23
Changed in compiz:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (70.8 KiB)

This bug was fixed in the package compiz - 1:0.9.10+13.10.20130822-0ubuntu1

---------------
compiz (1:0.9.10+13.10.20130822-0ubuntu1) saucy; urgency=low

  [ Sam Spilsbury ]
  * Bump version to 0.9.10

  [ Łukasz 'sil2100' Zemczak ]
  * Remove debian/patches/unity_support_test.patch:
    - Running the support test from compiz has bad side effects, from now
      on we run it from Xsession.d
  * Automatic snapshot from revision 3644

  [ Iven Hsu ]
  * Opacify: Only dim the windows above the active window.(LP:
    #1189374). (LP: #1189374)
  * KWD: Fix compile errors with KDE 4.11. The KWin developers made
    kdecorationbridge.h private. See:
    http://lists.freedesktop.org/archives/compiz/2013-March/003479.html
    (LP: #1193792). (LP: #1193792)

  [ Nikolay Martynov ]
  * When static switcher is enabled and has an option to show
    application icon turned on the icons are expected to be ~1/3 of a
    thumbnail (48px). Instead they are displayed in 512px size and
    completely cover everything. This change addresses this issue. See
    LP #1173914. (LP: #1173914, #1186426)

  [ BryanFRitt ]
  * Fixed the non-working Annotate 'Clear' Button. Moved this option's
    CCSM position upwards to keep the button shortcuts together. (LP:
    #1202907). (LP: #1202907)

  [ Mehrdad Afshari ]
  * Added "move window to previous monitor" feature to compiz Put
    plugin. (LP: #1178581)

  [ Hu Kang ]
  * gtk-window-decorator: destroy action menu when any of the (close,
    min, max) buttons on the title bar is pressed. (LP: #1101648)
  * Remove redundant src/logmessage/include/core/logmessage.h (LP:
    #1067246). (LP: #1067246)

  [ Steve Langasek ]
  * Fix for bug #763148 (with added test cases): when the desktop is
    resized, windows should stay on their original workspace. (LP:
    #763148)

  [ Brandon Schaefer ]
  * Unrevert 3728, fix failing tests. Change the behaviour of
    undecorating windows. Previously when a window was undecorated, we
    would shift it back to an appropriate position according to its
    gravity member. That behaviour was problematic because in the
    StaticGravity case the window has to just stay in the same place.
    But then if you had a window with StaticGravity which then did get a
    decoration and later removed it, it would be placed as though it was
    decorated and appear to be in the wrong place. The correct behaviour
    is to place all windows as though they have decorations, and then
    when decorations are removed, to move the window back to the corner
    as indicated in its gravity and then expand its size to cover the
    obscured regions no longer hidden because the decorations went away.
    (LP: #1165343).   1. Completely remove decorOffsetMove and other
    related code from      decor.cpp. Put the logic to handle the
    window->input () - window->border ()      placement offset inside of
    setWindowFrameExtents instead. Now the window      will always be
    offset from its original non-decorated position to the new
         decorated position, rather than having to guess between
    decoration sizes.   2. Make saveGeometry and restoreGeometry work
    relative to window->border ()      a...

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
Craig (craiglrobinson) wrote :

This seems to have reappeared :( :

>> dpkg -s compiz
Package: compiz
Status: install ok installed
Priority: optional
Section: x11
Installed-Size: 128
Maintainer: Ubuntu Developers <email address hidden>
Architecture: all
Version: 1:0.9.11.3+14.04.20150122-0ubuntu1
Provides: x-window-manager
Depends: compiz-core (>= 1:0.9.11.3+14.04.20150122-0ubuntu1), compiz-plugins-default (>= 1:0.9.11.3+14.04.20150122-0ubuntu1), compiz-gnome, debconf (>= 0.5) | debconf-2.0

Craig (craiglrobinson) wrote :

I should add that is appears to happen about 80% of the time. When I have enough patience I keep taking the screen shot until I manage to get it without the blue.

Jason Swaan (duyfken) wrote :

I agree completely with Craig's last comment, I get the exact same thing on Ubuntu MATE 15.04 when trying to select an area to grab using mate-screenshot

~$ dpkg -s compiz
Package: compiz
Status: install ok installed
Priority: optional
Section: x11
Installed-Size: 128
Maintainer: Ubuntu Developers <email address hidden>
Architecture: all
Version: 1:0.9.12.1+15.04.20150410.1-0ubuntu1
Provides: x-window-manager
Depends: compiz-core (>= 1:0.9.12.1+15.04.20150410.1-0ubuntu1), compiz-plugins-default (>= 1:0.9.12.1+15.04.20150410.1-0ubuntu1), compiz-gnome

Thomas Mayer (thomas303) wrote :

Same here for ubuntu 16.04. I use gnome-flashback (together with compiz).

Thomas Mayer (thomas303) wrote :

That's a regression in between of ubuntu 14.04 and ubuntu 16.04. In ubuntu 14.04 I never experienced this problem, while using this feature a lot (I had it up-to date before upgrading. And I had HES 14.04.4 installed).

Note that I just updated the very same machine from 14.04 to 16.04. So this is not hardware related (unless the change uses _new_ features of hardware). Tested on Dell Latitude E5510 bare metal.

It seems to affect other users as well:
https://m.reddit.com/r/techsupport/comments/4iysdw/gnomescreenshot_showing_orange_overlay_in/

Julian Haagsma (jhaagsma) wrote :

This is also a problem in 16.04 in gnome-flashback

Dimitrios Ntoulas (ntoulasd) wrote :

In 16.04 I think that the sceeenshot is taken to fast, before the selections box completely disappears.
So it includes the selection box in screenshot.

I think that a small delay, will fix the issue.

Eugene (schtaufenberg) wrote :

I have the same problem in linux mint 18.3 cinnamon

Kevin (kkd) wrote :

I solved the problem by enabling "Vertex buffer object" in OpenGL plugin using Compiz Config on Ubuntu 16.04.4 LTS.

To post a comment you must log in.