Ubuntu

1 pixel icons in notification-area-applet when compiz is the windows manager

Reported by nakki on 2011-04-20
This bug affects 335 people
Affects Status Importance Assigned to Milestone
GNOME Panel
Invalid
Undecided
Unassigned
Linux Mint
Undecided
Unassigned
Unity
High
Sam Spilsbury
skype
Invalid
Undecided
Unassigned
compiz (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Sam Spilsbury
Oneiric
Undecided
Unassigned
eiskaltdcpp (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned
Oneiric
Undecided
Unassigned
gnome-panel (Ubuntu)
Low
Unassigned
Natty
High
Unassigned
Oneiric
Low
Unassigned
unity (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

Binary package hint: gnome-panel

Install compiz 1:0.9.4+bzr20110531-0ubuntu1 from natty-proposed:
Test case:
                0) Use gnome-classic
                1) Open up qtdemo
                2) Navigate to Desktop -> Systray
                3) Run the demo
                4) The tray icon should appear and not be one px

I use gnome classic, not unity. Every time I open skype in notification area doesn't appear the skype's icon, only one green pixel!
See the image attached.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: gnome-panel 1:2.32.1-0ubuntu6.3
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Wed Apr 20 13:54:17 2011
ExecutablePath: /usr/lib/gnome-panel/notification-area-applet
GConfNonDefault:
 /apps/panel/general/applet_id_list=[applet_1,applet_0,indicator_applet_screen0,applet_2]
 /apps/panel/general/object_id_list=[object_0,menu_bar_screen0,browser_launcher_screen0,object_1,object_2]
 /apps/panel/general/toplevel_id_list=[top_panel_screen0]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110330)
ProcEnviron:
 SHELL=/bin/bash
 LANGUAGE=it_IT:en
 LANG=it_IT.UTF-8
SourcePackage: gnome-panel
UpgradeStatus: No upgrade log present (probably fresh install)

nakki (titibanjekistan) wrote :
Changed in gnome-panel (Ubuntu):
importance: Undecided → Low
Rocko (rockorequin) wrote :

It happens in unity as well, but not every time for me. Killing skype and restarting it seems to fix it. I think the icon has been scaled down to one pixel because that pixel acts like a the skype icon (ie you can get a menu and show/hide skype using the pixel).

Hadrien Dussuel (dbkblk) wrote :

I also have this bug. On classic gnome, with all non-indicators apps that use systray !

Hadrien Dussuel (dbkblk) wrote :

I've noticed that icons show up when using metacity and disappears when using compiz !

Zsolt Lauter (lauterzsolti) wrote :

Is this really a bug? Come on! I can't see that ugly green icon any more, all of the icons on the panel are monochrome (and there is this 1px for Skype and the buddy list comes up when you click on it). This one is the kindest bug I have ever seen!

Hadrien Dussuel (dbkblk) wrote :

To answer about that, Skype icon is ugly for sure but ALL THE APPS THAT DON'T USE INDICATORS ARE AFFECTED by this bug !

I thought this bug could be classified as "medium", not "low" because Classic gnome become unusable (and as a consequence, Ubuntu 11.04, because i don't like unity).

Millioner (lucky-bbb) wrote :

It is very annoying bug. It is not only for skype - all programs, which sets icons to area: qutim, qBittorrent, clementine, vlc, exaile, shutter and other. It really creates difficulties in my work.

zdmytriv (zdmytriv) wrote :

Same for me. Ubuntu Classic - no tray icons. Please fix it asap

FM33 (foxxm) wrote :

+1

Changed in gnome-panel (Ubuntu):
status: New → Confirmed
Michal Predotka (mpredotka) wrote :

I've just upgraded to Ubuntu 11.04 from 10.10 and I have this bug in Unity. Skype icon size is about 1px. See screenshot.

i confirm the comment #4

Changed in skype:
status: New → Invalid
summary: - No icon in notification-area-applet when I open skype
+ No icon in notification-area-applet
Changed in unity:
status: New → Invalid

Same for me. There isn't skype or VLC icons. Just one pixel. Icons shows well if applet is added to panel after application started.

Skripatch (enazarev) wrote :

That is strange but ktorrent shows well.

geezee (geezee-snooop) wrote :

Same here. Just one pixel for Skype and VLC. Pidgin shows up fine.

Andrey (waster2008) wrote :

Confirm the bug appearing with Compiz enabled for VLC, Skype, Qutim.

Sebastien Bacher (seb128) wrote :

bug #775324 suggest it's specific to Qt application, could it be a Qt issue?

summary: - No icon in notification-area-applet
+ 1 pixel icons in notification-area-applet for qt softwares

systray application from QT Demo has been tried in fluxbox Window manager and wordked properly.
systray application in lucid works properly with the gnome-panel provided. (the same binary copied).

Same bug here with Skype. Note that the first skype instance is pretty much invisible in the notification area but if I start another one the second works well (except the fact thatI get an error because there is already a skype running of course). I can then kill the first one and the the icon is still here.

Would be great to fix this important regression.

Same here on my (upgraded) natty, no icons for Clementine and Skype in the notification bar in Unity or Ubuntu classic. I *do* get icons when using "Ubuntu Classic (No effects)".

ii skype 2.2.0.25-1mave VOIP and instant messaging client
ii clementine 0.7.1-0ubuntu2 Modern music player and library organiser in

Kay (dtc-kay) wrote :

Mike Gerber, thanks for "no effects" mode hint. Works for me

Does No effects mean Metacity? Because I no longer have that tab since I installed ccsm.

Sebastian Bugiu: Yes, it's metacity.

Marcus Sundman (sundman) wrote :

At least switching compiz->metacity on-the-fly didn't make my skype icon bigger on-the-fly. Nor did switching back to compiz.

Changed in gnome-panel:
importance: Unknown → Critical
status: Unknown → Incomplete
Ben Stokes (ben-ukstokes) wrote :

Here's a crappy workaround for people on 'classic mode' that have the problem.

Launch skype
Open applications - terminal, and type: killall gnome-panel

This fixes the problem for Skype and Shutter, not sure about other apps that use the notification area.

Matias Pecchia (mabeett) wrote :

killall gnome-panel or killall notification-area-applet (then reload applet) will make the notification applet starts again.

But when you have more than 1 QT application ones have 1px icon and others the regular icon. (psi, hp-systray, skype, ktorrent...)

Drakej (drakej) wrote :

I don't get how they possibly missed this while testing 11.04 this issue was one of the first things I noticed within 10 minutes of use. That and the issue with multi display mode using ATI in Unity duping the gnome-panel. Seriously these issues are making me think it's time to switch distros for the first time in 5+ years.

Luca Manzari (manzariluca) wrote :

MAbeeTT thanks a lot for your suggestion, it works :D
Of course is not a fix, but at leaste skype is now usable!
I've made a "killall notification-area-applet" launcher on my panel, so I just have to hit it after I launch a qt application and everything works, that's how it looks

http://img577.imageshack.us/img577/9282/immaginerur.png

pretty, uh? :D

Drakej: I reported the bug like two or three weeks before the release so they knew about it. It's just taking time to fix it, who knows how complicated this may be? This is programming, sometimes you make great progress in a small amount of time, other times you have a stupid bug for weeks and cannot find it and fix it. Cut them some slack please. The release date was fixed and they weren't going to push back just for these rather small but annoying issues.

Teo Siang Hoe (andy1116) wrote :

Hey, I just switched from Windows to Ubuntu 12 hours ago so I might not know what I am doing.

I also have the same problem with the 1 pixel icon in the panel so I looked around and found this file. Run it in the terminal and select restore panel to default. Now my skype icon is showing perfectly. I hope it helps.

puzzled (puzzled) wrote :

Same here, made a bug report at bugzilla.gnome

Sebastien Bacher (seb128) wrote :

> I don't get how they possibly missed this while testing 11.04 this issue was one of the first things I noticed within 10 minutes of use.

There is nothing using notification icons in the default installation and only selected softwares are whitelisted there

@puzzled there is already an upstream bug here. https://bugzilla.gnome.org/show_bug.cgi?id=649176

Kay (dtc-kay) wrote :

Can anyone check this bug in gnome3 and post results to https://bugzilla.gnome.org/show_bug.cgi?id=649176 ?

Luca Tonin (luca-tonin) wrote :

I have the same bug:
Natty 11.04 64bit with Classical gnome

I think I found a solution.
The problem is the area dedicated to app icons: it is not resized automatically, when a new icon comes (for instance skype's icon).

on the top panel:
-> Unlock notification area applet
-> resize it manually
-> lock it again

It's still a bug but then it works.

BSA (b-s-a) wrote :

I have no problem in Ubuntu Classic, but in Ubuntu (Unity) cannot open psi-plus menu - no ANY icon in notification area are visible. Skype shows icon without problems in both modes.

Ubuntu 11.04, amd64, ATi Mobility Radeon 9600

I notice that now Vlc player icon is also a dot, a small 1px orange dot. it worked just fine yesterday. Should I report another bug or it's enough here? Check out the attachment to the left of the green Skype pixel.

We have already an upstream bug that links to this downstream one...

No new bugs are needed.

Sebastien Bacher (seb128) wrote :

if you have bugs about specific application i.e psi-plus check if a bug has been opened against those or unity and open an unity bug about whitelisting those,

Dmitri (lamukra) wrote :

Problem seems to be connected with compiz...
I have another workaround, for those with whom reading notification area to panel does not work.
Each time I open Skype I change Compiz to Metacity Window Manager - MWM - install compiz fusion icon from Software Center .
While Metacity is enabled REMOVE notification area from panel and add again and same with vlc.
Now you should see icons of skype and vlc (this was for when you started skype or vlc while compiz was selected a window manager)

other way around is to switch to MWM first then start Skype or VLC and go back to compiz

I know it is annoying, but this one works for me
Problem is that on one machine ( Radeon HD 5650) reading notification applet workd, on another (Radeon HD 4350) it does not...

So I am sticking with this workaround for now, I hope it will help someone and I hope this bug will be fixed ASAP

Changed in gnome-panel (Ubuntu Natty):
status: New → Confirmed
importance: Undecided → High
milestone: none → natty-updates
summary: - 1 pixel icons in notification-area-applet for qt softwares
+ 1 pixel icons in notification-area-applet for qt softwares (e.g. Skype)
tags: added: regression-release
Changed in unity:
status: Invalid → New
Changed in gnome-panel:
importance: Critical → Undecided
status: Incomplete → New
Changed in unity:
status: New → Invalid
Changed in eiskaltdcpp (Ubuntu Natty):
status: New → Invalid
Changed in eiskaltdcpp (Ubuntu Oneiric):
status: New → Invalid
summary: - 1 pixel icons in notification-area-applet for qt softwares (e.g. Skype)
+ 1 pixel icons in notification-area-applet when compiz is the windows
+ manager
Didier Roche (didrocks) on 2011-05-24
Changed in unity:
milestone: none → 3.8.14
status: Invalid → Triaged
Didier Roche (didrocks) on 2011-05-24
Changed in unity:
importance: Undecided → High
Changed in unity:
status: Triaged → Confirmed
72 comments hidden view all 152 comments

Sorry, that second link isn't formatted properly. It's supposed to be: http://blog.launchpad.net/general/of-bugs-and-statuses

Adam Łyskawa (a-lyskawa) wrote :

My bad, it was a mistake. I can't take it back though. I didn't know it works this way.

@Adam Łyskawa
I don't think this is a big problem. You can't change it back because Triaged status can only be set by members of the QA team. Didier Roche had marked it Triaged originally; I've contacted him to suggest that he do so again.

Well, I haved success. I compiled all compiz packages from Maverick in Natty.

THIS IS AN EXPERIMENTAL PROCEDURE - PLEASE GIVE ME FEEDBACK IN PRIVATE
NOTE THAT ***UNITY WILL BREAK***

0. Set Ubuntu classic as your session in GDM
1. Remove all packages related to compiz via synaptic (included libdecoration0, emerald, compizconfig etc)
2. Remove all unity related packages , note ubuntu-desktop will be removed after the step 1, don't worry.
3. Remove autoremovable packages (you can use synaptic)
4. add my PPA: ppa:guido-iodice/compiz-0.8.6-natty
5. update
6. install compiz, compiz-core, compiz-fusion-plugins-main, compiz-fusion-plugins-extra, compiz-fusion-plugins-unsupported (optional), compiz-gnome, compiz-plugins, compizconfig-backend-gconf, compizconfig-settings-manager, libcompizconfig0, libdecoration0, python-compizconfig, and, if you want, simple-ccsm ::: note, some of this packages are dependencies so they will be selected when you select the main package.
7. login/log out

It is very simple, but be care!!!

Rocko (rockorequin) wrote :

Rather than recompile compiz, why not just use Habib's suggestion in comment #42 to work around the problem? ie create a script called, say, '/usr/bin/skype-delayed' containing something like:

#!/bin/bash
sleep 15; skype

and then change your startup applications to run skype-delayed instead of skype.

I've found that a 15 second delay works better than 10 seconds, possibly because Unity takes so long to initialize.

Didier Roche (didrocks) on 2011-05-25
Changed in unity:
status: Confirmed → Triaged

On Tue, May 24, 2011 at 8:23 PM, Guiodic (Guido Iodice)
<email address hidden> wrote:
>> This is not MS Windows. You can use any DE, for example: KDE, LXDE,
> XFCE or any other environment made manualy
>
> You do miss the point. Ubuntu comes with GNOME, not KDE, LXDE etc. and
> gnome-panel and compiz are officially supported, not something in
> universe.
>
>> Second of all, DX have been looking into this issue.
>
> why no one in DX team asked a test or more info?

Because I can reproduce it and have been trying to figure out why it
happens. Give it some time.

>
>> we will re-prioritise to get this in for the next SRU.
> Thank you,.
>
> --
> You received this bug notification because you are a member of compiz
> packagers, which is subscribed to compiz in Ubuntu.
> https://bugs.launchpad.net/bugs/767095
>
> Title:
>  1 pixel icons in notification-area-applet when compiz is the windows
>  manager
>
> _______________________________________________
> Mailing list: https://launchpad.net/~compiz
> Post to     : <email address hidden>
> Unsubscribe : https://launchpad.net/~compiz
> More help   : https://help.launchpad.net/ListHelp
>

--
Sam Spilsbury

recko, the problem is not skype on startup.
I don't use skype on startup. The problem is ANY application using notification area whatever you launch them.

Adam Łyskawa (a-lyskawa) wrote :

Try launching and quitting app quickly. I can break it in less than a minute this way.

Tehnick (tehnick) wrote :

@tkoun
> how is your skype icon doing? mine I don't know because I can't see it!
> just to prove that as a matter of fact the funny critique that you call noise is better than just prrrrr noise...

I don't use Skype at all. Also I didn't see such bug in Debian. I am maintainer of eiskaltdcpp package from Debian and I subscribed to this bug report only because it affects to Ubuntu users of our program. Unfortunaly, I haven't got free time to install Ubuntu to find solution of this bug. But I believe that Ubuntu developers enough qualified to fix this defect in the nearest future.

PS: sorry for offtop.

tkoun (tkoun) wrote :

I confirm that Guiodic solution (post #116) works and it's easy to apply.

@UbuntuTeam:
unless there is some Unity related concern requiring compiz 0.9.4, PLEASE consider reverting to compiz 0.8.6 in natty (as per Guiodic's workaround) as solution to this crippling bug which seems not so easy to fix and leave compiz 0.9.4 for oneiric ocelot or platonic penguin

@ tkoun : thank you for the feedback.

@ tkoun & UbuntuTeam : I don't think Ubuntu can revert compiz to 0.8.6 version in Natty. This would break Unity that is the real new stuff in Natty. And, I think the bug is more trivial than we think, the difficult is to find it in the code.
But, definitively, it is related to compiz.

Neil J. Patel (njpatel) on 2011-05-25
Changed in unity:
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
Changed in compiz (Ubuntu Natty):
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
pitboss (pitboss2000) wrote :

Hey guys. I am also affected by the bug and I am using unity. A temporary workaround that works for me (at least with disappeared skype icon) is killing compiz: killall -9 compiz. Hope this is helpful to someone, before a fix is released.

@pitboss: this is a rough way . It is better to restart unity with

unity --replace

also

compiz --replace

should work.

Changed in unity:
status: Triaged → In Progress
Changed in compiz (Ubuntu Natty):
status: New → In Progress
Helge (helgesdk) wrote :

It seems the best workarounds so far is either:
a) Reverted to an older compiz as described in #116 (disables Unity).
b) Use the command >> killall -9 "notification-area-applet" << and reload the applet when prompted. Do it a couple of times and hopefully the icon will appear.

Using compiz --replace does not seem to be any more effective than workaround b) and it takes considerably more time.

I would really like to see this fixed in Ubuntu Classic as Unity is quite useless as long as I get severe graphical glitches when minimizing a window.

Sam Spilsbury (smspillaz) wrote :

Spent about 8 hours looking into this one, fix is here:

https://code.launchpad.net/~unity-team/compiz-core/compiz-core.fix_767095/+merge/62711

Still awaiting review, will most likely end up in the next SRU upload. Thanks for your patience.

That's great news, Sam. Can't wait to try it! Thanks for persevering :)

Helge (helgesdk) wrote :

Awesome, Sam - you're a star!

tkoun (tkoun) wrote :

great news!
Sam chasing this bugger for 8 hours is a great relief for all of us having regretted the upgrade to natty because of this.

thanx a lot!

Changed in unity:
milestone: 3.8.14 → 3.8.16
Didier Roche (didrocks) on 2011-05-30
Changed in unity (Ubuntu Oneiric):
status: New → In Progress

Thanks Sam, can you tell us when this will be available as an update from
the Natty repos? Sorry, I don't know your process so well.

It will go into -proposed in a week or two and then hit the main
archive once platform is happy that there are no regressions

On Mon, May 30, 2011 at 7:16 PM, Craig Esterhuizen
<email address hidden> wrote:
> Thanks Sam, can you tell us when this will be available as an update from
> the Natty repos?  Sorry, I don't know your process so well.
>
> --
> You received this bug notification because you are a member of compiz
> packagers, which is subscribed to compiz in Ubuntu.
> https://bugs.launchpad.net/bugs/767095
>
> Title:
>  1 pixel icons in notification-area-applet when compiz is the windows
>  manager
>
> _______________________________________________
> Mailing list: https://launchpad.net/~compiz
> Post to     : <email address hidden>
> Unsubscribe : https://launchpad.net/~compiz
> More help   : https://help.launchpad.net/ListHelp
>

--
Sam Spilsbury

Didier Roche (didrocks) wrote :

@Sam: it will go in -proposed as soon as you will deliver the updated compiz tarball for the SRU. I hope you can deliver it before a week

Changed in unity (Ubuntu Natty):
status: New → Invalid
Changed in unity (Ubuntu Oneiric):
status: In Progress → Invalid
Sam Spilsbury (smspillaz) wrote :

Test case:

0) Use gnome-classic
1) Open up qtdemo
2) Navigate to Desktop -> Systray
3) Run the demo
4) The tray icon should appear and not be one px

Changed in compiz (Ubuntu Natty):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-05-31
Changed in unity (Ubuntu Oneiric):
status: Invalid → In Progress
Changed in gnome-panel (Ubuntu Natty):
status: Confirmed → Invalid
Changed in gnome-panel (Ubuntu Oneiric):
status: Confirmed → Invalid
Changed in unity:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-06-01
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu Oneiric):
status: In Progress → Invalid
description: updated
Filip Milivojevic (zekica) wrote :

Any news on when will updated compiz packages be available?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.4+bzr20110606-0ubuntu1

---------------
compiz (1:0.9.4+bzr20110606-0ubuntu1) oneiric; urgency=low

  * New bug fix release:
    - Switcher window borders are not properly unmapped with
      (unity|gtk)-window-decorator (LP: #789580)
    - maximized window is displaced (LP: #772612)
    - Unity launcher gets visible while screensaver is active (LP: #771391)
    - 1 pixel icons in notification-area-applet when compiz is the windows
      manager (LP: #767095)
  * debian/patches/00_bzr_fix_apps_without_startupid.patch:
    - removed: upstream
 -- Didier Roche <email address hidden> Mon, 06 Jun 2011 16:18:08 +0200

Changed in compiz (Ubuntu Oneiric):
status: New → Fix Released

On Mon, Jun 6, 2011 at 7:50 PM, Launchpad Bug Tracker
<email address hidden> wrote:
> This bug was fixed in the package compiz - 1:0.9.4+bzr20110606-0ubuntu1
>
> ---------------
> compiz (1:0.9.4+bzr20110606-0ubuntu1) oneiric; urgency=low
>
>  * New bug fix release:
>    - Switcher window borders are not properly unmapped with
>      (unity|gtk)-window-decorator (LP: #789580)
>    - maximized window is displaced (LP: #772612)
>    - Unity launcher gets visible while screensaver is active (LP: #771391)
>    - 1 pixel icons in notification-area-applet when compiz is the windows
>      manager (LP: #767095)
>  * debian/patches/00_bzr_fix_apps_without_startupid.patch:
>    - removed: upstream
>  -- Didier Roche <email address hidden>   Mon, 06 Jun 2011 16:18:08 +0200
>
> ** Changed in: compiz (Ubuntu Oneiric)
>       Status: New => Fix Released

Is this referring to release to proposed or updates?

Accepted compiz into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Ivan Osadchii (tepoga) wrote :

Works good so far, wasn't able to trigger the bug after update. Thanks a lot!

tags: added: verification-done
removed: verification-needed

After installing the compiz packages from natty-proposed the icons appear. Thank you very much! :)

Tony_Harrison (toy-ruby) wrote :

Works perfectly! Thanks Sam and everyone else who got this released!

Omer P. (omerp) wrote :

I appreciate your work, Sam.

[rant]

But I think there's a separate lesson to be learned here: When such a major overhaul as was done to compiz is undertaken, making it impossible for users to use the previous version (as was the case here, where natty users *could not* go back to 0.8.6, until Guiodic made his wonderful PPA) is just bad practice.

There are numerous other problems with the current version of compiz, numerous other reasons to want to stay at 0.8.6 for now (for example, the newer version crashes every window decorator except the unity-window-decorator, such as emerald, etc.) -- this is not a knock on compiz or its developers, of course; no software is free of bugs, and early in the lifecycle of every new major overhaul, there will be its share of problems. Not only that, but I imagine some of the compatibility issues (e.g. emerald) are just as likely to be bugs in the interfacing modules, rather than bugs in compiz. But the fact that someone had to hack a solution to enable users to downgrade is just poor usability.

[/rant]

SebG (sebg) wrote :

Works for me, too. Icon shows up now.

However I just experienced a strange behavior in the xsane scan preview window. (Contents are drawn in window, two black approx 5px wide bars are drawn when mouse is moved in window, one horizontally, one vertically.)
Please ignore this if noone else can confirm this issue :-) it may be related to something else.

I am another happy user who can report that problem went away. Additionally it looks like it fixed a two other bugs and introduces one new (at least for me):
- So far i haven't noticed any gnome-applet crashes
- Emerald finaly works

There is one regression tough - when I switch to Emerald shadows that should appear under the right edge of each window are not displayed at all. Could you please advise to which package the bug should be raised - emerald or compiz?

Adam Łyskawa (a-lyskawa) wrote :

Now it works.
I even use Emerald decorator without problems (but it's hacked PPA version). The other bug with Compiz remained - when I switch window blur on and off - unity top panel breaks and requires unity --replace. But it's an old bug and it's probably display driver dependent.

Rocko (rockorequin) wrote :

The new version fixes it for me, and I haven't noticed any side effects. Once one of my notification-area icons was initially half-drawn after login (it was considerably bigger than one pixel, though) but a few seconds later it redrew itself correctly.

On Tue, Jun 7, 2011 at 9:12 AM, Marcin Dylewski
<email address hidden> wrote:
> I am another happy user who can report that problem went away. Additionally it looks like it fixed a two other bugs and introduces one new (at least for me):
> - So far i haven't noticed any gnome-applet crashes
> - Emerald finaly works
>
> There is one regression tough - when I switch to Emerald shadows that
> should appear under the right edge of each window are not displayed at
> all. Could you please advise to which package the bug should be raised -
> emerald or compiz?
>

Emerald has been unsupported for a very very long time.

> --
> You received this bug notification because you are a member of compiz
> packagers, which is subscribed to compiz in Ubuntu.
> https://bugs.launchpad.net/bugs/767095
>
> Title:
>  1 pixel icons in notification-area-applet when compiz is the windows
>  manager
>
> _______________________________________________
> Mailing list: https://launchpad.net/~compiz
> Post to     : <email address hidden>
> Unsubscribe : https://launchpad.net/~compiz
> More help   : https://help.launchpad.net/ListHelp
>

--
Sam Spilsbury

Sam Spilsbury (smspillaz) wrote :
Download full text (5.4 KiB)

On Tue, Jun 7, 2011 at 7:17 AM, Omer P. <email address hidden> wrote:
> I appreciate your work, Sam.
>
> [rant]
>
> But I think there's a separate lesson to be learned here: When such a
> major overhaul as was done to compiz is undertaken, making it impossible
> for users to use the previous version (as was the case here, where natty
> users *could not* go back to 0.8.6, until Guiodic made his wonderful
> PPA) is just bad practice.

Non-LTS releases are places where we land software that is coming out
of upstreams and polish it for our users. Of course, I understand that
there is a bar of stability that we aim to achieve, and of course, I
understand that we've fallen short (way short, and this is my fault as
the maintainer of compiz) of that bar, however that's not to say that
progress must be made, hard decisions have to be taken etc.

I'm not going to try to provide justification for why things were done
the way they were during the N cycle. It was difficult for everyone,
most notably because the entire stack was completely rewritten from
the ground up.

Providing packages for users to use during the 'classic' session of
the 0.8.x release series of compiz is something that we could have
done. However, I believe that the burden here far outweighs the
benefits of switching to 0.9.x completely. Shipping packages for 0.8.x
would mean that we'd have to distro-patch all of compiz 0.9 or 0.8 to
provide separate binary names in the packages. It also breaks upgrade
paths when users are upgrading and they need to maintain two sets of
plugins for 0.8 and 0.9. Finally, when we want to remove compiz 0.8
from the system, there's no sane way in apt that we could replace it
without introducing artificial conflicts.

Additionally, I think that shipping the 0.8.x series would have had
far more wide reaching effects than just having to put in the effort
to maintain an outdated stack. First of all, like we saw with
distributions that shipped KDE4 and KDE3 simultaneously, KDE4 was the
victim of an immediate backlash and everyone reverted back to KDE3.
The result of this is that KDE4 got hardly any end user testing and
this seriously stifled the development of KDE, since the developers
didn't know what users priorities were in the bug reports. Now even
today, only now are people starting to get used to KDE again. But the
fact that users were given an option to "opt-out" of that testing
means that the KDE project was seriously crippled in being able to
determine its priorities.

I don't think that compiz 0.9.x would have matured so quickly in the
same way that it did during the N cycle if we didn't receive the same
amount of testing that we did. Being able to sift through all the bug
reports showed us the actual usage patterns of normal users and allows
the developers to address those problems. For example, I don't use any
Qt apps which use the system tray (not a fan of skype) and I surefire
would not have noticed this bug (which is a race condition in the way
reparenting works in compiz) had users not tested it.

The moral of the story here is that if we provide users the option to
run away from the problems, then the discourse turns from "solutions
are cre...

Read more...

Omer P. (omerp) wrote :

Fair enough. Thanks, Sam, for taking the time to explain this.

(I also realize that the comments on a specific bug are a non-ideal place for this conversation, and I appreciate you addressing it here anyway.)

On Wed, Jun 8, 2011 at 7:14 AM, Omer P. <email address hidden> wrote:
> Fair enough. Thanks, Sam, for taking the time to explain this.
>
> (I also realize that the comments on a specific bug are a non-ideal
> place for this conversation, and I appreciate you addressing it here
> anyway.)
>

It prompted me to write a blog post about it anyways, since I think
this issue is much larger than just in compiz.

> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/767095
>
> Title:
>  1 pixel icons in notification-area-applet when compiz is the windows
>  manager
>
> Status in Desktop panel for GNOME:
>  New
> Status in The Linux Mint Distribution:
>  New
> Status in Skype:
>  Invalid
> Status in Unity:
>  Fix Released
> Status in “compiz” package in Ubuntu:
>  Fix Released
> Status in “eiskaltdcpp” package in Ubuntu:
>  Invalid
> Status in “gnome-panel” package in Ubuntu:
>  Invalid
> Status in “unity” package in Ubuntu:
>  Invalid
> Status in “compiz” source package in Natty:
>  Fix Committed
> Status in “eiskaltdcpp” source package in Natty:
>  Invalid
> Status in “gnome-panel” source package in Natty:
>  Invalid
> Status in “unity” source package in Natty:
>  Invalid
> Status in “compiz” source package in Oneiric:
>  Fix Released
> Status in “eiskaltdcpp” source package in Oneiric:
>  Invalid
> Status in “gnome-panel” source package in Oneiric:
>  Invalid
> Status in “unity” source package in Oneiric:
>  Invalid
>
> Bug description:
>  Binary package hint: gnome-panel
>
>
>  Install compiz 1:0.9.4+bzr20110531-0ubuntu1 from natty-proposed:
>  Test case:
>                  0) Use gnome-classic
>                  1) Open up qtdemo
>                  2) Navigate to Desktop -> Systray
>                  3) Run the demo
>                  4) The tray icon should appear and not be one px
>
>  I use gnome classic, not unity. Every time I open skype in notification area doesn't appear the skype's icon, only one green pixel!
>  See the image attached.
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 11.04
>  Package: gnome-panel 1:2.32.1-0ubuntu6.3
>  ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
>  Uname: Linux 2.6.38-8-generic x86_64
>  NonfreeKernelModules: nvidia
>  Architecture: amd64
>  Date: Wed Apr 20 13:54:17 2011
>  ExecutablePath: /usr/lib/gnome-panel/notification-area-applet
>  GConfNonDefault:
>   /apps/panel/general/applet_id_list=[applet_1,applet_0,indicator_applet_screen0,applet_2]
>   /apps/panel/general/object_id_list=[object_0,menu_bar_screen0,browser_launcher_screen0,object_1,object_2]
>   /apps/panel/general/toplevel_id_list=[top_panel_screen0]
>  InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110330)
>  ProcEnviron:
>   SHELL=/bin/bash
>   LANGUAGE=it_IT:en
>   LANG=it_IT.UTF-8
>  SourcePackage: gnome-panel
>  UpgradeStatus: No upgrade log present (probably fresh install)
>

--
Sam Spilsbury

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.4+bzr20110606-0ubuntu1~natty1

---------------
compiz (1:0.9.4+bzr20110606-0ubuntu1~natty1) natty-proposed; urgency=low

  * New bug fix release:
    - Switcher window borders are not properly unmapped with
      (unity|gtk)-window-decorator (LP: #789580)
    - maximized window is displaced (LP: #772612)
    - Unity launcher gets visible while screensaver is active (LP: #771391)
    - 1 pixel icons in notification-area-applet when compiz is the windows
      manager (LP: #767095)
  * debian/patches/00_bzr_fix_apps_without_startupid.patch:
    - removed: upstream
 -- Didier Roche <email address hidden> Wed, 01 Jun 2011 10:23:26 +0200

Changed in compiz (Ubuntu Natty):
status: Fix Committed → Fix Released
nakki (titibanjekistan) wrote :

Yes, I confirm that compiz (1:0.9.4+bzr20110606-0ubuntu1~natty1) natty-proposed solves the problem.

Helge (helgesdk) on 2011-07-07
Changed in gnome-panel:
status: New → Invalid
Changed in linuxmint:
status: New → Invalid
Displaying first 40 and last 40 comments. View all 152 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.