if window is touching the edge, compiz thinks it's on both desktops

Bug #762335 reported by LostinSpacetime on 2011-04-16
208
This bug affects 54 people
Affects Status Importance Assigned to Milestone
Compiz
Medium
Sam Spilsbury
Compiz Desktop Wall Plugin
Medium
Sam Spilsbury
Unity
Fix Released
Medium
Sam Spilsbury
compiz (Ubuntu)
Medium
Sam Spilsbury
compiz-plugins-main (Ubuntu)
Medium
Sam Spilsbury
unity (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: compiz

If I place a window on the edge of the virtual desktop (I'm using the snapping windows plugin) then, for the window manager, the window is present on both virtual desktops. This is a problem if one tries to switch to that window, from a neighbour desktop, just by clicking on the icon in the launcher for example. The window will get the focus, but the desktop will not switch.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: compiz 1:0.9.4+bzr20110415-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic-pae 2.6.38.2
Uname: Linux 2.6.38-8-generic-pae i686
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Ist ein Verzeichnis: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86 Kernel Module 270.41.03 Sat Apr 9 00:04:57 PDT 2011
 GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-8ubuntu3)
Architecture: i386
CompizPlugins: [core,detection,composite,opengl,decor,regex,dbus,imgjpeg,vpswitch,resize,imgpng,blur,titleinfo,obs,snap,gnomecompat,compiztoolbox,mousepoll,winrules,place,move,imgsvg,animation,expo,session,workarounds,wall,unitymtgrabhandles,ezoom,fade,switcher,scale,scaleaddon,unityshell]
CompositorRunning: compiz
Date: Sat Apr 16 02:04:06 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus: nvidia-current, 270.41.03, 2.6.38-8-generic-pae, i686: installed
GraphicsCard:
 nVidia Corporation GT215 [GeForce GT 240] [10de:0ca3] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:8328]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110330)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110330)
JockeyStatus:
 firmware:dvb_usb - Firmware für DVB-Karten (Proprietär, Aktiviert, In Benutzung)
 xorg:nvidia_current - Beschleunigter Grafiktreiber von NVIDIA (Proprietär, Aktiviert, In Benutzung)
MachineType: MICRO-STAR INTERNATIONAL CO.,LTD MS-7599
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=de_AT:de:en
 LANG=de_AT.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-2.6.38-8-generic-pae root=UUID=99b5f9c7-b1d2-4c4b-8021-8041a6155693 ro acpi_enforce_resources=lax quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-8.42-generic-pae 2.6.38.2
Renderer: Unknown
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
XorgConf:
 Section "Device"
  Identifier "Default Device"
  Option "NoLogo" "True"
 EndSection
dmi.bios.date: 09/04/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: V1.13
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 770-C45 (MS-7599)
dmi.board.vendor: MICRO-STAR INTERNATIONAL CO.,LTD
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: MICRO-STAR INTERNATIONAL CO.,LTD
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrV1.13:bd09/04/2010:svnMICRO-STARINTERNATIONALCO.,LTD:pnMS-7599:pvr1.0:rvnMICRO-STARINTERNATIONALCO.,LTD:rn770-C45(MS-7599):rvr1.0:cvnMICRO-STARINTERNATIONALCO.,LTD:ct3:cvr1.0:
dmi.product.name: MS-7599
dmi.product.version: 1.0
dmi.sys.vendor: MICRO-STAR INTERNATIONAL CO.,LTD
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu1
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu1
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Related branches

summary: - if window is on the edge, compiz thinks it's on both desktops
+ if window is touching the edge, compiz thinks it's on both desktops

This is happening very often since windows, when created, are frequently put on the edge of the desktop. The desktop doesn't even switch when changing between windows using the scale plugin or the appswitcher (alt+tab).

Timo Aaltonen (tjaalton) wrote :

possibly due to the "active" window area being larger than the visible one (for resizing).

Changed in compiz (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed

What Timo said sounds right. The problem persists even if a window is a few pixels away from the edge. I must give it a significant buffer (10px?) for it to only show on the appropriate desktop.

This effect also "wraps". I often have a terminal on the left edge of the left desktop (in a 2x2 arrangement), and a maximized browser on the right desktop. When I try to use the scrollbar of the browser (on the far right), I end up resizing the terminal by dragging its left edge into the desktop.

Changed in compiz (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in compiz:
importance: Undecided → Medium
Changed in unity:
importance: Undecided → Medium
Changed in compiz:
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in unity:
milestone: none → 4.26.0
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in unity:
status: New → In Progress
Changed in compiz:
status: New → In Progress
Changed in compiz-wall-plugin:
importance: Undecided → Medium
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → 0.9.6
status: New → Fix Committed
Changed in compiz:
status: In Progress → Fix Committed
Changed in unity:
status: In Progress → Fix Committed
Changed in compiz (Ubuntu):
status: Confirmed → Invalid
Changed in compiz-plugins-main (Ubuntu):
status: New → Fix Committed
assignee: nobody → Sam Spilsbury (smspillaz)

That was fast! :) I will test as soon as released.

Stephen Rees-Carter (valorin) wrote :

I'm still experiencing this bug, or something similar to this bug anyway.

I've reported it here: https://bugs.launchpad.net/unity/+bug/834248
(and an older bug report for natty: https://bugs.launchpad.net/unity/+bug/755842 )

Didier Roche (didrocks) on 2011-10-25
Changed in unity (Ubuntu):
status: New → Fix Committed
Omer Akram (om26er) on 2011-12-08
Changed in compiz-plugins-main (Ubuntu):
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Tyler Wagner (tyler) wrote :

Is this a duplicate of #755842? It seems to be the same root cause.

I'm not sure, but as the same developer has organized it already and it's fix commited, I'm just going to let it be. The one you mentioned also dealt with overlapping windows while this one is about edge windows.

Omer Akram (om26er) on 2012-09-25
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Changed in compiz-wall-plugin:
status: Fix Committed → Fix Released
Changed in compiz:
status: Fix Committed → Fix Released
Changed in compiz-plugins-main (Ubuntu):
status: Fix Committed → Fix Released

This bug is not fixed in 12.10. Do the following:

1. Place a window at the left edge of the screen.
2. Go to the the right workspace.
3. Click on the icon of the application on the launcher.
Nothing happens.

Changed in compiz:
status: Fix Released → Confirmed
Changed in compiz-wall-plugin:
status: Fix Released → Confirmed
Changed in unity:
status: Fix Released → Confirmed
Changed in compiz-plugins-main (Ubuntu):
status: Fix Released → Confirmed
Changed in unity (Ubuntu):
status: Fix Released → Confirmed
Daniel van Vugt (vanvugt) wrote :

Even if you find a bug is not fixed for you please don't ever revert from Fix Released. In that case you should log a new bug.

However most recently the bug was fixed as bug 1037164 so please look there.

Changed in compiz:
status: Confirmed → Fix Released
Changed in compiz-wall-plugin:
status: Confirmed → Fix Released
Changed in unity:
status: Confirmed → Fix Released
Changed in compiz-plugins-main (Ubuntu):
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Fix Released

roger that!

To post a comment you must log in.