alt-tab does not always work, instead is overridden by focus-follows-mouse

Bug #755156 reported by Kees Cook on 2011-04-09
86
This bug affects 18 people
Affects Status Importance Assigned to Milestone
compiz (Fedora)
Fix Released
Medium
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: compiz

The default window switcher under unity in compiz suffers from not being able to deal with focus-follows-mouse. (This is not a unity issue, I experience it with just plain compiz too.

Attached is a video demonstrating it. The point is that the terminal on the left will remain focused even after selecting the firefox window on the far right. It is not always reproducible.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: compiz 1:0.9.4+bzr20110407-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
DRM.card0.DVI.D.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1920x1200 1600x1200 1280x1024 1280x1024 1152x864 1024x768 1024x768 800x600 800x600 640x480 640x480 720x400
 edid-base64: AP///////wAQrBXwTDZDNCEUAQOANCB47h7Frk80sSYOUFSlSwCBgKlA0QBxTwEBAQEBAQEBKDyAoHCwI0AwIDYABkQhAAAaAAAA/wBDNTkyTTA4QzRDNkwKAAAA/ABERUxMIFUyNDEwCiAgAAAA/QA4TB5REQAKICAgICAgAGw=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Fri Apr 8 17:42:58 2011
DistroCodename: natty
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation 82Q35 Express Integrated Graphics Controller [8086:29b2] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Intel Corporation Device [8086:4f4a]
   Subsystem: Intel Corporation Device [8086:4f4a]
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-2.6.38-7-generic root=/dev/mapper/systemvg-root2lv ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-7.39-generic 2.6.38
Renderer: Unknown
SourcePackage: compiz
UpgradeStatus: Upgraded to natty on 2006-11-27 (1593 days ago)
XorgConf:
 Section "ServerFlags"
  Option "DontZap" "False"
 EndSection
dmi.bios.date: 09/22/2008
dmi.bios.vendor: Intel Corp.
dmi.bios.version: JOQ3510J.86A.0954.2008.0922.2331
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: DQ35JO
dmi.board.vendor: Intel Corporation
dmi.board.version: AAD82085-800
dmi.chassis.type: 3
dmi.modalias: dmi:bvnIntelCorp.:bvrJOQ3510J.86A.0954.2008.0922.2331:bd09/22/2008:svn:pn:pvr:rvnIntelCorporation:rnDQ35JO:rvrAAD82085-800:cvn:ct3:cvr:
version.compiz: compiz 1:0.9.4+bzr20110407-0ubuntu2
version.ia32-libs: ia32-libs 20090808ubuntu11
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.1-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu6
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu6

Kees Cook (kees) wrote :
Kees Cook (kees) wrote :

Watch the orange highlight on the terminal's "close" button to see that it remains focused when it shouldn't.

Mohsin Falak (fi8er1) on 2011-04-10
Changed in compiz (Ubuntu):
status: New → Confirmed

In compiz (not unity), I find this bad behaviour pretty reliable / reproducible, not occasional. Focus always follows original mouse position rather than selected window. (Marked my 779191 as duplicate)

Changed in compiz (Fedora):
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in compiz (Fedora):
status: Confirmed → Fix Released
Christian Reis (kiko) wrote :

I think this is a dupe of bug 762032 -- Kees, I think the reason you are able to focus the browser window to your left is that it the mouse cursor happens to appear inside it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.