compiz artifacts in chromium, xchat, opera... you name it

Bug #753369 reported by Fabien Tassin on 2011-04-07
82
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Sam Spilsbury
compiz (Ubuntu)
Medium
Sam Spilsbury
unity (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: compiz

Yesterday's compiz upgrade (1:0.9.4+bzr20110406-0ubuntu1) regressed in chromium, leaving artifacts behind.
See the video attached. 100% reproducible in various pages with selectors. I'm not sure it's limited to selectors or not though.

Tried to downgrade chromium a few versions to confirm it was not it, it's not. Previous versions that used to be fine now show the same artifacts.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: compiz 1:0.9.4+bzr20110406-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.41-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86 Kernel Module 270.30 Fri Feb 25 14:34:41 PST 2011
 GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-8ubuntu1)
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,gnomecompat,commands,vpswitch,resize,snap,mousepoll,regex,move,place,imgpng,session,animation,wall,workarounds,expo,ezoom,staticswitcher,fade,scale,unityshell]
CompositorRunning: compiz
Date: Thu Apr 7 12:18:24 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current, 270.30, 2.6.38-6-generic, i686: installed
 nvidia-current, 270.30, 2.6.38-8-generic, i686: installed
 nvidia-current, 270.30, 2.6.38-7-generic, i686: installed
GraphicsCard:
 nVidia Corporation G94 [GeForce 9600 GT] [10de:0622] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:827c]
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100331)
InstallationMedia_: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100331)
JockeyStatus: xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, In use)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/usr/bin/tcsh
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=03e1779a-d90a-4b59-8b03-2d1198aeb7cc ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-8.41-generic 2.6.38.2
Renderer: Unknown
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/04/2006
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F2
dmi.board.name: 945PL-S3
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF2:bd08/04/2006:svn:pn:pvr:rvnGigabyteTechnologyCo.,Ltd.:rn945PL-S3:rvrx.x:cvn:ct3:cvr:
version.compiz: compiz 1:0.9.4+bzr20110406-0ubuntu1
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.1-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu6
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu6

Related branches

Fabien Tassin (fta) wrote :
Fabien Tassin (fta) wrote :

it affects other products too. It's not limited to Chromium.
I see it with the context menu in xchat, like when i want to open a link in my browser (or copy that link to the buffer). Once the action is done, the menu remains on screen until something else refreshes the screen.

on irc, someone also reported it happens in Opera.

summary: - artifacts in chromium
+ compiz artifacts in chromium, xchat, opera... you name it
Didier Roche (didrocks) on 2011-04-08
Changed in compiz (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
Changed in unity:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
Hernando Torque (htorque) wrote :

I cannot reproduce the artifacts in chromium (the ones from the screencast), but all the other ones (so maybe that's two bugs here). See bug 754609 for some screenshots and a screencast.

At first I thought it does only happen with my Nvidia GPU, but I obviously did something wrong during testing - happens with Intel too.

Didier Roche (didrocks) on 2011-04-11
Changed in unity (Ubuntu):
status: New → Triaged
David Barth (dbarth) wrote :

The code submitted and merged as rev. 2748 in lp~unity-team/compiz/trunk does not resolve the issue and introduces regressions. See https://wiki.ubuntu.com/Unity/QA/TestLog#compiz_0.9.4+bzr20110414

Didier Roche (didrocks) on 2011-04-15
Changed in unity:
milestone: none → 3.8.10
Didier Roche (didrocks) on 2011-04-19
Changed in unity:
milestone: 3.8.10 → 3.8.12
David Barth (dbarth) wrote :

I cannot reproduce any of the artifacts anymore with chromium or other applicatoins with which I had noticed the issues previously. The main change being the stackattack removal (rev. 2751) and the additional xsync on XUngrabServer (rev. 2752).

David Barth (dbarth) on 2011-04-22
Changed in unity:
milestone: 3.8.12 → 3.8.14
importance: High → Medium
Changed in compiz (Ubuntu):
importance: High → Medium
Didier Roche (didrocks) on 2011-04-22
Changed in unity (Ubuntu):
importance: Undecided → Medium
Jan Claeys (janc) wrote :

I haven't seen this happen anymore in xchat for some time, so looks like it's fixed... (I'm running latest Compiz & Unity from -proposed, if that matters).

(I can't try Chromium right now because it crashes...)

David Robert Lewis (afrodeity) wrote :

Horrible artifacts in the top menu. Seems to be something to do with the global menu stripping out stuff from Chromium.

David Barth (dbarth) wrote :

Putting back in the backlog. Even if there are still rare occurences of the issue, I see no reproducible way of triggering the problem, to even start thinking about a resolution.

Changed in unity:
milestone: 3.8.14 → backlog
Changed in unity:
status: Triaged → Fix Released
Changed in compiz (Ubuntu):
status: Triaged → Fix Released
Changed in unity (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers