Grid plugin: Maximizing a window from left or right edge loses original size

Bug #753051 reported by Dylan McCall on 2011-04-06
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: compiz

Steps to reproduce:
* Drag a window to the right edge of the screen to vertically maximize it on that edge.
* Drag the title bar directly to the top edge without pulling it away from the right edge.
* Unmaximize the window.

Note that the window is returned to its size when it was vertically maximized, instead of its original size.

Right, it restores the most recent position of the window. Good catch.
However, this is a plugin-core interaction issue, and I'm not sure how
feasible it is to try and fix this in the grid plugin considering that
core is frozen. I can try to though.

On Thu, Apr 7, 2011 at 7:16 AM, Dylan McCall <email address hidden> wrote:
> Public bug reported:
>
> Binary package hint: compiz
>
> Steps to reproduce:
> * Drag a window to the right edge of the screen to vertically maximize it on that edge.
> * Drag the title bar directly to the top edge without pulling it away from the right edge.
> * Unmaximize the window.
>
> Note that the window is returned to its size when it was vertically
> maximized, instead of its original size.
>
> ** Affects: compiz (Ubuntu)
>     Importance: Undecided
>         Status: New
>
> --
> You received this bug notification because you are a member of compiz
> packagers, which is subscribed to compiz in Ubuntu.
> https://bugs.launchpad.net/bugs/753051
>
> Title:
>  Grid plugin: Maximizing a window from left or right edge loses
>  original size
>
> _______________________________________________
> Mailing list: https://launchpad.net/~compiz
> Post to     : <email address hidden>
> Unsubscribe : https://launchpad.net/~compiz
> More help   : https://help.launchpad.net/ListHelp
>

--
Sam Spilsbury

Alberto Russo (valix) wrote :

After today upgrade, this bug affects me.

Ubuntu Natty i386

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.4+bzr20110411-0ubuntu1

---------------
compiz (1:0.9.4+bzr20110411-0ubuntu1) natty; urgency=low

  * New upstream snapshot, including all 01_bzr* patch:
    - compiz crashed with SIGSEGV in PluginClassHandler<DecorWindow, CompWindow,
      0>::get() (LP: #743807)
    - Animation for Grid Previews is broken (LP: #754088)
    - Grid plugin: Maximizing a window from left or right edge loses original
      size (LP: #753051)
  * add 00_remove_printf.patch: remove debug printf
  * 02_add_debug_spewer_for_apport.patch:
    - refreshed
 -- Didier Roche <email address hidden> Mon, 11 Apr 2011 13:25:14 +0200

Changed in compiz (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers