"Show Desktop" Screen Edge doesn't work anymore after recent update

Bug #752687 reported by Bazon
112
This bug affects 23 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: compiz

1) release: 11.04
2) version: compiz 1:0.9.4git20110322-0ubuntu5
3) what I expect to happen: binding the function "show desktop" to the bottom tight screen edge corner works (as it did before)
4) what happened instead: it doesn't work any more. keyboard binding to super+d works still, but screen edge doesn't.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: compiz 1:0.9.4git20110322-0ubuntu5
ProcVersionSignature: Ubuntu 2.6.38-8.41-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Ist ein Verzeichnis: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 270.30 Fri Feb 25 14:34:55 PST 2011
 GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-8ubuntu1)
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,move,place,grid,resize,regex,animation,gnomecompat,imgpng,mousepoll,session,workarounds,animationaddon,wall,wobbly,expo,ezoom,staticswitcher,fade,scale,unityshell,scaleaddon]
CompositorRunning: compiz
Date: Wed Apr 6 18:31:47 2011
DistUpgraded: Log time: 2011-03-09 15:47:01.319601
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current, 270.30, 2.6.38-6-generic, x86_64: installed
 nvidia-current, 270.30, 2.6.38-8-generic, x86_64: installed
 nvidia-current, 270.30, 2.6.38-7-generic, x86_64: installed
GraphicsCard:
 nVidia Corporation GT218 [GeForce 210] [10de:0a65] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: CardExpert Technology Device [10b0:1401]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110308)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110308)
JockeyStatus: xorg:nvidia_current - Beschleunigter Grafiktreiber von NVIDIA (Proprietär, Aktiviert, In Benutzung)
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
ProcEnviron:
 LANGUAGE=de_DE:en
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=987314a0-2459-4100-a058-3474e6414faa ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-8.41-generic 2.6.38.2
Renderer: Unknown
SourcePackage: compiz
UpgradeStatus: Upgraded to natty on 2011-03-26 (11 days ago)
dmi.bios.date: 03/04/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.00
dmi.board.name: N68C-S UCC
dmi.board.vendor: ASRock
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.00:bd03/04/2010:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnN68C-SUCC:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.
version.compiz: compiz 1:0.9.4git20110322-0ubuntu5
version.ia32-libs: ia32-libs 20090808ubuntu11
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.1-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu6
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu6

Revision history for this message
Bazon (bazonbloch) wrote :
Revision history for this message
Sébastien Valette (sebastien-valette) wrote :

Same problem here. Actually, there does not seem to be any tab to activate edge/corners in compizconfig anymore. There was with ubuntu 10.10. Now only super+d triggers "show desktop".

Revision history for this message
Ayzen (ayzen-quwe) wrote :

I can confirm this bug too. I tried to bind left-right edges for switching between desktops, but that doesn't work in Ubuntu 11.04. I suppose it's a Unity bug...

Revision history for this message
Bazon (bazonbloch) wrote :

For me, it works again. whyever.

Revision history for this message
Ayzen (ayzen-quwe) wrote :

Have applied all updates, and still no luck with this... :(
Bazon, can you bind "left-right edges + left click" for switching between desktops (for example, in Rotate Cube). And try clicking on screen edges.

Revision history for this message
Simon Junga (simonthechipmunk) wrote :

Same problem with me.
Combining Screen Edge actions with mouse keys does not work for all Compiz plugins.
Firstly I suspected the grid plugin, because of the new win7 like functions, but disabling does not show any effect on this bug.
What's strange: Using Screen Edges without further keys does work!

Changed in compiz (Ubuntu):
status: New → Confirmed
Revision history for this message
Paulo J. S. Silva (pjssilva) wrote :

I have just upgraded to 11.10 (actually I did a clean install but preserved my /home). I am trying to configure LeftBottom for expo plugin and RightBottom for scale plugin. It works at first but once I logout and login again it stops working. If I erase the settings in CCSM and reconfigure the settings work again until next reboot.

Revision history for this message
Navaja (verschae) wrote :

Same problem here in 11.10.

Revision history for this message
iSlave (macslave) wrote :

Same problem here ater upgrading to 11.10 from 11.04. No problems on 11.04, though...

Revision history for this message
Alex (alevar) wrote :

I had this problem. However putting compiz into the startup applications solved it.

Name: Compiz
Command: bash -c "sleep 3; compiz --replace"

Saw this solution somewhere else, but cant find the link

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Fix Released according to comment #4. If you disagree, please join bug 858845 where the discussion continues.

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers