Ubuntu

compiz crashed with SIGABRT in raise() from abort() from __libc_message() from malloc_printerr() from _int_free()

Reported by Jonathan Almeida on 2011-04-04
This bug affects 212 people
Affects Status Importance Assigned to Milestone
Unity
High
Thomas Thurman
compiz (Ubuntu)
High
Canonical Desktop Experience Team
Oneiric
High
Canonical Desktop Experience Team
Quantal
High
Canonical Desktop Experience Team
unity (Ubuntu)
High
Canonical Desktop Experience Team
Oneiric
High
Canonical Desktop Experience Team
Quantal
High
Canonical Desktop Experience Team

Bug Description

You have landed here because you encountered some heap corruption causing your compiz to crash. Arguably your bug is different to this one, however as most heap corruption is untraceable with regular crash reports and stack traces, it is probably better to leave you bug as a duplicate of this.

We will endeavour to fix all possible sources of such heap corruption leading to such a crash over time.

Thanks for you understanding.

ORIGINAL DESCRIPTION:
Binary package hint: compiz

Here's an image link: http://img543.imageshack.us/i/screenshotdeesktop.png/

If I deactivate the driver it goes back to normal.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: compiz-core 1:0.9.4git20110322-0ubuntu5
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
NonfreeKernelModules: wl fglrx
Architecture: amd64
Date: Mon Apr 4 11:26:19 2011
DistroCodename: natty
DistroVariant: ubuntu
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110329.1)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110329.1)
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=en_CA:en
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcVersionSignature_: Ubuntu 2.6.38-7.39-generic 2.6.38
Signal: 6
SourcePackage: compiz
StacktraceTop:
 raise () from /lib/x86_64-linux-gnu/libc.so.6
 abort () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 free () from /lib/x86_64-linux-gnu/libc.so.6
Title: compiz crashed with SIGABRT in raise()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (<unknown>:1537): libindicator-WARNING **: Shortcut Group does not have key 'TargetEnvironment' falling back to deprecated use of 'OnlyShowIn' and 'NotShowIn'.
 (nautilus:1546): GConf-CRITICAL **: gconf_value_free: assertion `value != NULL' failed
 (<unknown>:2026): libindicator-WARNING **: Shortcut Group does not have key 'TargetEnvironment' falling back to deprecated use of 'OnlyShowIn' and 'NotShowIn'.
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu1

StacktraceTop:
 raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
 abort () at abort.c:92
 __libc_message (do_abort=2, fmt=0x7f34672423e0 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:189
 malloc_printerr (av=<value optimized out>, p=0x7f346747d208) at malloc.c:6283
 _int_free (av=<value optimized out>, p=0x7f346747d208) at malloc.c:4795

Changed in compiz (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
tags: added: compiz-0.9
visibility: private → public

After the beta release of 11.04, this issue has gone. It has only left the plymouth boot screen slightly 'blown up'.

Thanks !

Omer Akram (om26er) wrote :

the duplicate bugs are from unity 3.8.8 so its definitely not fixed, you may just not be facing the issue anymore.

Changed in compiz (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
status: New → Confirmed
summary: - compiz crashed with SIGABRT in raise() after activating ATI drivers
+ compiz crashed with SIGABRT in raise()
Didier Roche (didrocks) on 2011-05-31
Changed in unity:
importance: Undecided → Critical
Changed in compiz (Ubuntu):
importance: Medium → Critical
Changed in unity (Ubuntu):
importance: Undecided → Critical

Hmm, this sounds like an old bug, and possibly one related to the fglrx driver workaround that was released for Natty, and then reintroduced recently in Oneiric since it's still rquired.

I'll makr this bug invalid for now. If someone can still reproduce the issue, please reopen the bug.

Changed in unity:
status: Confirmed → Incomplete
Changed in compiz (Ubuntu):
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Changed in unity:
importance: Critical → High
Changed in compiz (Ubuntu):
importance: Critical → High
Changed in unity (Ubuntu):
importance: Critical → High
tags: added: bugpattern-needed
Evan Huus (eapache) wrote :

Apport pointed me here from bug #852826 which just happened to me on latest Oneiric. Reopening.

Changed in unity:
status: Incomplete → Confirmed
Changed in compiz (Ubuntu):
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
tags: added: oneiric
tags: added: iso-testing
Changed in compiz (Ubuntu):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Changed in unity (Ubuntu):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in compiz (Ubuntu):
status: Confirmed → Triaged
Changed in unity (Ubuntu Oneiric):
milestone: none → ubuntu-11.10
Changed in compiz (Ubuntu Oneiric):
milestone: none → ubuntu-11.10
tags: added: rls-mgr-o-tracking
David Barth (dbarth) wrote :

Ok, how can i reproduce that? What are the steps to reproduce please?

Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu Oneiric):
status: Triaged → Incomplete
Changed in compiz (Ubuntu Oneiric):
status: Triaged → Incomplete

I've been able to reproduce (bug 860317)

I opened a session and had a staking problem with the switcher, opened a terminal and entered "unity --reset" to see if it improved things.

Since I didn't run the command in the background and couldn't close the terminal, I opened another tab and entered the command again "unity --reset &"

I tested alt-tab again to check if it fixed the problem (it did, at least for that session) then closed both terminal tabs with CTRL+D, this crash happened on close of the terminal

Changed in compiz (Ubuntu Oneiric):
status: Incomplete → Confirmed
Changed in unity (Ubuntu Oneiric):
status: Incomplete → Confirmed
Didier Roche (didrocks) on 2011-09-27
Changed in unity:
status: Incomplete → Confirmed
milestone: none → 4.20.0
Didier Roche (didrocks) on 2011-09-27
tags: added: didrocks-oneiric-lilst
tags: added: didrocks-oneiric-list
removed: didrocks-oneiric-lilst
Thomas Thurman (marnanel) wrote :

Seeiing if I can reproduce it.

Changed in unity:
assignee: nobody → Thomas Thurman (marnanel)
Changed in unity:
status: Confirmed → Fix Committed
Changed in compiz (Ubuntu Oneiric):
status: Confirmed → Fix Committed
Changed in unity (Ubuntu Oneiric):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-09-29
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package unity - 4.20.0-0ubuntu1

---------------
unity (4.20.0-0ubuntu1) oneiric; urgency=low

  * New upstream release + cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #835259)
    - dash does not scroll down during keyboard navigation (LP: #852506)
    - compiz crashed with SIGSEGV in _XFreeEventCookies() (LP: #851472)
    - compiz crashed with SIGSEGV in g_object_unref() (LP: #847512)
    - compiz crashed with SIGSEGV in nux::WindowCompositor::MouseEventCycle()
      (LP: #831678)
    - compiz and X can disagree on the stacking order (LP: #845719)
    - compiz crashed with SIGSEGV in unity::dash::LensView::OnResultAdded()
      (LP: #855252)
    - CCSM crashes Unity (LP: #861643)
    - compiz crashed with SIGSEGV in PrivateWindow::addWindowStackChanges()
      (LP: #862115)
    - Touch - When dragging a window with a 3 touch, dragging to the top
      should show the maximize gesture preview. (LP: #750316)
    - compiz crashed with SIGABRT in raise() (LP: #750386)
    - Launcher - Spread should not affect the state of window (LP: #764673)
    - [UIFe] Add system setting icon to Launcher (LP: #764744)
    - compiz crashed with SIGABRT in raise() [Merely unchecking the Unity
      plugin is enough to crash Compiz...] (LP: #823386)
    - Launcher - does not hide if revealed from top 24px of the left edge of
      the screen (LP: #835989)
    - Clickable areas of previously active window remains on 'Show Desktop'
      (LP: #836325)
    - Cannot search for some apps in Dash (LP: #837075)
    - Dash - Search box cursor not responding correctly to focus (LP: #839704)
    - Multi-display: Application menu only showing on primary screen
      (LP: #845212)
    - Ellipsized values in size filter (LP: #851359)
    - (oneiric) dash result expansions don't display icons (LP: #854615)
    - run the wrong command if enter is hit before the view is refreshed
      (LP: #856205)
    - Java application windows cut-off/truncated/not displayed properly
      (LP: #857201)
    - compiz crashed with SIGSEGV in sigc::signal_base::impl() (LP: #831769)
    - Minimizing a window should switch focus to the windows underneath it
      (breaks restore) (LP: #859885)
    - Ratings filter allows ratings > 1.0 (LP: #861255)
    - Serious Unity problem stuck in spread when dragging icons back to the
      dash (LP: #862045)
    - Must use hardware keyboard to perform search for applications in Unity
      (LP: #739812)
    - Files lens should also search Downloads (LP: #748915)
    - The dash crosses the monitor boundary when resolution is 1152x864 or
      lesser width (LP: #765338)
    - Dash - dragging a file outside of the Desktop Dash should close the Dash
      (LP: #764641)
    - Text in Dash search text box overflows and doesn't crop with longer
      strings; RtL input starts in wrong place (LP: #834765)
    - Where the average background colour is either very light or dark, adjust
      this value to darken/lighten in order to preserve readability
      (LP: #837993)
    - Dash does not resize when I connect to an external display and mirror
      displays (LP: #83813...

Read more...

Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Changed in compiz (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
Brian Murray (brian-murray) wrote :

I reported bug 1045965, when running quantal, which was marked as a duplicate of this bug report.

Brian Murray (brian-murray) wrote :

I used 'apt-get autoremove', something I had not done after upgrading to Quantal, and then I was able to use compiz again.

tags: added: quantal
Yann Dìnendal (yannbreliere) wrote :

When I log in my session, unity is unresponsive for a few minutes, then crashes. Apport told me this was this bug report.

Brian Murray (brian-murray) wrote :

I actually now think this had to do with some autostart applications set in gnome-session-properties. I disabled a few and now can log in to my desktop and have it usuable on a regular basis.

Joey Stanford (joey) wrote :

I had the same problem. I tried the above suggestions without success. I also tried gconf-cleaner with no luck. I was finally able to fix this by doing an rm -rf .compiz* from my home directory and restarting lightdm.

mdmcginn (mcweb) wrote :

My Quantal installation still crashes after a minute. I tried 'apt-get autoremove' and renaming my autostart directory in /.conf/. Trying gconf-cleaner gets "Gtk-WARNING: cannot open display". My duplicate bug is https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1055002.

mdmcginn (mcweb) wrote :

See also https://bugs.launchpad.net/ubuntu/quantal/+source/unity/+bug/1045187
which says "Changed in unity: Status: Fix Committed → Fix Released"

mdmcginn (mcweb) wrote :

Recent upgrades may have fixed it. I've got Unity working right now. I did rm -rf .compiz* from my home directory and but was unable to restart lightdm: lack of permissions on org.freedesktop.

mdmcginn (mcweb) wrote :

Not fixed. Says Fix Released a year ago for Oneiric , so how can it be the same bug a year later in Quantal, unless it's a regression? Began when I switched to Quantal beta. Unity taskbar freezes then disappears and reappears a few times. Can open files by clicking on desktop items but windows have no minimize/maximize/close buttons.
Running "unity&" in a terminal is an effective workaround until I reboot.

Joey Stanford (joey) wrote :

Further to my comment #17: https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/750386/comments/17

I found that the as of Beta 2 that trick by itself doesn't work any longer. I have to rm -rf /home/<me>/.cache/compiz* and restart lightdm to get it to work. It's a reliable (for me) fix such that I created a bash script to do it and it works for me all the time.

Joey Stanford (joey) wrote :

I should also add this happens only on two of my machines (a system76 model and a zareason model) both with NVIDIA cards, but not my Thinkpad (Intel card).

Marius B. Kotsbak (mariusko) wrote :

Is this really fixed? It still shows up. See bug #1059847.

description: updated
summary: - compiz crashed with SIGABRT in raise()
+ compiz crashed with SIGABRT in raise() from abort() from
+ __libc_message() from malloc_printerr() from _int_free()
Joey Stanford (joey) wrote :

Apparently this is still happening to many people (including myself) and I'm getting pings and emails about the work-around that I've discovered. This is the script that I use. Don't trust me... research this yourself.

1) I login at lightdm and verify that launching anything from Unity causes a hang/crash/freeze.
2) I control-alt 1 to a console terminal and login
3) I run this script (replace "<me>" with your login name. I've called it "fixcompiz.sh"

#!/bin/sh
sudo service lightdm stop
rm -rf /home/me/.compiz*
rm -rf /home/me/.cache/.compiz*
sudo service lightdm start

4) when lightdm starts it forces me over to console 7 where I can just login and continue on my happy way with a working system.

I have to perform the above 4 steps on my two nvidia machines on every boot.

Angel Guzman Maeso (shakaran) wrote :

100% reproducible bug in quantal with several machines using even FOSS drivers with ati. Very annoning bug. The only temporal workaround that works for me was commented previously. Just my 2 cent using one command less:

sudo service lightdm stop
rm -rf ~/.compiz* ~/.cache/.compiz*
sudo service lightdm start

I just hope that this could be well fixed before to release quantal, raised to critical and don't appear more in next releases.

Daniel van Vugt (vanvugt) wrote :

All - Please try this to produce a better crash report that will help us find the root cause of the problem:

    env MALLOC_CHECK_=3 G_SLICE=always-malloc unity --replace

Angel Guzman Maeso (shakaran) wrote :

@vanvugt I try to produce a better crash report but it is difficult because when unity/compiz crash you don't windows borders for move windows and pressing keys for write doesn't write anything.

So, I boot the pc. Enter in a lightdm session. Then I open a terminal. I fire up google-chrome. Then unity crash. I go to tty with Alt+F1 and I write in terminal:

DISPLAY=:0 metacity --replace

This give me again windows border and keyboard write access pressing Alt+F7.

Then I write:
env MALLOC_CHECK_=3 G_SLICE=always-malloc unity --replace > unity-replace2.log

Unity crash. I did the same but from tty, and save the output in unity-replace.log.

I attach the logs and .xsession-errors that seems have a memory-map and backtrace.

Angel Guzman Maeso (shakaran) wrote :
Angel Guzman Maeso (shakaran) wrote :
Jim Scholfield (jgs-colorado) wrote :

This is making 12.10 beta nearly unusable for me. This happened following login and no other activity.

Joey Stanford (joey) wrote :

This still happens for me on two machines. I'm updated current on 2012-08-17.

Changed in compiz (Ubuntu Quantal):
status: Fix Released → Confirmed
tags: added: apport-request-retrace
Didier Roche (didrocks) wrote :

@joey, @jgs-colorado, @shakaran: can you please try again reporting the crash? This will open a new bug thanks to the new tag and we can get a fresh stacktrace.

Package: compiz-core 1:0.9.8.4-0ubuntu2
ProcCmdline: compiz --sm-client-id 10d3990f13aebb068c134885648837407100000201130040

tags: removed: apport-request-retrace
Joey Stanford (joey) wrote :

some updates...

I've attached two valgrind logs. The problem I had though was gnome-session was grabbing compiz.bin and executing directly when the crashes occurred so the valgrind logs I do have don't cover that exact case. However, they do show a bunch of errors.

I took a video of what's happening currently: http://socialcam.com/v/SC5Pte9r?type=email

Now I need to figure out how to stop gnome-session from directly executing compiz.bin (which is compiz just renamed because compiz is now a shell script wrapper for valgrind).

On 18/10/12 08:59, Joey Stanford wrote:
> some updates...
>
> I've attached two valgrind logs. The problem I had though was gnome-
> session was grabbing compiz.bin and executing directly when the crashes
> occurred so the valgrind logs I do have don't cover that exact case.
> However, they do show a bunch of errors.
>
> I took a video of what's happening currently:
> http://socialcam.com/v/SC5Pte9r?type=email
>
> Now I need to figure out how to stop gnome-session from directly
> executing compiz.bin (which is compiz just renamed because compiz is now
> a shell script wrapper for valgrind).
>
>
> ** Attachment added: "valgrind logs"
> https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/750386/+attachment/3401910/+files/valgrind.tar.gz
>

what PPAs do you have?

Joey Stanford (joey) wrote :

I restarted this with valgrind again and I can't get it crash when it's called from valgrind. As soon as I put the original compiz back it causes a freeze (which is not in the video). I did get two more grinds out of though in case they are of any help.

Joey Stanford (joey) wrote :

Just this one: deb http://dl.google.com/linux/talkplugin/deb/ stable main

Joey Stanford (joey) wrote :

fwiw, after the valgrind experiment I had to include another line item to my workaround... normally removing .compiz and .cache/compiz and restarting lightdm works. I added the compiz.desktop to keep it from picking up the test script I was using.

#!/bin/sh
sudo service lightdm stop
rm -rf /home/joey/.compiz*
rm -rf /home/joey/.cache/.compiz*
rm -rf /home/joey/.config/gnome-session/saved-session/compiz.desktop
sudo service lightdm start

Daniel van Vugt (vanvugt) wrote :

I don't think it's sensible to reopen/reuse this old bug for quantal. Heap corruption can be introduced by any manner of new logic. And the crash it produces will often have an old-looking call stack like this one.

Instead we should focus on finding the corruption at its source. To do that, please run:
    env MALLOC_CHECK_=3 G_SLICE=always-malloc unity --replace
And if/when it crashes, please log a new bug.

Daniel van Vugt (vanvugt) wrote :

Joey,

Please log a new bug about any crash you can produce with valgrind or otherwise.

Colan Schwartz (colan) wrote :

@vanvugt: How do we create new bugs with crash reports now that they go to errors.ubuntu.com instead of Launchpad? Is there a way to do this, or must we wait until both are supported? I haven't been able to create new bugs recently because of this problem.

Colan Schwartz (colan) wrote :

The bug I describe in my comment above is bug #1071092 .

Colan Schwartz (colan) wrote :

I was able to file a new bug with that debug mode on: bug #1096457

Joey Stanford (joey) wrote :

@vanvugt, I've started posting more diagnostics against @colan's bug of bug #1096457 since I see the same errors he is getting.

Daniel van Vugt (vanvugt) wrote :

Sorry, I'm not working on Compiz right now. Unsubscribing myself...

Joey Stanford (joey) wrote :

fyi, I fixed this by removing .config/dconf/user

Colan Schwartz (colan) wrote :

Confirming that removing that file worked for me as well. Can anyone else comment on whether this works or doesn't work? If it works in the general case, not just bug #1096457, we can update the problem description to include this workaround (as I did in the other ticket).

Jorge Juan (jjchico) wrote :

Removing .config/dconf/user also worked for me (so far).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers