compiz crashed with SIGSEGV in CompWindow::id()

Bug #746899 reported by Andreas Moog on 2011-04-01
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: compiz

I can reproduce this crash easily by starting amsn.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: compiz-core 1:0.9.4git20110322-0ubuntu5
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 270.30 Fri Feb 25 14:34:55 PST 2011
 GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-6ubuntu4)
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CrashCounter: 1
Date: Fri Apr 1 03:38:07 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus: nvidia-current, 270.30, 2.6.38-7-generic, x86_64: installed
ExecutablePath: /usr/bin/compiz
GraphicsCard:
 nVidia Corporation G96 [GeForce 9400 GT] [10de:0641] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Micro-Star International Co., Ltd. Device [1462:1571]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110302)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110302)
JockeyStatus: xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, In use)
Lsusb:
 Bus 002 Device 002: ID 046d:c00c Logitech, Inc. Optical Wheel Mouse
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 003: ID 05ac:1294 Apple, Inc. iPhone 3GS
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: MSI MS-7309
ProcCmdline: /usr/bin/compiz
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-7-generic root=UUID=79bf9a9f-934f-4adf-89cc-c7377f997e01 ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-7.39-generic 2.6.38
Renderer: Unknown
SegvAnalysis:
 Segfault happened at: 0x43bef0 <CompWindow::id()>: mov 0x58(%rdi),%rax
 PC (0x0043bef0) ok
 source "0x58(%rdi)" (0x00000058) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: compiz
StacktraceTop:
 CompWindow::id (this=0x0) at /build/buildd/compiz-0.9.4git20110322/src/window.cpp:4467
 CompScreen::handleEvent (this=0x25469f0, event=0x7fff2ea02180) at /build/buildd/compiz-0.9.4git20110322/src/event.cpp:1292
 PrivateCompositeScreen::handleEvent (this=0x26103e0, event=0x7fff2ea02180) at /build/buildd/compiz-0.9.4git20110322/plugins/composite/src/screen.cpp:102
 CompScreen::handleEvent (this=0x25469f0, event=0x7fff2ea02180) at /build/buildd/compiz-0.9.4git20110322/src/event.cpp:986
 PrivateGLScreen::handleEvent (this=0x26275e0, event=0x7fff2ea02180) at /build/buildd/compiz-0.9.4git20110322/plugins/opengl/src/screen.cpp:588
Title: compiz crashed with SIGSEGV in CompWindow::id()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lp lpadmin plugdev sambashare
dmi.bios.date: 03/10/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: V2.4
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: K9N6PGM2-V2 (MS-7309)
dmi.board.vendor: MSI
dmi.board.version: 2.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: MSI
dmi.chassis.version: 2.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrV2.4:bd03/10/2010:svnMSI:pnMS-7309:pvr2.0:rvnMSI:rnK9N6PGM2-V2(MS-7309):rvr2.0:cvnMSI:ct3:cvr2.0:
dmi.product.name: MS-7309
dmi.product.version: 2.0
dmi.sys.vendor: MSI
version.compiz: compiz 1:0.9.4git20110322-0ubuntu5
version.libdrm2: libdrm2 2.4.23-1ubuntu5
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu11
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu6

Andreas Moog (ampelbein) wrote :

Thank you for taking the time to report this crash and helping to make Ubuntu better. This particular crash has already been reported and is a duplicate of bug #747439, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

visibility: private → public
tags: removed: need-amd64-retrace
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers