gtk-window-decorator crashed with SIGSEGV in gwd_get_decor_frame()

Bug #740767 reported by Basile on 2011-03-23
336
This bug affects 72 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Medium
Sam Spilsbury

Bug Description

How reproduce:
 1) Bootup your natty
 2) Login {with,without} Unity. (= both "Ubuntu Desktop" and "Ubuntu Classic Desktop" can repro this)
 3) Open any application (e.g. gnome-terminal)
 4) Type [Alt]+[Space].
 5) So, crash(segv) gtk-window-deco. apport reports "Compiz crashed".

Actual result:
 - Compiz is crashed by segv, and does not show application-window menu.
 - dmesg said:
[ 1385.320113] gtk-window-deco[3021]: segfault at 0 ip 080527e8 sp bfba9fb0 error 4 in gtk-window-decorator[8048000+18000]

Expected result:
 - Open applicaton-window menu looks like "right-click at window-title".

=========================================================================
error!

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: compiz-gnome 1:0.9.4git20110322-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.38-generic-pae 2.6.38
Uname: Linux 2.6.38-7-generic-pae i686
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CurrentDmesg:
 [ 32.232906] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=0
 [ 109.692729] show_signal_msg: 6 callbacks suppressed
 [ 109.692735] gtk-window-deco[1536]: segfault at 0 ip 080527e8 sp bfea1440 error 4 in gtk-window-decorator[8048000+18000]
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: Off
 modes: 1280x800
 edid-base64: AP///////wBMo0JCAAAAAAAQAQOAHhN4Cof1lFdPjCcnUFQAAAABAQEBAQEBAQEBAQEBAQEB7hoAgFAgEDAMQDMAL74QAAAZAAAADwAAAAAAAAAAACOHAmQAAAAA/gBTQU1TVU5HCiAgICAgAAAA/gBMVE4xNDFXMS1MMDYKAGM=
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1920x1200 1600x1200 1280x1024 1280x960 1024x768 800x600 800x600 640x480
 edid-base64: AP///////wBMLT4ENDJZTSITAQMONCB4Ku6Ro1RMmSYPUFQjCACpQIGAgUABAQEBAQEBAQEBKDyAoHCwI0AwIDYABkQhAAAaAAAA/QA4PB5REQAKICAgICAgAAAA/ABTeW5jTWFzdGVyCiAgAAAA/wBITEpTODAwNDQxCiAgACc=
Date: Wed Mar 23 10:32:01 2011
DistUpgraded: Log time: 2011-03-22 20:20:32.772128
DistroCodename: natty
DistroVariant: ubuntu
ExecutablePath: /usr/bin/gtk-window-decorator
GraphicsCard:
 Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03) (prog-if 00 [VGA controller])
   Subsystem: Toshiba America Info Systems Device [1179:ff00]
   Subsystem: Toshiba America Info Systems Device [1179:ff00]
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta i386 (20100901.1)
InstallationMedia_: Ubuntu 10.10 "Maverick Meerkat" - Beta i386 (20100901.1)
MachineType: TOSHIBA SATELLITE M100
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdline: /usr/bin/gtk-window-decorator
ProcEnviron:
 LANGUAGE=ru_RU:en
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-7-generic-pae root=UUID=60daa7b6-c055-4c38-ad77-75f9263b94f7 ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-7.38-generic-pae 2.6.38
Renderer: Unknown
Signal: 11
SourcePackage: compiz
StacktraceTop:
 gwd_get_decor_frame ()
 ?? ()
 ?? () from /usr/lib/libgtk-x11-2.0.so.0
 gtk_menu_popup () from /usr/lib/libgtk-x11-2.0.so.0
 action_menu_map ()
Title: gtk-window-decorator crashed with SIGSEGV in gwd_get_decor_frame()
UpgradeStatus: Upgraded to natty on 2011-03-22 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors: (gnome-sound-recorder:1656): GStreamer-CRITICAL **: gst_implements_interface_cast: assertion `gst_element_implements_interface (GST_ELEMENT (from), iface_type)' failed
dmi.bios.date: 01/02/2007
dmi.bios.vendor: TOSHIBA
dmi.bios.version: V2.60
dmi.board.name: HAQAA
dmi.board.vendor: TOSHIBA
dmi.board.version: Null
dmi.chassis.asset.tag: *
dmi.chassis.type: 10
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnTOSHIBA:bvrV2.60:bd01/02/2007:svnTOSHIBA:pnSATELLITEM100:pvrPSMA0E-0SL01CRU:rvnTOSHIBA:rnHAQAA:rvrNull:cvnTOSHIBA:ct10:cvrN/A:
dmi.product.name: SATELLITE M100
dmi.product.version: PSMA0E-0SL01CRU
dmi.sys.vendor: TOSHIBA
version.compiz: compiz 1:0.9.4git20110322-0ubuntu1
version.libdrm2: libdrm2 2.4.23-1ubuntu5
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu11
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu6

Basile (basilio) wrote :

StacktraceTop:
 gwd_get_decor_frame (frame_name=0x943e9f8 "\320\332\066\t\001") at /build/buildd/compiz-0.9.4git20110322/gtk/window-decorator/frames.c:99
 position_action_menu (menu=0x9395948, x=0xbfea159c, y=0xbfea1598, push_in=0x9395a20, user_data=0x943e9f8) at /build/buildd/compiz-0.9.4git20110322/gtk/window-decorator/actionmenu.c:39
 gtk_menu_position (menu=0x9395948, set_scroll_offset=1) at /build/buildd/gtk+2.0-2.24.3/gtk/gtkmenu.c:4250
 IA__gtk_menu_popup (menu=0x9395948, parent_menu_shell=0x0, parent_menu_item=0x0, func=0x8059cd0 <position_action_menu>, data=0x943e9f8, button=1, activate_time=109661) at /build/buildd/gtk+2.0-2.24.3/gtk/gtkmenu.c:1593
 action_menu_map (win=0x943e9f8, button=1, time=109661) at /build/buildd/compiz-0.9.4git20110322/gtk/window-decorator/actionmenu.c:118

affects: ubuntu → compiz (Ubuntu)
Changed in compiz (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
visibility: private → public
Fumihito YOSHIDA (hito) wrote :

I can reproduce this bug at anytime. So I added description for reproducing the bug.

description: updated
description: updated
description: updated
Observer (dbvweb) wrote :

I can reproduce the bug too.

Metacity works ... but gtk-windows-decorator does not.

Fumihito YOSHIDA (hito) wrote :

@Observer, and reporters:

Today, I update to compiz* to 1:0.9.4git20110322-0ubuntu5, the problem goes away in my test environment.
I cannot reproduce this problem now. Could you please double-check it?

in /var/log/dpkg.log said:
2011-03-30 22:17:01 configure compiz-core 1:0.9.4git20110322-0ubuntu5 <none>
2011-03-30 22:17:01 status unpacked compiz-core 1:0.9.4git20110322-0ubuntu5
2011-03-30 22:17:01 status half-configured compiz-core 1:0.9.4git20110322-0ubuntu5
2011-03-30 22:17:01 status installed compiz-core 1:0.9.4git20110322-0ubuntu5
2011-03-30 22:17:01 configure compiz-plugins 1:0.9.4git20110322-0ubuntu5 <none>
2011-03-30 22:17:01 status unpacked compiz-plugins 1:0.9.4git20110322-0ubuntu5
2011-03-30 22:17:01 status half-configured compiz-plugins 1:0.9.4git20110322-0ubuntu5
2011-03-30 22:17:01 status installed compiz-plugins 1:0.9.4git20110322-0ubuntu5
2011-03-30 22:17:01 configure compiz-gnome 1:0.9.4git20110322-0ubuntu5 <none>
2011-03-30 22:17:01 status unpacked compiz-gnome 1:0.9.4git20110322-0ubuntu5
2011-03-30 22:17:01 status unpacked compiz-gnome 1:0.9.4git20110322-0ubuntu5
2011-03-30 22:17:01 status unpacked compiz-gnome 1:0.9.4git20110322-0ubuntu5
2011-03-30 22:17:01 status half-configured compiz-gnome 1:0.9.4git20110322-0ubuntu5
2011-03-30 22:17:01 status installed compiz-gnome 1:0.9.4git20110322-0ubuntu5

Observer (dbvweb) wrote :

@Fumihito,

Compiz on my machine seem to crash. This happened before today. I've retested after full update with the same crashes.
https://bugs.launchpad.net/ubuntu/+source/ibus/+bug/745821 <--- I just logged a new bug report.

Could be related?

Raul Dias (rsd) wrote :

I have a similar problem:

in dmesg:
[ 543.093184] do_general_protection: 42 callbacks suppressed
[ 543.093188] compiz[5601] general protection ip:7faa31063394 sp:7fff7e2bdf30 error:0 in libpthread-2.13.so[7faa3105a000+18000]

video card:
VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 02)

Before upgrading to 11.04 (from 10.10) never had an issue related to 3d.

Basically unity and gnome (ubuntu classic) does not have a window decorator and cant start one.

On ubuntu classic (no effects) works fine.

Also, under kde everything is extremely slow until special effects are switched off (ALT SHIFT F12).

Derek Muller (dsirus5) wrote :

I'm also experiencing the gtk-window-decorator crash whenever I hit alt+space, in Ubuntu Classic (Natty, fully updated). Compiz seems to work perfectly on my machine in every other regard.

A quick "compiz --replace" fixes things, but I find myself having to do this frequently -- I'm accustomed to using alt+space a lot!

"apt-cache showpkg" lists my compiz version as 1:0.9.4+bzr20110415-0ubuntu2.

@Mr. Yoshida: I hunted down the .debs of the 1:0.9.4git20110322-0ubuntu5 version of compiz, compiz-core et. al. you mentioned, uninstalled the ones currently in the repo, and installed your version. I still get the same behavior -- I even tried rebooting. If that version works flawlessly on your machine, yet I still get the gtk-window-decorator crash using it, what do you think could account for such a discrepancy?

Do you (or anyone else, for that matter) have any suggestions for possible workarounds, or should I just wait for the bug to be assigned and an official update released?

Fumihito YOSHIDA (hito) wrote :

Dear @Derek:

I can't reproduce this problem. I'm in no-win situation.
(Ah... that is bug squad-er habits, non-reproducible bug is our defeat!)

However, this much can be said: below results from my testing.
   - I can't encountered in any updates after comment#7.
   - I can't encountered in latest natty too.
   - Now, ubuntu-11.04-desktop-i386.iso (natty's release image) works fine too.

So, when you using latest natty, but the crash still continued, that indicate
another problem occured...probably.

For clarification, could you please check with ubuntu-11.04-desktop-i386.iso
live?

kiilo (kiilo.org) wrote :

mmmh

i replaced in compizConfig Settings Manager the preferences for WIndows decorations:

 "command" i replaced to

/usr/bin/compiz-decorator

works now here ... please can someone check?

kiilo

p54c (p54c) wrote :

yes @kiilo now it works.

replacing
"/usr/bin/compiz-decorator --replace" to "/usr/bin/compiz-decorator"
Works now again!

kiilo (kiilo.org) wrote :

so problem solved?

default setup should be changed then ...

kiilo

eldad (eldad-a) wrote :

@kiilo: solved for me!
in compizConfig Settings Manager the preferences for WIndows decorations:

 "command" should read:
 /usr/bin/compiz-decorator

cablop (cablop) wrote :

I upgraded today and i sadly see this wasn't fixed in the repos with the correct value for command in window decorator...
as a side note i found natty is more frustration than success...

cablop (cablop) wrote :

bug is still active, i set the options as kiilo said, but when you log out and log in the setting is reverted to the wrong one
also i think that works per user session, nor system-wide...

Roel Kramer (roel-koelkast) wrote :

Got this problem as well. It happens when i'm using pycharm for a while. Pycharm is written in java and i'm using the sun sdk.

Same problem here, typing [Alt]+[Space] crashes gtk-window-decorator.

Using /usr/bin/compiz-decorator in the "command" field of the WIndows decorations plugin in compiz settings manager fixes the problem.

Simon Woolf (semw) wrote :

The only thing I've found that works to get around the problem that the old, broken setting (gtk-window-decorator) replacing the correct one (compiz-decorator) whenever you log out & in is actually manually making /usr/bin/gtk-window-decorator a symlink to /usr/bin/compiz-decorator.

Not a particularly pretty workaround, but at least I can use window menus now...

Bill Vogel (hillbilly9) wrote :

Hello everyone, I've got the same problem when clicking on the window icon or typing ALT- space, here's the pertinent detail:
** (gtk-window-decorator:5033): CRITICAL **: Could not find frame info \xf0d\u0014 \u0001 in frame type table

The solution that worked for me was this setting for "Command" under the "Window Decoration" section of ccsm:
    /usr/bin/unity-window-decorator --replace

Although I'm not using unity at the moment, I just happened to notice, after a reboot, that it no longer crashed and this was the window decorator that was running instead of gtk-window-decorator.

Good luck..... -B

jchronakis (jchronakis) wrote :

Same problem here and it was fixed with the suggested setting:

Compiz Settings > Window decoration -> Command: /usr/bin/compiz-decorator

BTW, I am on "Ubuntu classic desktop".

Thank you for the fix, I can't live without the "Always on top" and "Always on visible workspace" :)

Ståle Tomten (staale) wrote :

Same problem on linux mint 11 and it was fixed with the /usr/bin/compiz-decorator command setting

Changed in compiz (Ubuntu):
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
Naftuli Kay (naftulikay) wrote :

Affected on Mint 11. Crashes on ALT+Space or on click of upper right menu icon.

Miki Barzilay (mb5000) wrote :

Confirm. Changing to /usr/bin/compiz-decorator and reboot solved the issue in LinuxMint 11.

Paul van Genderen (paulvg) wrote :

Instead of alt+space, I clicked the menu button. But the result was the same.

Changed in compiz (Ubuntu):
status: New → Confirmed
Daniel Apostolov (apostolov) wrote :

With Natty, alt-space worked for several weeks after installation then stopped, showing the symptoms as described above. Just clicking on the "use default" button on the right of the corresponding field in the compiz configuration manager restored the correct value into the box (/usr/bin/compiz-decorator). The change took effect after a X-windows restart with ctrl-alt-backspace. The modification persisted throughout x-restarts and logout/logins.

Also, here is the way I was able to reproduce the unintended modification of the Command value to its buggy state:

1. From Ubuntu Software Center install Compiz Fusion Icon.
2. Start the applet from Applications->System Tools->Compiz Fusion Icon.
3. Right-click on the blue arrowed box icon that has appeared in the notification area.
4. From Select window manager menu item select Metacity (I also have Openbox listed).
5. Check the Compiz Configuration Manager. The value of the Command field is now "gtk-windows-decorator --replace" .
6. From the Compiz Fusion Icon select back Compiz.
7. The value of the Command field does not return back to "/usr/bin/compiz-decorator" and alt-space keep crashing.

After several tries changing the windows manager stopped changing the Command value, until I restarted the Compiz Fusion Icon applet. After that I was able to reproduce it again.

cazacugmihai (cazacugmihai) wrote :

I have the same problem in Ubuntu 11.04. Thanks to @kiilo advice, I can fix the problem
replacing "/usr/bin/compiz-decorator --replace" to "/usr/bin/compiz-decorator".

I have the same problem in Linux Mint 11. Replaced command "gtk-windows-decorator --replace" with "/usr/bin/compiz-decorator", and this fixes it.

Fredrik Sjögren (fsj) wrote :

In Mint 11 I had to replace

gtk-window-decorator --replace

with

/usr/bin/compiz-decorator

Solved the issue.

Paul van Genderen (paulvg) wrote :

I never installed Compiz Fusion Icon and had this.

Confirmed #30 workaround.

Derek (bugs-m8y) wrote :

I'm encountering this as well.
Ubuntu 11.04 - unfortunately I can't use compiz-decorator since it calls the unity-decorator which does a number of annoying things, like thick shadows that look horrible on this graphics card and are slow to boot.

gtk-window-decorator at least is configurable from CCSM.

Derek (bugs-m8y) wrote :

Simple workaround I guess is just to disable alt-space :)

Ran into this same problem. I believe Daniel Apostolov (apostolov)'s post (#27) is what happened. The menu button worked fine. I experimented with Compiz Fusion Icon. The menu button stopped working. Resetting the window decorations command fixed the problem

João Valadares (jmvaladares) wrote :

Solved this, on 11.10, using:

sudo nvidia-xconfig --add-argb-glx-visuals -d 24

Fibonacci (fibonacci-prower) wrote :

Also affects Mint.

Rene Horn (the-rhorn) wrote :

Yes, comment #30 solved this for me too.

Can this become the default from now on then please?

Elijah Lynn (elijah-lynn) wrote :

Running 11.10 for few weeks now with no issues. Got this issue randomly and eventually did a dmsg - right after it crashed again and found the error that led me here.

I tried #36 first, then restarted, no go. Then went ahead and followed #30 and pow, right back up! Not even a restart was needed! I haven't restarted yet but hopefully it sticks!

Gnome Classic here, Replacing command "gtk-windows-decorator --replace" with "/usr/bin/compiz-decorator"solved this for me too, why isn't this the default yet?

Oliver Dungey (oliver-dungey) wrote :

I am running Ubuntu 12 with Unity with a dual monitor setup with nVidia graphics on my laptop. Whenever I start using the mouse scroll wheel on the secondary monitor compiz-decorator goes bang (not all apps cause the problem). As a temporary workaround I now fire up a terminal when it goes bang the first time and run this to keep it going forever:

while true; do compiz-decorator --sync; done;

Nasty hack but at least I can get on with work without having to continually restart it by hand.

I don't know why but if i change the alt+space shortcut to anything else like ctrl+f1 i don't have any issues. But before i was having all the same problems. Can someone else try this?

you can change the setting in "ccsm" then in the "general options" under the "key bindings" icon its call "Window Menu"

Thank you

Will Cooke (willcooke) wrote :

As part of the big bug clear up for 16.04 LTS I am marking this bug as Wont Fix.
These types of crasher are better handled by errors.ubutnu.com which can collate similar crash reports to help us identify persitent bugs rather than one-off crashes.
Sorry we are not able to help with this specific issue. If you are still experiencing this crash, please re-open the bug and add the tag "desktop-bugscrub-reopened". See https://wiki.ubuntu.com/BigDesktopBugScrub for more information.

Changed in compiz (Ubuntu):
status: Confirmed → Won't Fix
tags: added: desktop-bugscrub-autoclosed
To post a comment you must log in.