menu application appears behind window application

Bug #735162 reported by Le Gluon Du Net on 2011-03-14
82
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
compiz (Ubuntu)
Medium
Unassigned
xcompmgr (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: compiz

Hello,

after a certain time of using my computer, compiz becomes mad and make my menu appear in the background, behind the application, so I can't see it...
This is a transparent terminal where you can see the menu behind the window terminal:

http://img854.imageshack.us/my.php?image=tmphfm9tx.png

I do a after a compiz --replace to come back to a normal use.

Sometimes this problem comes with other trouble:

--> invisible window
--> close a window but a part of the window is still visible

Thanks for your help

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: compiz 1:0.9.4-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
Uname: Linux 2.6.38-6-generic i686
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] est un dossier: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86 Kernel Module 270.29 Wed Feb 23 16:16:53 PST 2011
 GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-5ubuntu3)
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,move,thumbnail,compiztoolbox,regex,place,imgpng,vpswitch,grid,gnomecompat,resize,screenshot,animation,wall,session,wobbly,expo,workarounds,ezoom,staticswitcher,fade,scale]
CompositorRunning: compiz
Date: Mon Mar 14 23:05:12 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current, 270.29, 2.6.38-6-generic, i686: installed
 vboxhost, 4.0.4, 2.6.38-6-generic, i686: installed
GraphicsCard: nVidia Corporation G92 [GeForce 8800 GT] [10de:0611] (rev a2) (prog-if 00 [VGA controller])
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110302)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110302)
JockeyStatus: xorg:nvidia_current - Pilote d'accélération graphique NVIDIA (Propriétaire, Activé, En cours d'utilisation)
MachineType: HP-Pavilion GX598AA-ABF a6221.fr
ProcEnviron:
 LANGUAGE=fr:en
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-6-generic root=UUID=16c9140c-d87b-4d72-97d9-c796f9b870f5 ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
Renderer: Unknown
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/27/2007
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 5.21
dmi.board.name: Leonite2
dmi.board.vendor: ASUSTek Computer INC.
dmi.board.version: 6.00
dmi.chassis.type: 3
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: 1111
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr5.21:bd07/27/2007:svnHP-Pavilion:pnGX598AA-ABFa6221.fr:pvr:rvnASUSTekComputerINC.:rnLeonite2:rvr6.00:cvnHewlett-Packard:ct3:cvr1111:
dmi.product.name: GX598AA-ABF a6221.fr
dmi.sys.vendor: HP-Pavilion
version.compiz: compiz 1:0.9.4-0ubuntu4
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu1
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu11
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu5

Le Gluon Du Net (legluondunet) wrote :
David Barth (dbarth) wrote :

Thanks for reporting the issue. Any idea on how we could reproduce the issue? Is there an window manager related operation that you're using frequently, or that you happen to do around the time the issue appears?

Changed in compiz (Ubuntu):
importance: Undecided → High
Le Gluon Du Net (legluondunet) wrote :

I don't know how to reproduce this bug, but it seems coming after play games who needs a huge amount of graphic power or if I'm working on a lot of open windows.
I have this bug with "nouveau" driver or "nividia" driver.

When it happens, i do a:

compiz --replace

and everything come back to normal.

Alex Launi (alexlauni) on 2011-03-29
Changed in compiz (Ubuntu):
status: New → Confirmed
importance: High → Medium
William (bthomas-akld) wrote :

I get this effect quite often with firefox. If I right click on a link sometimes (I haven't actually worked out when), the menu comes up in behind the application and you can't use it. In this case, I can get around it by minimising and restoring the firefox window, I don't need to restart compiz. I am using the AMD fglrx driver with an HD 3400.

barlennan (barlennan) wrote :

I use fvwm and xcompmgr -c instead of compiz, but I have been getting this problem very often since updating to Natty Narwhal. It seems to happen most often after unlocking the screen with gnome-screensaver. Once it does all application menus, including those of gnome-panel, emacs, and most annoyingly firefox, appear behind any other windows. This also happens with gnome-screensaver's login window. Many times I thought my laptop was frozen and rebooted before I realized I just had to type my password and hit return.

So it is not strictly a compiz bug, but its severity is much worse than "medium"!

KAMI (kami911) wrote :

This problem appears very often on my Ubuntu Natty based systems. I tested both nvidia and ati embedded systems. Bot of them able to produce this problem. I am attaching a screenshot of mine.

KAMI (kami911) wrote :

Bot system uses latest official (from the manufacturer) binary, prop. driver

Bryce Harrington (bryce) wrote :

[I gather xcompmgr actually has nothing to do with this bug; feel free to reopen with explanation if it does.]

Changed in xcompmgr (Ubuntu):
status: New → Invalid
barlennan (barlennan) wrote :

This should not have been marked invalid for xcompmgr. I have the bug, run xcompmgr, and do not run compiz.

Changed in xcompmgr (Ubuntu):
status: Invalid → Confirmed
Bryce Harrington (bryce) wrote :

Hey legluondunet,

You filed this bug report against natty, but I see it's still open and
doesn't appear to have much activity recently. So, now that oneiric
is released and stable, this may be a good point for you to upgrade
and re-test if this issue is still present there.

If it's solved in the new release and you think it's worth backporting
the fix, please indicate that. Or if having the fix in the new release
is good enough, feel free to close out the bug (or let us know and we'll
close it.)

If it's not solved, leave the bug report open. I can't promise we'll
get to it (we get way more bugs filed than we can usually get to), but
your testing and feedback can help out if and when we do.

Changed in xcompmgr (Ubuntu):
status: Confirmed → Incomplete
Download full text (5.1 KiB)

I can confirm that it still happens in Oneiric. It just happened to me now.

On Tue, Nov 8, 2011 at 10:01 PM, Bryce Harrington
<email address hidden> wrote:
> Hey legluondunet,
>
>
> You filed this bug report against natty, but I see it's still open and
> doesn't appear to have much activity recently.  So, now that oneiric
> is released and stable, this may be a good point for you to upgrade
> and re-test if this issue is still present there.
>
> If it's solved in the new release and you think it's worth backporting
> the fix, please indicate that.  Or if having the fix in the new release
> is good enough, feel free to close out the bug (or let us know and we'll
> close it.)
>
> If it's not solved, leave the bug report open.  I can't promise we'll
> get to it (we get way more bugs filed than we can usually get to), but
> your testing and feedback can help out if and when we do.
>
>
> ** Changed in: xcompmgr (Ubuntu)
>       Status: Confirmed => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/735162
>
> Title:
>  menu application appears behind window application
>
> Status in Compiz:
>  New
> Status in “compiz” package in Ubuntu:
>  Confirmed
> Status in “xcompmgr” package in Ubuntu:
>  Incomplete
>
> Bug description:
>  Binary package hint: compiz
>
>  Hello,
>
>  after a certain time of using my computer, compiz becomes mad and make my menu appear in the background, behind the application, so I can't see it...
>  This is a transparent terminal where you can see the menu behind the window terminal:
>
>  http://img854.imageshack.us/my.php?image=tmphfm9tx.png
>
>  I do a after a compiz --replace to come back to a normal use.
>
>  Sometimes this problem comes with other trouble:
>
>  --> invisible window
>  --> close a window but a part of the window is still visible
>
>  Thanks for your help
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 11.04
>  Package: compiz 1:0.9.4-0ubuntu4
>  ProcVersionSignature: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
>  Uname: Linux 2.6.38-6-generic i686
>  NonfreeKernelModules: nvidia
>  .proc.driver.nvidia.gpus.0: Error: [Errno 21] est un dossier: '/proc/driver/nvidia/gpus/0'
>  .proc.driver.nvidia.registry: Binary: ""
>  .proc.driver.nvidia.version:
>   NVRM version: NVIDIA UNIX x86 Kernel Module  270.29  Wed Feb 23 16:16:53 PST 2011
>   GCC version:  gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-5ubuntu3)
>  Architecture: i386
>  CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,move,thumbnail,compiztoolbox,regex,place,imgpng,vpswitch,grid,gnomecompat,resize,screenshot,animation,wall,session,wobbly,expo,workarounds,ezoom,staticswitcher,fade,scale]
>  CompositorRunning: compiz
>  Date: Mon Mar 14 23:05:12 2011
>  DistUpgraded: Fresh install
>  DistroCodename: natty
>  DistroVariant: ubuntu
>  DkmsStatus:
>   nvidia-current, 270.29, 2.6.38-6-generic, i686: installed
>   vboxhost, 4.0.4, 2.6.38-6-generic, i686: installed
>  GraphicsCard: nVidia Corporation G92 [GeForce 8800 GT] [10de:0611] (rev a2) (prog-if 00 [VGA controller])
>  InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110302)
>  Install...

Read more...

Matthew Meyer (osarusan) wrote :

It's happened to me a few times this month as well... I just noticed it after I played a video file, but I'm not sure if that was the cause of it or not. I only just noticed it now.

Happened to me with Precise 64bit and Intel HD3000 video. It usually happens about *half* the time I open a fullscreen game in wine.

Addendum: after many tribulations, I also am unable to consistently reproduce this issue.

Jay Bee (jay-bee) wrote :

I have the same problem after using the PC for a while.

As stated above "compiz --replace" in terminal solves this bug for me, too. Would be nice to not having to do that though...

Mike (bild85) wrote :

This is really annoying. Happens on both of my fully-updated 12.04 LTS workstations every-other week or so.

I tried compiz --replace but it isn't reliable. Sometimes leaves me with no window boarders and no way to recover the desktop. Best solution I found was to kill the desktop with:
Alt + PrintScr + K
Not elegant, but works.

$ uname -a
Linux hostname-l 3.2.0-030200rc5-generic #201112091935 SMP Sat Dec 10 00:36:07 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Michael Murphy (mmstick) wrote :

Happening here on my Ubuntu 13.04 system as well.

Amael (amael) wrote :

Hi all,

I also had this problem with Nvidia driver-310 (proprietary, tested), but I solved the problem by switching to nvidia-313-updates (proprietary) !

System :
   Ubuntu 13.04 System, 64 bits, GNOME WM.

$ uname -a
Linux XXXXX 3.8.0-26-generic #38-Ubuntu SMP Mon Jun 17 21:43:33 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

lshw extract about my graphic card :
...
     *-pci:0
          description: Host bridge
          produit: Core Processor DMI
          fabriquant: Intel Corporation
          identifiant matériel: 100
          information bus: pci@0000:00:00.0
          version: 11
          bits: 32 bits
          horloge: 33MHz
        *-pci:0
             description: PCI bridge
             produit: Core Processor PCI Express Root Port 1
             fabriquant: Intel Corporation
             identifiant matériel: 3
             information bus: pci@0000:00:03.0
             version: 11
             bits: 32 bits
             horloge: 33MHz
             fonctionnalités: pci msi pciexpress pm normal_decode bus_master cap_list
             configuration: driver=pcieport
             ressources: irq:16 portE/S:c000(taille=4096) mémoire:f6000000-f7efffff portE/S:e0000000(taille=335544320)
           *-display
                description: VGA compatible controller
                produit: GT218 [GeForce 210]
                fabriquant: NVIDIA Corporation
                identifiant matériel: 0
                information bus: pci@0000:01:00.0
                version: a2
                bits: 64 bits
                horloge: 33MHz
                fonctionnalités: pm msi pciexpress vga_controller bus_master cap_list rom
                configuration: driver=nvidia latency=0
                ressources: irq:16 mémoire:f6000000-f6ffffff mémoire:e0000000-efffffff mémoire:f2000000-f3ffffff portE/S:cc00(taille=128) mémoire:f7e00000-f7e7ffff
           *-multimedia
                description: Audio device
                produit: High Definition Audio Controller
                fabriquant: NVIDIA Corporation
                identifiant matériel: 0.1
                information bus: pci@0000:01:00.1
                version: a1
                bits: 32 bits
                horloge: 33MHz
                fonctionnalités: pm msi pciexpress bus_master cap_list
                configuration: driver=snd_hda_intel latency=0
                ressources: irq:17 mémoire:f7efc000-f7efffff
...

Available for any additional information you might need !

Amael

Michael Murphy (mmstick) wrote :

I haven't seen this bug occur in any installations over the last ~6 months so I'm assuming the bug was already fixed.

Changed in xcompmgr (Ubuntu):
status: Incomplete → Fix Released
Changed in compiz:
status: New → Fix Released
Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
Nieke Aerts (nieke-a) wrote :

I still have the problem. Seems to appear when I have a lot of windows open and I have only had it when at least one of them is maximized.

Nieke Aerts (nieke-a) wrote :

I guess I cannot edit the message.
I should have added:
Distributor ID: Ubuntu
Description: Ubuntu 14.04.1 LTS
Release: 14.04
Codename: trusty

Daniel Miller (peaches491) wrote :

Same thing here on 12.04 (old, I know)

Linux 3.13.0-39-generic #66~precise1-Ubuntu SMP Wed Oct 29 09:56:49 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Unity 5.20.0
Compiz 0.9.7.12

Let me know if you guys need any more data! I've just confirmed that the previous 'compix --replace' works, though it's a pain. It screws up all of my workspace layouts.

Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers