unity-window-decorator doesn't start on secondary X session

Bug #730495 reported by Gunnar Hjalmarsson on 2011-03-07
84
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Loïc Molinari
compiz (Ubuntu)
High
Sam Spilsbury
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gdm-guest-session

When in a guest session, Zenity generated GTK+ dialogs are displayed without the title bar. While the title is displayed on the top desktop panel when in Unity (see attachment), it's not shown at all on the classic desktop.

Gunnar Hjalmarsson (gunnarhj) wrote :
Martin Pitt (pitti) wrote :

This isn't actually specific to the guest session. I also get this when running another "real user" session. .xsession-errors complains that unity-window-decorator fails to start because it cannot open display :0.0. This is not surprising, as :0.0 is my primary X session of my own user, and the current X $DISPLAY is :1 or :2. When I start unity-window-decorator in a terminal, it works just fine, though.

Didier, could that be related to the startup checks which session to use? Does anything hardcode display :0 there? I can't see anything obvious in 01_unity_window_decorator.patch, but this issue reproduces perfectly well for me as well.

summary: - Title bar missing in GTK+ dialogs
+ unity-window-decorator doesn't start on secondary X session
affects: gdm-guest-session (Ubuntu) → compiz (Ubuntu)
Changed in compiz (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Didier Roche (didrocks) wrote :

Hum, it's not the startup checks (it doesn't act on any variable (yet)) and just run compiz, it doesn't check the DISPLAY set or whatever.

I rechecked the compiz decorator wrapper (/usr/bin/compiz-decorator) which didn't change apart from a s/gtk-/unity- decorator by default and it doesn't hardcode that. I'll get over it, (or if sam have any idea) next week once all the racy decorator crashes fixed.

tags: added: compiz-0.9 unity
Gunnar Hjalmarsson (gunnarhj) wrote :

A couple of weeks ago I filed bug 721150, and that issue was probably not guest session related either then. Just mention it for the case it may help you detect the problem.

Didier Roche (didrocks) on 2011-03-07
tags: added: unity-priority
Didier Roche (didrocks) on 2011-03-08
tags: added: dids-top-ten
John S. Gruber (jsjgruber) wrote :

From a little extra testing:

Running a unity desktop, in the secondary session, when I issue "unity-windows-decorator --replace &" it works. If I issue "unity --reset &" it doesn't work, nor does running "compiz --replace &"

Running a classic desktop in the secondary session there is no window decoration started as well.

In the classic case running "compiz --replace &" *does* work to start the window decorator, as does "unity --reset &" and unity-windows-decoorator --replace &".

spontex (spontex) wrote :

I just learned the existence of this unity-windows-decorator reading this Launchpad page! I only saw this decorator during the first few days of my 11.04 installation and not anymore since then.
This makes Unity much more usable!

Should unity-windows-decorator be placed in the startup applications?

spontex (spontex) wrote :

By the way, I experienced this bug on my main session.

David Barth (dbarth) on 2011-03-28
tags: removed: unity-priority
David Barth (dbarth) on 2011-03-28
Changed in unity:
importance: Undecided → High
status: New → Confirmed
assignee: nobody → Loïc Molinari (loic.molinari)
milestone: none → 3.8.2
Didier Roche (didrocks) on 2011-03-29
Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-04-01
Changed in unity:
milestone: 3.8.2 → 3.8.4
Changed in compiz (Ubuntu):
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
Anders Kaseorg (andersk) wrote :

This isn’t specific to unity-window-decorator. If you go to ccsm → Effects → Window Decoration and change the command to /usr/bin/gtk-window-decorator, that fails in the same way. ~/.xsession-errors has the line

(gtk-window-decorator:19510): Gtk-WARNING **: cannot open display: :0.0

Didier Roche (didrocks) on 2011-04-06
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Changed in compiz (Ubuntu):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-04-06
Changed in unity:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.4+bzr20110406-0ubuntu1

---------------
compiz (1:0.9.4+bzr20110406-0ubuntu1) natty; urgency=low

  * new upstream bzr tarball:
    - display/size problems with xterm (LP: #748137)
    - fix crashes on tcl/tk applications (LP: #741074, #747439)
    - fix grab on compose keys (LP: #747323)
    - resync stack at regular interval to avoid invisible windows
      (LP: #723014, #743011, #736876, #740465, #684590)
    - fix weird order in alt + tab (LP: #175874)
    - fix crash in gitk (LP: #743011, #741074)
    - avoid compiz detection by fglrx driver (LP: #740298)
    - Wrong window moves (LP: #741656, #743634)
    - Unity Grid is broken for multi-monitor setups (LP: #709221)
    - Feature Freeze Exception: Animation for Grid Plugin Previews (LP: #744104)
    - unity-window-decorator crashed with SIGSEGV in gdk_window_get_events()
      (LP: #725284)
    - fix xterm (LP: #692463)
    - start the decorator on a secondary screen (LP: #730495)
  * debian/patches/090_git_fix_new_invisible_windows.patch,
    debian/patches/100_bump_core.h.patch:
    - upstreamed
  * debian/patches/01_unity_window_decorator.patch
    debian/patches/085_add_grid_plugin.patch:
    - in bzr upstream tarball
 -- Didier Roche <email address hidden> Wed, 06 Apr 2011 19:37:45 +0200

Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-04-07
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments