unity-window-decorator crashed with SIGSEGV in gdk_window_get_events()

Bug #725284 reported by Mario Vukelic on 2011-02-25
514
This bug affects 90 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Loïc Molinari
compiz (Ubuntu)
High
Unassigned
Natty
High
Unassigned
unity (Ubuntu)
High
Unassigned
Natty
High
Unassigned

Bug Description

Binary package hint: compiz

I didn't do anything, just read a website in firefox, suddenly compiz crashed.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: compiz-gnome 1:0.9.4-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic x86_64
NonfreeKernelModules: wl
Architecture: amd64
Date: Fri Feb 25 22:43:07 2011
ExecutablePath: /usr/bin/unity-window-decorator
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100131)
ProcCmdline: /usr/bin/unity-window-decorator
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=de_DE.utf8
 LC_MESSAGES=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f30a887d41e <gdk_window_get_events+14>: mov (%rbx),%rdx
 PC (0x7f30a887d41e) ok
 source "(%rbx)" (0xffffffff98009000) not located in a known VMA region (needed readable region)!
 destination "%rdx" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: compiz
StacktraceTop:
 gdk_window_get_events () from /usr/lib/libgdk-x11-2.0.so.0
 event_filter_func ()
 ?? () from /usr/lib/libgdk-x11-2.0.so.0
 ?? () from /usr/lib/libgdk-x11-2.0.so.0
 ?? () from /usr/lib/libgdk-x11-2.0.so.0
Title: unity-window-decorator crashed with SIGSEGV in gdk_window_get_events()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Mario Vukelic (mario-vukelic) wrote :
Mario Vukelic (mario-vukelic) wrote :

Right, and I'm running a Classic session with effects, so I'm a bit surprised about the "unity-window-decorator" in the automatic report title. Running the nouveau drivers on a MacBook Pro 5,4

StacktraceTop:
 IA__gdk_window_get_events (window=0xffffffff98009000) at /build/buildd/gtk+2.0-2.24.1/gdk/gdkwindow.c:7346
 event_filter_func (gdkxevent=0x7fff6b1ccb60, event=<value optimized out>, data=<value optimized out>) at /build/buildd/compiz-0.9.4/unity/unity_window_decorator/src/events.c:875
 gdk_event_apply_filters (display=0x16b0000, event=0x19b95d0, xevent=0x7fff6b1ccb60, return_exposes=0) at /build/buildd/gtk+2.0-2.24.1/gdk/x11/gdkevents-x11.c:356
 gdk_event_translate (display=0x16b0000, event=0x19b95d0, xevent=0x7fff6b1ccb60, return_exposes=0) at /build/buildd/gtk+2.0-2.24.1/gdk/x11/gdkevents-x11.c:927
 _gdk_events_queue (display=0x16b0000) at /build/buildd/gtk+2.0-2.24.1/gdk/x11/gdkevents-x11.c:2310

Changed in compiz (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
tags: added: compiz-0.9
visibility: private → public
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.4-0ubuntu2

---------------
compiz (1:0.9.4-0ubuntu2) natty; urgency=low

  * Force libdecoration0 to have the same version than compiz-plugins
  * debian/patches/01_unity_window_decorator.patch
    - fix a crash in unity-window-decorator (LP: #726063, #725284, #726101)
  * Backport some patches from upstream to fix other crashes and bring
    support to the unity plugin (LP: #726702)
  * debian/compiz-core.install:
    png are now installed in /usr/share/compiz
  * add the future unity mt plugin by default
 -- Didier Roche <email address hidden> Mon, 28 Feb 2011 20:51:00 +0100

Changed in compiz (Ubuntu):
status: New → Fix Released
Alex Launi (alexlauni) on 2011-03-03
Changed in unity:
status: New → Fix Released
Changed in unity (Ubuntu):
status: New → Fix Released
Andreas Moog (ampelbein) wrote :

I get this bug on about 30% of cases when I move windows to another workscreen by right clicking the menubar and selecting "Move to Workspace X".

Changed in compiz (Ubuntu):
status: Fix Released → New
Mauricio Pretto (pretto) wrote :

Just got this bug today , all natty updates applied

Didier Roche (didrocks) on 2011-03-08
Changed in unity:
status: Fix Released → New
Changed in unity (Ubuntu):
status: Fix Released → New
Changed in compiz (Ubuntu):
importance: Medium → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity:
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
importance: Undecided → High
tags: added: unity-priority
Didier Roche (didrocks) on 2011-03-08
tags: added: dids-top-ten
Alex Launi (alexlauni) on 2011-03-08
Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged

The issue happened while I was setting the transparency of the gnome-terminal background.

Will restart and see if reproducible. this area is more stable tan it used to be it is my first compiz crash since last Thursday update.

Neil J. Patel (njpatel) on 2011-03-17
Changed in unity:
milestone: none → 3.6.8
assignee: Sam "SmSpillaz" Spilsbury (smspillaz) → Loïc Molinari (loic.molinari)
Changed in unity (Ubuntu Natty):
milestone: none → ubuntu-11.04-beta-1
Scott Morgan (blumf) wrote :

I can reliably reproduce this bug by opening a scp network connection in nautilus. It also happens sporadically at random times too.

David Barth (dbarth) wrote :

I do confirm: it even crashed /unity/ itself btw. Running 3.6.6-0ubuntu1 here

Didier Roche (didrocks) on 2011-03-24
Changed in unity:
milestone: 3.6.8 → 3.8
tags: added: bugpattern-needed
David Barth (dbarth) on 2011-03-28
tags: added: unity
removed: unity-priority
Didier Roche (didrocks) on 2011-03-28
Changed in unity:
milestone: 3.8 → 3.8.2
Alex Launi (alexlauni) on 2011-03-28
Changed in compiz (Ubuntu Natty):
status: New → Triaged
Didier Roche (didrocks) on 2011-04-01
Changed in unity:
milestone: 3.8.2 → 3.8.4
Loïc Molinari (loic.molinari) wrote :

It's been fixed with recent changes by Sam. Marking it as "fix committed" while still tracking new reports to be sure.

Changed in unity:
status: Triaged → Fix Committed
Changed in compiz (Ubuntu Natty):
status: Triaged → Fix Committed
Changed in unity (Ubuntu Natty):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.4+bzr20110406-0ubuntu1

---------------
compiz (1:0.9.4+bzr20110406-0ubuntu1) natty; urgency=low

  * new upstream bzr tarball:
    - display/size problems with xterm (LP: #748137)
    - fix crashes on tcl/tk applications (LP: #741074, #747439)
    - fix grab on compose keys (LP: #747323)
    - resync stack at regular interval to avoid invisible windows
      (LP: #723014, #743011, #736876, #740465, #684590)
    - fix weird order in alt + tab (LP: #175874)
    - fix crash in gitk (LP: #743011, #741074)
    - avoid compiz detection by fglrx driver (LP: #740298)
    - Wrong window moves (LP: #741656, #743634)
    - Unity Grid is broken for multi-monitor setups (LP: #709221)
    - Feature Freeze Exception: Animation for Grid Plugin Previews (LP: #744104)
    - unity-window-decorator crashed with SIGSEGV in gdk_window_get_events()
      (LP: #725284)
    - fix xterm (LP: #692463)
    - start the decorator on a secondary screen (LP: #730495)
  * debian/patches/090_git_fix_new_invisible_windows.patch,
    debian/patches/100_bump_core.h.patch:
    - upstreamed
  * debian/patches/01_unity_window_decorator.patch
    debian/patches/085_add_grid_plugin.patch:
    - in bzr upstream tarball
 -- Didier Roche <email address hidden> Wed, 06 Apr 2011 19:37:45 +0200

Changed in compiz (Ubuntu Natty):
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-04-07
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package unity - 3.8.4-0ubuntu1

---------------
unity (3.8.4-0ubuntu1) natty; urgency=low

  * New upstream release.
    - [fglrx] compiz crashed with SIGSEGV in nux::IOpenGLSurface::UnlockRect()
      (LP: #685682)
    - SIGSEGV in g_atomic_int_get (LP: #688803)
    - unity-panel-service crashed with SIGSEGV in bamf_factory_view_for_path()
      (LP: #717684)
    - New window tracking system breaks in the case where windows try to
      restack relative to destroyed windows that were never mapped
      (LP: #723014)
    - Numpad 'Enter' doesn't work on highlighted items in dash, places-files and
      places-apps (LP: #741615)
    - compiz crashed with SIGSEGV in free() (LP: #738864)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #741674)
    - compiz crashed with SIGSEGV in CompWindow::id() (LP: #742028)
    - Windows that reparent away from the root before they are mapped can
      cause other windows to become invisible (and compiz to crash)
      (LP: #743011)
    - compiz crashed with SIGABRT in raise() (LP: #743414)
    - compiz crashed with SIGSEGV in g_object_get_qdata() (LP: #742905)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #748033)
    - compiz crashed with SIGSEGV in CompScreen::dpy() (LP: #751372)
    - compiz crashed with SIGABRT in __kernel_vsyscall() (LP: #744867)
    - unity-window-decorator crashed with SIGSEGV in gdk_window_get_events()
      (LP: #725284)
    - Missing icons in app launcher (LP: #728393)
    - Multiple quick clicks on launcher icon with multiple windows completely
      crashes Unity (LP: #731790)
    - Add a test case for invisible windows regressions (LP: #736876)
    - Re-sync with xquerytree to avoid stacking order issues (LP: #740465)
    - Wrong window moves (LP: #741656)
    - compiz crashed with SIGSEGV in g_cclosure_marshal_VOID__VOID()
      (LP: #742280)
    - panel superposition (LP: #742859)
    - unity-window-decorator doesn't start on secondary X session
      (LP: #730495)
    - Unity Launcher stops autohiding and is not responsive (LP: #744325)
    - dash categories dropdown menu leaves "ghost" on desktop (LP: #746800)
    - new dialogs open close enough of the launcher to make hide (LP: #747302)
    - dnd from the application place to the launcher works only once
      (LP: #747316)
    - compiz crashed with SIGSEGV in CompWindow::id() while opening tcl/tk
      interface of R (LP: #747439)
    - minimize animates window fading to the top left corner (ubuntu symbol)
      (LP: #747765)
    - Spread - Clicking on a app icon to spread the windows must always show
      all the windows, regardless of whether or not some of the windows are
      minimised (LP: #750349)
    - Launcher - Show visual de-coupling of Launcher app icons (LP: #751196)
    - unity-window-decorator crashed with SIGSEGV in event_filter_func()
      (LP: #748317)
    - Pressing Super-W to switch windows also presents Dash (LP: #753453)
    - Don't create windows over the launcher (LP: #688816)
    - Unity Grid is broken for multi-monitor setups (LP: #709221)
    - F10 key does not move focus to indicators when on the desktop.
      (LP: #727548)
    - dynamic ...

Read more...

Changed in unity (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.