Compiz clears the root window in the installer session

Bug #720679 reported by Evan on 2011-02-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Compiz Core
Low
Sam Spilsbury
Unity
Fix Released
Low
Sam Spilsbury
compiz (Ubuntu)
Low
Sam Spilsbury
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: compiz

In both Maverick and Natty, when replacing metacity with compiz in the installer session, the root window gets initially painted by /usr/bin/ubiquity-dm (you can see it for about a second) and then cleared to black by compiz. There do not appear to be any windows set to _NET_WM_WINDOW_TYPE_DESKTOP.

To reproduce:
Boot a live CD and press a key when you see the 'man = keyboard' icon. Select a language then hit F6 over the first option. This will bring up the kernel command line. Add 'break=bottom maybe-ubiquity' just before '--', leaving a space between them, then hit enter to boot.

This should then bring you to an initramfs prompt. Type 'chroot root bash' then 'sed -i "s/'metacity'/'compiz'/g" /usr/bin/ubiquity-dm'. Type exit and exit again.

You should now be booted into the live session using compiz. The screen will be black, despite the code in /usr/bin/ubiquity-dm that attempts to paint to the root window. 'DISPLAY=:0 xsetroot -solid red' from a VT will also not work.

Related branches

Evan (ev) wrote :
Changed in compiz (Ubuntu):
status: New → Confirmed
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in compiz-core:
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → 0.9.5.96
importance: Undecided → Medium
status: New → Confirmed
Changed in unity:
importance: Undecided → Medium
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → 4.16.0
Didier Roche (didrocks) on 2011-09-15
Changed in unity:
milestone: 4.16.0 → 4.18.0
Alex Launi (alexlauni) on 2011-09-23
Changed in unity:
status: New → Confirmed
Didier Roche (didrocks) on 2011-09-26
Changed in unity:
milestone: 4.18.0 → 4.20.0
Didier Roche (didrocks) on 2011-09-29
Changed in compiz-core:
importance: Medium → Low
Changed in unity:
importance: Medium → Low
Changed in compiz (Ubuntu):
importance: Undecided → Low
Didier Roche (didrocks) on 2011-09-29
Changed in unity:
milestone: 4.20.0 → 4.22.0
Didier Roche (didrocks) on 2011-10-04
Changed in unity:
milestone: 4.22.0 → 4.24.0
Changed in unity:
milestone: 4.24.0 → 4.26.0
Sam Spilsbury (smspillaz) wrote :

A small note, the linked branch fixes the problem in the case where compiz starts up after the root window is set, but you won't be able to change it while compiz is running because there isn't any reliable way to get a notification when a background pixmap for a window changes (XDamage will report changes to the root window every time a subwindow changes which kills performance, Expose events wont be generated because all subwindows have been redirected)

Changed in compiz-core:
status: Confirmed → Fix Committed
Changed in unity:
status: Confirmed → Fix Committed
Changed in compiz (Ubuntu):
status: Confirmed → Fix Committed
Omer Akram (om26er) on 2012-01-20
Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
Changed in compiz-core:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Changed in compiz-core:
milestone: 0.9.5.96 → 0.9.7.0
Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers