vim.gnome window is invisible

Bug #719001 reported by Jean-Baptiste Lallement on 2011-02-14
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Unassigned
compiz (Ubuntu)
High
Sam Spilsbury
Natty
High
Sam Spilsbury
unity (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

Binary package hint: compiz

vim.gnome window is sometimes invisible.
It's on the top layer but invisible. It blocks the interaction with the windows behind, I can't see the menu but if I click at the place of the toolbar the menus are activated and visible.

I haven't found a pattern to reproduce it each time, but this is randomly reproducible on different systems.

If I kill vim, the invisible window disappear.

xwininfo below:

xwininfo: Window id: 0x6200024 "ui.py (/tmp/apport/apport) - GVIM"

  Absolute upper-left X: -1
  Absolute upper-left Y: -29
  Relative upper-left X: -1
  Relative upper-left Y: -29
  Width: 811
  Height: 378
  Depth: 24
  Visual: 0x21
  Visual Class: TrueColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x20 (installed)
  Bit Gravity State: NorthWestGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: no
  Map State: IsViewable
  Override Redirect State: no
  Corners: +-1+-29 -214+-29 -214-251 +-1-251
  -geometry 113x24+-1+-29

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: compiz 1:0.9.2.1+glibmainloop4-0ubuntu11
ProcVersionSignature: Ubuntu 2.6.38-3.30-generic 2.6.38-rc4
Uname: Linux 2.6.38-3-generic i686
Architecture: i386
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1024x600 1024x600
 edid-base64: AP///////wAiZOkDZUECABoUAQOAFg14CoYmlFdRkCchT1QAAAABAQEBAQEBAQEBAQEBAQEBlBEAsEBYGSA1I0UA3IEAAAAZFhQA2EBYJiBdIxUE3IEAAAAAAAAA/gAAAAAAAAAAAAAAAAAAAAAA/gAAAAAAAAAAAAEAAAAAABY=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Mon Feb 14 22:14:59 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
GraphicsCard:
 Subsystem: ASUSTeK Computer Inc. Device [1043:83ac]
   Subsystem: ASUSTeK Computer Inc. Device [1043:83ac]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110209)
MachineType: ASUSTeK Computer INC. 1015PE
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US.UTF-8:en
 LANG=en_US.UTF-8
 LC_MESSAGES=en_AG.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-3-generic root=UUID=014cdf46-1d84-4e78-a68e-5d6de3419ad9 ro quiet splash vt.handoff=7
SourcePackage: compiz
dmi.bios.date: 05/31/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0402
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 1015PE
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0402:bd05/31/2010:svnASUSTeKComputerINC.:pn1015PE:pvrx.x:rvnASUSTeKComputerINC.:rn1015PE:rvrx.xx:cvnASUSTeKComputerINC.:ct10:cvrx.x:
dmi.product.name: 1015PE
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.
version.compiz: compiz 1:0.9.2.1+glibmainloop4-0ubuntu11
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu1
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu4
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.13.2+git20110124.fadee040-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-1ubuntu7
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu4

Jean-Baptiste Lallement (jibel) wrote :
Changed in compiz (Ubuntu):
status: New → Confirmed
importance: Undecided → High
description: updated
tags: added: compiz-0.9
Jean-Baptiste Lallement (jibel) wrote :

output of xwinfo -all

Jean-Baptiste Lallement (jibel) wrote :

output of wmctrl -l

Changed in compiz (Ubuntu):
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
milestone: none → natty-alpha-3
Jean-Baptiste Lallement (jibel) wrote :

I'm still facing this problem with the current version of unity/compiz from the archive as of today.

Changed in compiz (Ubuntu Natty):
milestone: natty-alpha-3 → ubuntu-11.04-beta-2
Jean-Baptiste Lallement (jibel) wrote :

when this happens, I kill the instances of vim and restart it until I can see the window.
But after some time tons of problems start to appears:
- when I click on the window on the front the window behind get the focus
- the gvim window is always on top
- some windows can't be clicked
- can't use alt tab to switch between windows
- ...

And finally, after a long battle to try to keep the desktop not sinking into deeper water, I run 'unity' and the bug-buddy shows up with the crash file attached.

David Barth (dbarth) wrote :

Can reporters on this bug confirm that the issue is not occuring anymore with the latest compiz release? ie 0.9.4+bzr20110415 coming to an archive near you.

Changed in unity:
status: New → Triaged
importance: Undecided → Medium
milestone: none → 3.8.10
Jean-Baptiste Lallement (jibel) wrote :

I haven't met this issue for the last few days. I'm closing this report. Thanks for the fix.

Changed in compiz (Ubuntu Natty):
milestone: ubuntu-11.04-beta-2 → none
status: Confirmed → Fix Released
Changed in unity:
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.8.10-0ubuntu1

---------------
unity (3.8.10-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Application windows can sometimes fail to display and will mask regions
      of the screen (LP: #709461)
    - Launcher appears _under_ application windows (LP: #743834)
    - Unity Launcher Temporarily Appears Broken at Login (LP: #756951)
    - compiz crashed with signal 7 in g_file_get_uri() (LP: #728319)
    - Only with few windows (and one maximized) or Dodge active window - When
      re-focusing on maximised window Unity launcher does not hide
      (LP: #734681)
    - UIFe: Unity Dash button does not give adequate feedback (LP: #748676)
    - Focus problem with Thunderbird (LP: #753951)
    - compiz crashed with SIGSEGV in PrivateWindow::updateStartupId()
      (LP: #759363)
    - unity places don't start up on login. (LP: #761225)
    - unity crashes when emptying trash twice (LP: #761643)
    - compiz crashed with SIGSEGV in PlacesResultsController::Clear()
      (LP: #761211)
    - compiz crashed with SIGSEGV in PanelView::~PanelView() (LP: #761634)
    - compiz crashed with SIGSEGV in SimpleLauncherIcon::SetIconName()
      (LP: #763560)
    - compiz crashed with SIGSEGV in PlacesView::ConnectPlaces() (LP: #761942)
    - Intellihide stuck with in x=0 on the bfb (LP: #764643)
    - compiz crashed with SIGSEGV in PlacesView::OnResizeFrame() (LP: #763800)
    - unity crashed with GError in reset_unity_compiz_profile(): Failed to
      contact configuration server; the most common cause is a missing or
      misconfigured D-Bus session bus daemon. See
      http://projects.gnome.org/gconf/ for information. (Details - 1: Failed
      to get connection to session: Command line `dbus-launch
      --autolaunch=f0af37ac055f6f348acd417f00000008 --binary-syntax --close-
      stderr' exited with non-zero exit status 1: No protocol
      specified\nAutolaunch error: X11 initialization failed.\n) (LP: #753528)
    - Chromium fullscreen + Alt-TAB confuses the launcher (LP: #757434)
    - Cannot click on left-most indicator on panel if a non-indicator icon
      appears (LP: #761409)
    - vim.gnome window is invisible (LP: #719001)
    - Trash/ws switcher icon in unity resets to default icon theme on the
      event of a deletion or emptying the trash or after an upgrade
      (LP: #761289)
    - Incorrect keynav hilight/opened Quicklist without any request
      (LP: #764730)
    - indicator font does not update when changing font in Appearance
      Preferences. (LP: #759886)
    - In dash search filter drop box, black text is on a black background when
      item is selected (LP: #761201)
 -- Didier Roche <email address hidden> Tue, 19 Apr 2011 19:30:20 +0200

Changed in unity (Ubuntu Natty):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers