Ubuntu

compiz crashed with SIGSEGV in pthread_mutex_lock()

Reported by kyleabaker on 2011-02-04
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: compiz

Restarted Compiz due to some graphical glitches related to bug and compiz crashed on "compiz --replace":

"semi-random invisible window with x geometry on top layer possible, all viewport only (one ws though)"
https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/709461

1) The release of Ubuntu you are using, via 'lsb_release -rd' or System -> About Ubuntu
Description: Ubuntu natty (development branch)
Release: 11.04

2) The version of the package you are using, via 'apt-cache policy pkgname' or by checking in Software Center
compiz:
  Installed: 1:0.9.2.1+glibmainloop4-0ubuntu9
  Candidate: 1:0.9.2.1+glibmainloop4-0ubuntu9
  Version table:
 *** 1:0.9.2.1+glibmainloop4-0ubuntu9 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main amd64 Packages
        100 /var/lib/dpkg/status

3) What you expected to happen
Compiz should restart cleanly via "compiz --replace"

4) What happened instead
Compiz crashed.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: compiz-core 1:0.9.2.1+glibmainloop4-0ubuntu9
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic x86_64
Architecture: amd64
CrashCounter: 1
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1280x1024 1280x1024 1152x864 1024x768 1024x768 1024x768 832x624 800x600 800x600 800x600 800x600 640x480 640x480 640x480 640x480 720x400
 edid-base64: AP///////wBMLRUBOTFTRyQPAQNsJh54Km+GolpNlCQaT1S/74CBgHFPAQEBAQEBAQEBAQEBMCoAmFEAKkAwcBMAeC0RAAAeAAAA/QA4Sx5RDgAKICAgICAgAAAA/ABTeW5jTWFzdGVyCiAgAAAA/wBIOU5ZOTEwNTg5CiAgAEE=
Date: Thu Feb 3 19:45:05 2011
DistUpgraded: Yes, recently upgraded Log time: 2011-01-25 23:54:18.644640
DistroCodename: natty
DistroVariant: ubuntu
ExecutablePath: /usr/bin/compiz
GraphicsCard: Subsystem: ASUSTeK Computer Inc. Device [1043:81ff]
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
Lsusb:
 Bus 002 Device 004: ID 046d:c00e Logitech, Inc. M-BJ58/M-BJ69 Optical Wheel Mouse
 Bus 002 Device 003: ID 413c:2005 Dell Computer Corp. RT7D50 Keyboard
 Bus 002 Device 002: ID 045e:00f7 Microsoft Corp. LifeCam VX-1000
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: System manufacturer System Product Name
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-1-generic root=UUID=c22af6bd-3412-4356-aa68-821df900d884 ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x7fdd4c395394 <pthread_mutex_lock+4>: mov 0x10(%rdi),%esi
 PC (0x7fdd4c395394) ok
 source "0x10(%rdi)" (0x00000038) not located in a known VMA region (needed readable region)!
 destination "%esi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: compiz
StacktraceTop:
 pthread_mutex_lock () from /lib/libpthread.so.0
 ?? () from /lib/libglib-2.0.so.0
 PrivateScreen::~PrivateScreen() ()
 PrivateScreen::~PrivateScreen() ()
 CompScreen::~CompScreen() ()
Title: compiz crashed with SIGSEGV in pthread_mutex_lock()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 08/19/2008
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: ASUS M2N4-SLI ACPI BIOS Revision 1205
dmi.board.name: M2N4-SLI
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: 1.XX
dmi.chassis.asset.tag: 123456789000
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrASUSM2N4-SLIACPIBIOSRevision1205:bd08/19/2008:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM2N4-SLI:rvr1.XX:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.2.1+glibmainloop4-0ubuntu9
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu1
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.13.2+git20110124.fadee040-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-1ubuntu6
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu4

kyleabaker (kyleabaker) wrote :

Thank you for taking the time to report this crash and helping to make Ubuntu better. This particular crash has already been reported and is a duplicate of bug #711231, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

visibility: private → public
tags: removed: need-amd64-retrace
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers