xterm -iconic option does not work with compiz

Bug #711894 reported by Hizoka on 2011-02-02
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Medium
Sam Spilsbury
compiz (Ubuntu)
Medium
Sam Spilsbury
Natty
Medium
Sam Spilsbury
Oneiric
Medium
Sam Spilsbury
unity (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

Binary package hint: xterm

This command does not work with compiz but it works without compiz

xterm -iconic -e "echo 'I sleep' && sleep 5"

with compiz : the window is visible
without compiz : the window is at the bottom of the screen

the bug exists for :
 - Lucid 64
 - Lucid 32
 - Maverick 32
and probably for Maverick 64

 - XTerm(256)
 - XTerm(261)

Sorry for my english.

uboops (oops66) wrote :

Hello,
Right, I have exactly the same behavior, so I can confirm this bug with Compiz.
I have tried the both ways under Ubuntu 10.04LTS up to date and this bug only occurs with compiz activated ( no problem with metacity, in this case the xterm window is successfully iconified).
Regards,
Uboops

Tomzz (n-contact-2aide-fr) wrote :

Hello,
I have a same problem with Lucid 64bits and compiz actived.
Regards

On Wed, 2 Feb 2011, Hizoka wrote:

> Public bug reported:
>
> Binary package hint: xterm
>
> This command does not work with compiz but it works without compiz
>
> xterm -iconic -e "echo 'I sleep' && sleep 5"
>
> with compiz : the window is visible
> without compiz : the window is at the bottom of the screen

Given that, I'd also expect that iconifying a normal window would fail.
(Since the window manager is responsible for the behavior described,
it sounds like another bug in compiz).

--
Thomas E. Dickey
http://invisible-island.net
ftp://invisible-island.net

Loïc Minier (lool) on 2011-04-13
summary: - iconic option does not work with compiz
+ xterm -iconic option does not work with compiz
affects: xterm (Ubuntu) → compiz (Ubuntu)

Right, we need to add that to the client list it seems

On Wed, Apr 13, 2011 at 7:18 PM, Launchpad Bug Tracker
<email address hidden> wrote:
> You have been subscribed to a public bug:
>
> Binary package hint: xterm
>
> This command does not work with compiz but it works without compiz
>
> xterm -iconic -e "echo 'I sleep' && sleep 5"
>
> with compiz : the window is visible
> without compiz : the window is at the bottom of the screen
>
> the bug exists for :
>  - Lucid 64
>  - Lucid 32
>  - Maverick 32
> and probably for Maverick 64
>
>  - XTerm(256)
>  - XTerm(261)
>
> Sorry for my english.
>
> ** Affects: compiz (Ubuntu)
>     Importance: Undecided
>         Status: New
>
> --
> xterm -iconic option does not work with compiz
> https://bugs.launchpad.net/bugs/711894
> You received this bug notification because you are a member of compiz packagers, which is subscribed to compiz in Ubuntu.
>
> _______________________________________________
> Mailing list: https://launchpad.net/~compiz
> Post to     : <email address hidden>
> Unsubscribe : https://launchpad.net/~compiz
> More help   : https://help.launchpad.net/ListHelp
>

--
Sam Spilsbury

Changed in compiz (Ubuntu):
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
milestone: none → ubuntu-11.04-beta-2
Kate Stewart (kate.stewart) wrote :

From comments this should be marked as confirmed, and targetted to natty series

Changed in compiz (Ubuntu Natty):
milestone: ubuntu-11.04-beta-2 → ubuntu-11.04
status: New → Confirmed
importance: Undecided → Medium
Changed in compiz (Ubuntu Oneiric):
milestone: ubuntu-11.04 → none
Changed in compiz (Ubuntu Natty):
milestone: ubuntu-11.04 → natty-updates

Kate we have a fix for this but it is too invasive and not for natty,
perhaps for an SRU0

On Sat, Apr 16, 2011 at 11:05 AM, Kate Stewart
<email address hidden> wrote:
> >From comments this should be marked as confirmed,  and targetted to
> natty series
>
> ** Also affects: compiz (Ubuntu Natty)
>   Importance: Undecided
>     Assignee: Sam "SmSpillaz" Spilsbury (smspillaz)
>       Status: New
>
> ** Changed in: compiz (Ubuntu Natty)
>    Milestone: ubuntu-11.04-beta-2 => ubuntu-11.04
>
> ** Changed in: compiz (Ubuntu Natty)
>       Status: New => Confirmed
>
> ** Changed in: compiz (Ubuntu Natty)
>   Importance: Undecided => Medium
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/711894
>
> Title:
>  xterm -iconic option does not work with compiz
>
> Status in “compiz” package in Ubuntu:
>  Confirmed
> Status in “compiz” source package in Natty:
>  Confirmed
>
> Bug description:
>  Binary package hint: xterm
>
>  This command does not work with compiz but it works without compiz
>
>  xterm -iconic -e "echo 'I sleep' && sleep 5"
>
>  with compiz : the window is visible
>  without compiz : the window is at the bottom of the screen
>
>  the bug exists for :
>   - Lucid 64
>   - Lucid 32
>   - Maverick 32
>  and probably for Maverick 64
>
>   - XTerm(256)
>   - XTerm(261)
>
>  Sorry for my english.
>

--
Sam Spilsbury

David Barth (dbarth) on 2011-07-21
Changed in compiz (Ubuntu Natty):
milestone: natty-updates → none
status: Confirmed → Won't Fix
Changed in unity:
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → 4.6.0
Didier Roche (didrocks) on 2011-08-01
Changed in unity:
milestone: 4.6.0 → 4.8.0
Alex Launi (alexlauni) on 2011-08-01
Changed in unity:
status: New → Invalid
status: Invalid → Confirmed
importance: Undecided → Medium
Changed in unity:
status: Confirmed → Fix Released
Changed in compiz (Ubuntu Oneiric):
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: New → Fix Released
Rolf Leggewie (r0lf) wrote :

natty has seen the end of its life and is no longer receiving any updates. Marking the natty task for this ticket as "Won't Fix".

Changed in unity (Ubuntu Natty):
status: New → Won't Fix
Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in unity (Ubuntu Oneiric):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers