Ubuntu

compiz crashed with SIGSEGV in __pthread_mutex_lock()

Reported by Michael Terry on 2011-02-01
This bug affects 231 people
Affects Status Importance Assigned to Milestone
Unity
High
Loïc Molinari
compiz (Ubuntu)
High
Loïc Molinari
Natty
High
Loïc Molinari
unity (Ubuntu)
Undecided
Loïc Molinari
Natty
Undecided
Loïc Molinari

Bug Description

Binary package hint: compiz

When logging in, sometimes Unity does not finish loading. No indicators appear but the desktop icons will. I can't interact with anything because compiz will have crashed.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: compiz-core 1:0.9.2.1+glibmainloop4-0ubuntu8
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic x86_64
Architecture: amd64
CrashCounter: 1
DRM.card0.DP.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI.A.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1366x768
 edid-base64: AP///////wAwZAMJAQEBASMTAQOAHRF4CoWVmVdPjyYhUFQAAAABAQEBAQEBAQEBAQEBAQEBux1W6lAAGTAjcFoAJ6YQAAAYAAAADwAC0ALQAAUBBUzUAg4AAAAA/gBUTURJU1BMQVkKICAgAAAA/gBMVDEzM0VFMDkxMDAKALI=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Tue Feb 1 08:03:58 2011
DistUpgraded: Yes, recently upgraded Log time: 2010-08-25 06:21:49.797653
DistroCodename: natty
DistroVariant: ubuntu
ExecutablePath: /usr/bin/compiz
GraphicsCard: Subsystem: CLEVO/KAPOK Computer Device [1558:3100]
MachineType: System76, Inc. Lemur UltraThin
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_GB.utf8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-1-generic root=UUID=625ed789-1cb3-4081-9c7e-f812810b5126 ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x7fe9e2bd2394 <__pthread_mutex_lock+4>: mov 0x10(%rdi),%esi
 PC (0x7fe9e2bd2394) ok
 source "0x10(%rdi)" (0x894c02fa8328ec9b) not located in a known VMA region (needed readable region)!
 destination "%esi" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: compiz
StacktraceTop:
 __pthread_mutex_lock (mutex=0x894c02fa8328ec8b) at pthread_mutex_lock.c:50
 g_source_unref_internal (source=0x7fe9e18d38e0, context=0x894c02fa8328ec83, have_lock=0) at /build/buildd/glib2.0-2.27.93/glib/gmain.c:1671
 PrivateScreen::~PrivateScreen() ()
 PrivateScreen::~PrivateScreen() ()
 CompScreen::~CompScreen() ()
Title: compiz crashed with SIGSEGV in __pthread_mutex_lock()
UnitySupportTest:

UserGroups: adm admin cdrom dialout dip fax floppy fuse lpadmin plugdev sambashare tape video
XsessionErrors:
 (<unknown>:1515): Bonobo-WARNING **: Bonobo must be initialized before use
 (nautilus:1520): GConf-CRITICAL **: gconf_value_free: assertion `value != NULL' failed
 (nm-applet:1525): Gtk-CRITICAL **: IA__gtk_widget_is_toplevel: assertion `GTK_IS_WIDGET (widget)' failed
dmi.bios.date: 08/17/2010
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: CALPELLACRB.86C.0000.X.0000000000
dmi.board.asset.tag: Tag 12345
dmi.board.name: Lemur UltraThin
dmi.board.vendor: System76, Inc.
dmi.board.version: lemu2
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: System76, Inc.
dmi.chassis.version: lemu2
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrCALPELLACRB.86C.0000.X.0000000000:bd08/17/2010:svnSystem76,Inc.:pnLemurUltraThin:pvrlemu2:rvnSystem76,Inc.:rnLemurUltraThin:rvrlemu2:cvnSystem76,Inc.:ct10:cvrlemu2:
dmi.product.name: Lemur UltraThin
dmi.product.version: lemu2
dmi.sys.vendor: System76, Inc.
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu1
version.xserver-xorg: xserver-xorg 1:7.5+6ubuntu8
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.13.2+git20110124.fadee040-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu1

Related branches

lp:~unity-team/compiz/work-around-glibmm-bug-561885
Merged into lp:~unity-team/compiz/trunk at revision 2742
Sam Spilsbury (community): Approve on 2011-04-08
Michael Terry (mterry) wrote :
visibility: private → public
tags: removed: unity-2d
tags: added: compiz-0.9

StacktraceTop:
 __pthread_mutex_lock (mutex=0x894c02fa8328ec8b)
 g_source_unref_internal (source=0x7fe9e18d38e0,

Changed in compiz (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Ant Vas (antono) on 2011-02-07
Changed in compiz (Ubuntu):
status: New → Confirmed
Ant Vas (antono) wrote :

Very similar to
https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/191174

Semms still not fixed :(

shishimaru (shishimaru) wrote :

I'm affected by this bug. Anyway, I tried to "unity --reset" and it crashed Compiz.

pdaemon (philipp-burath) wrote :

This bug affect me as well. I get the same symptoms as discussed in the initial bug report. What can I do to assist?

Dmitry G. (hint) wrote :

Affect me while in Gnome, not Unity. In the middle of the session, pretty lot time from log in.

Sebastien Bacher (seb128) wrote :

The issue is still there using compiz 0.9.4 and unity 3.4.6:

"#1 0x004d4ab4 in g_source_unref_internal () from /lib/libglib-2.0.so.0
No symbol table info available.
#2 0x00d06bd0 in Glib::Source::unreference() const () from /usr/lib/libglibmm-2.4.so.1
No symbol table info available.
#3 0x080709f5 in ~RefPtr (this=0x8a51540, __in_chrg=<value optimised out>) at /usr/include/glibmm-2.4/glibmm/refptr.h:207
No locals.
#4 PrivateScreen::~PrivateScreen (this=0x8a51540, __in_chrg=<value optimised out>) at /build/buildd/compiz-0.9.4/src/screen.cpp:4776
No locals.
#5 0x08070cc2 in PrivateScreen::~PrivateScreen (this=0x8a51540, __in_chrg=<value optimised out>) at /build/buildd/compiz-0.9.4/src/screen.cpp:4778
No locals.
#6 0x0806f858 in CompScreen::~CompScreen (this=0x8a514b8, __in_chrg=<value optimised out>) at /build/buildd/compiz-0.9.4/src/screen.cpp:4683
        p = <value optimised out>
#7 0x0806f962 in CompScreen::~CompScreen (this=0x8a514b8, __in_chrg=<value optimised out>) at /build/buildd/compiz-0.9.4/src/screen.cpp:4686
No locals.
#8 0x080663c1 in CompManager::fini (this=0xbf9c1bbc) at /build/buildd/compiz-0.9.4/src/main.cpp:259
No locals.
#9 0x08066bb0 in main (argc=1, argv=0xbf9c1c94) at /build/buildd/compiz-0.9.4/src/main.cpp:287"

Didier Roche (didrocks) on 2011-02-25
Changed in unity:
milestone: none → 3.8
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
Didier Roche (didrocks) on 2011-02-25
Changed in unity (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

bug #684991 seems similar to this crasher

vulfgar (vulfgar) wrote :

I get this when I login and I get it again every time I restart compiz. I don't use unity, I prefer classic desktop.

Didier Roche (didrocks) on 2011-03-28
Changed in unity:
milestone: 3.8 → 3.8.2
Sam Spilsbury (smspillaz) wrote :

I talked to Murray Cummings about this one - apparantly it is a bug in Glibmm where sources are auto unref'd when they are first disconnected and also on the parent class destructors. In any case, this crash only seems to happen when compiz is actually exiting, so the real issue is that compiz is failing to start. I'd like to see why this is, since there are very few cases where shutDown is true except where *two* instances of compiz are started. And in that case it is a gnome-session bug.

Sam Spilsbury (smspillaz) wrote :

Hrm, ok, looking into this further it seems like g-s restarts compiz because we miss a timeout. Except that it can't because the first compiz cant be restarted yet.

Could someone please attach their .xsession-errors ?

Gary M (garym) wrote :

@Sam, a .xsession-errors file is attached to the duplicate bug #717652 : https://launchpadlibrarian.net/64134992/XsessionErrors.txt .

Changed in unity:
milestone: 3.8.2 → 3.8.4
Jason (jaseeverett) wrote :

I've been directed here from the duplicate bug Bug #750127. I'm running Natty beta

Compiz seems to load fine and operates as normal until I start matlab and then it crashes every time as reported for Bug #750127.

Let me know if you need more information.

David Barth (dbarth) on 2011-04-06
Changed in unity:
assignee: Sam "SmSpillaz" Spilsbury (smspillaz) → Loïc Molinari (loic.molinari)
Didier Roche (didrocks) on 2011-04-07
Changed in unity:
milestone: 3.8.4 → 3.8.6

Platform i386
Affects me too.
I could provide more info if needed (just told me which one)

Changed in compiz (Ubuntu Natty):
assignee: nobody → Loïc Molinari (loic.molinari)
Changed in unity (Ubuntu Natty):
assignee: nobody → Loïc Molinari (loic.molinari)
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu Natty):
status: Confirmed → In Progress
Changed in compiz (Ubuntu Natty):
status: Confirmed → In Progress
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu Natty):
status: In Progress → Fix Committed
Changed in compiz (Ubuntu Natty):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-04-11
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.8.6-0ubuntu1

---------------
unity (3.8.6-0ubuntu1) natty; urgency=low

  * New upstream release.
    - compiz crashed with SIGABRT in raise() (LP: #748163)
    - System freezes when maximize button is clicked (LP: #754063)
    - compiz crashed with SIGSEGV in QuicklistView::IsMenuItemSeperator()
      (LP: #754302)
    - compiz crashed with SIGSEGV in std::_List_node_base::_M_hook()
      (LP: #754235)
    - compiz crashed with SIGSEGV in ubus_server_pump_message_queue()
      (LP: #754657)
    - drag from dash to launcher (LP: #662616)
    - Add a test case for unity-decorator regressions (LP: #736878)
    - the files place category combo has empty space (LP: #741641)
    - panel superposition (LP: #742859)
    - Unity Launcher stops autohiding and is not responsive (LP: #744325)
    - Unity Launcher stops autohiding and is not responsive (LP: #744325)
    - [FFE] Need API to set urgency from background process (LP: #747677)
    - Launcher - Escape from 'drag behind the Launcher' interaction
      (LP: #750298)
    - Launcher needs to be desaturated when Dash is open, not transparent.
      (LP: #750358)
    - compiz crashed with SIGSEGV in free() (LP: #752293)
    - migrate_favorites.py crashed with ImportError in __main__: No module
      named gconf (LP: #752176)
    - compiz crashed with SIGSEGV in PluginClassHandler<DecorWindow,
      CompWindow, 0>::get() (LP: #743807)
    - cannot close the dash by clicking on the bfb (LP: #753914)
    - Animation for Grid Previews is broken (LP: #754088)
    - compiz crashed with SIGSEGV in PanelMenuView::OnPlaceViewShown()
      (LP: #754585)
    - Pressing F10 then "left arrow" wit Unity on Natty makes the system
      unusable (LP: #756867)
    - compiz crashed with SIGSEGV in __pthread_mutex_lock() (LP: #711231)
    - Tooltips and Dash Font Problems (LP: #741605)
    - Title elipisising incorrect. Type “Shotwell” for a good example
      (LP: #750350)
    - compiz crashed with SIGSEGV in Launcher::Launcher() (LP: #748096)
    - BFB - Turn top left corner blue rather than Ubuntu logo (LP: #755286)
    - launcher appears and gets stuck when resizing windows with mouse
      (LP: #754690)
    - Wrong item gets dragged out (LP: #729796)
    - Launcher - when the launcher is folded, the bottom icon partially falls
      off the end of the screen (LP: #731869)
    - unity-window-decorator: Resize padding: Tiny focused windows lose resize
      padding and shadow when <69 pixels wide (LP: #737707)
    - Deinstalling an application with launcher entry leaves orphaned shortcut
      (LP: #748107)
    - Two Nautilus windows open when clicked on a device icon on Launcher
      (started after 3.8.2) (LP: #748299)
    - compiz crashed with SIGSEGV in Launcher::AnimationTimeout()
      (LP: #749890)
  * debian/control:
    - build-dep on latest nux (ABI break)
  * debian/unity-common.install:
    - install the desktop file for the new capplet
 -- Didier Roche <email address hidden> Mon, 11 Apr 2011 12:42:33 +0200

Changed in unity (Ubuntu Natty):
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-04-11
Changed in compiz (Ubuntu Natty):
status: Fix Committed → Triaged
Changed in unity:
milestone: 3.8.6 → 3.8.8
status: Fix Released → Triaged
hassan121 (k7rata121) wrote :

affects me too , but not 'sometimes' , Its always !

I use ubuntu 11.04 beta 1

my video card is intel g828 and compiz was working good in ubuntu 10.04

Didier Roche (didrocks) on 2011-04-14
Changed in unity:
milestone: 3.8.8 → 3.8.10
Kate Stewart (kate.stewart) wrote :

Increasing priority due to number of duplicates.

Changed in compiz (Ubuntu Natty):
importance: Medium → High
milestone: none → ubuntu-11.04
Loïc Molinari (loic.molinari) wrote :

This bug can be reproduced by running "metacity --replace" while compiz is running.

This is a bug in glibmm (https://bugzilla.gnome.org/show_bug.cgi?id=561885) we tried to workaround in Compiz by never returning false in the event source callback. It appeared to be problematic with some people experiencing infinite loops. There's a patch in bugzilla we should try and maybe improve.

Didier Roche (didrocks) on 2011-04-19
Changed in unity:
milestone: 3.8.10 → 3.8.12
Geoffrey Pursell (geoffp) wrote :

This happens to me on every boot now as of yesterday's updates. Video card is a Radeon 3850, but compiz still appears to be running, just without the Unity environment. There's just Nautilus on the desktop, and startup items do load. To get anything done, I have to start apps with DISPLAY=:0 from another login.

Download full text (5.0 KiB)

It appears the problem was, in my case, related to a misconfiguration on the
gnome-launcher.
The default session launched was 'unity', due to a previous installation of
ubuntu netbook-edition. By setting the default session to 'ubuntu' , unity
start correctly with X.
On Apr 20, 2011 5:12 PM, "Geoffrey Pursell" <email address hidden> wrote:
> This happens to me on every boot now as of yesterday's updates. Video
> card is a Radeon 3850, but compiz still appears to be running, just
> without the Unity environment. There's just Nautilus on the desktop,
> and startup items do load. To get anything done, I have to start apps
> with DISPLAY=:0 from another login.
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (759791).
> https://bugs.launchpad.net/bugs/711231
>
> Title:
> compiz crashed with SIGSEGV in __pthread_mutex_lock()
>
> Status in Unity:
> Triaged
> Status in “compiz” package in Ubuntu:
> Triaged
> Status in “unity” package in Ubuntu:
> Fix Released
> Status in “compiz” source package in Natty:
> Triaged
> Status in “unity” source package in Natty:
> Fix Released
>
> Bug description:
> Binary package hint: compiz
>
> When logging in, sometimes Unity does not finish loading. No
> indicators appear but the desktop icons will. I can't interact with
> anything because compiz will have crashed.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.04
> Package: compiz-core 1:0.9.2.1+glibmainloop4-0ubuntu8
> ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
> Uname: Linux 2.6.38-1-generic x86_64
> Architecture: amd64
> CrashCounter: 1
> DRM.card0.DP.1:
> status: disconnected
> enabled: disabled
> dpms: Off
> modes:
> edid-base64:
> DRM.card0.HDMI.A.1:
> status: disconnected
> enabled: disabled
> dpms: Off
> modes:
> edid-base64:
> DRM.card0.LVDS.1:
> status: connected
> enabled: enabled
> dpms: On
> modes: 1366x768
> edid-base64:
AP///////wAwZAMJAQEBASMTAQOAHRF4CoWVmVdPjyYhUFQAAAABAQEBAQEBAQEBAQEBAQEBux1W6lAAGTAjcFoAJ6YQAAAYAAAADwAC0ALQAAUBBUzUAg4AAAAA/gBUTURJU1BMQVkKICAgAAAA/gBMVDEzM0VFMDkxMDAKALI=
> DRM.card0.VGA.1:
> status: disconnected
> enabled: disabled
> dpms: Off
> modes:
> edid-base64:
> Date: Tue Feb 1 08:03:58 2011
> DistUpgraded: Yes, recently upgraded Log time: 2010-08-25 06:21:49.797653
> DistroCodename: natty
> DistroVariant: ubuntu
> ExecutablePath: /usr/bin/compiz
> GraphicsCard: Subsystem: CLEVO/KAPOK Computer Device [1558:3100]
> MachineType: System76, Inc. Lemur UltraThin
> ProcCmdline: compiz
> ProcEnviron:
> LANGUAGE=en_US:en
> PATH=(custom, user)
> LANG=en_GB.utf8
> LC_MESSAGES=en_US.utf8
> SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-1-generic
root=UUID=625ed789-1cb3-4081-9c7e-f812810b5126 ro quiet splash vt.handoff=7
> SegvAnalysis:
> Segfault happened at: 0x7fe9e2bd2394 <__pthread_mutex_lock+4>: mov
0x10(%rdi),%esi
> PC (0x7fe9e2bd2394) ok
> source "0x10(%rdi)" (0x894c02fa8328ec9b) not located in a known VMA region
(needed readable region)!
> destination "%esi" ok
> SegvReason: reading unknown VMA
> Signal: 11
> SourcePackage: compiz
> StacktraceTop:
> __pthread_mutex_lock (mutex=0x894c02fa8328ec8b) at pthread_mutex_lock.c:50
> g_source_unref...

Read more...

Geoffrey Pursell (geoffp) wrote :

Avignon: I had no previous installation of netbook edition, but I had switched to the "Ubuntu Classic" session once Unity stopped working. Switching back to the "Ubuntu" session makes Unity work again. Fantastic!

tekstr1der (tekstr1der) wrote :

My bug #765072 was duped to this one. I've used only a straight-up Unity session since installing beta 1 and have experienced this crash. If unrelated, both mine and the more popular bug #740897 should be un-duped from this bug report.

David Barth (dbarth) on 2011-04-22
Changed in unity:
milestone: 3.8.12 → 3.8.14
Davide P. (scaltro) wrote :

The bug still be there...

Last Natty 64-bit, and Gnome

I have the same issue with ATI/xorg driver and AMD official driver.

Changed in compiz (Ubuntu Natty):
milestone: ubuntu-11.04 → natty-updates
Changed in unity (Ubuntu Natty):
milestone: none → natty-updates
milestone: natty-updates → none
Changed in compiz (Ubuntu):
milestone: ubuntu-11.04 → none
hassan121 (k7rata121) wrote :

the bug is still here after the final release please help !!

Pete Stucke (pstucke) wrote :

For those who are still having problems with Compiz, particularly if you cannot get the titlebar to appear on your windows, I suggest using Metacity. This will give you a working desktop environment until a fix is released:

metacity --replace

Pete Stucke (pstucke) wrote :

The other thing you can do is select "Ubuntu Classic (No Effects)" as your desktop session when you log in.

Alf (antonio-floresta) wrote :

I confirm taht the bug is still here.
I have installed Natty in two machines (Lenovo T61 and Lenovo ThinkCengtre 8810-AA5) and on both the leak can be easily reproduced: just minimize and restore an gnome-terminal window, for example. Or just drag a window to the top until touching the gnome-panel on the top.
It seems that any graphic operation (minimize, maximize, open, etc.) makes that compiz leak memory.

David Barth (dbarth) on 2011-05-31
Changed in unity:
milestone: 3.8.14 → 3.8.16
Didier Roche (didrocks) on 2011-06-01
Changed in unity:
importance: Medium → Critical
Loïc Molinari (loic.molinari) wrote :

We should really try to fix the problem in GLibmm improving the patch attached in that bug report https://bugzilla.gnome.org/show_bug.cgi?id=561885.

David Barth (dbarth) wrote :

I recommend to not consider this bug for an SRU anymore, and wll update the milestone accordingly.

Rationale:
- the only potential fix for the problem has proved to have widespread and critical side-effects when used on compiz (and was reverted as a consequence)
- the issue occurs only under special conditions and doesn't impact users in regular daily usage

The bug is moved to the backlog though, as it is still something we'd like to get rid of for the next version.

Changed in unity:
importance: Critical → High
milestone: 3.8.16 → none
tags: added: backlog
Ing. Forigua (ingforigua) wrote :

I have this problen on oneric i cant see anything in my desktop

Tim Penhey (thumper) wrote :

The source unreffing has been fixed upstream and in the oneiric branch. I'd love to know if this is still happening.

Omer Akram (om26er) wrote :

sorry for the wrong status, now changed to incomplete per Tim's comment.

Changed in unity:
status: Triaged → Invalid
Changed in compiz (Ubuntu Natty):
status: Triaged → Invalid
status: Invalid → Won't Fix
Changed in compiz (Ubuntu):
status: Triaged → Invalid
Changed in unity:
status: Invalid → Incomplete
Changed in compiz (Ubuntu):
status: Invalid → Incomplete
Changed in compiz (Ubuntu Natty):
status: Won't Fix → Triaged
Changed in compiz (Ubuntu):
status: Incomplete → Fix Committed
Changed in unity:
status: Incomplete → Fix Committed
Changed in unity:
status: Fix Committed → Fix Released
dino99 (9d9) wrote :

Might be fixed since a while, as the latest duplicate report was also about "natty"

Changed in compiz (Ubuntu Natty):
status: Triaged → Invalid
tags: removed: natty
Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.