Compiz grid edges do not work with nvidia twinview

Bug #710912 reported by Uli Tillich on 2011-01-31
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: compiz

Ubuntu 11.04 Natty - all updates installed -
Compiz Version: 1:0.9.2.1+glibmainloop4-0ubuntu8
Nvidia Drivers: 260.19.29-0ubuntu1

The Compiz Grid plugin, which is activated by default in Unity does not recognize edges between monitors with nvidia Twinview (monitors set side by side). Keyboard shortcuts (CRTL+ALT+"right arrow") work perfectly.

Expected behavior:
When dragging a window to the right edge of the left monitor, once the mouse is near the edge, compiz grid should give a preview for resizing the window to fill the right side of the left monitor (similar to when it is dragged to the left edge). Once the mouse passes to the right monitor it should give a preview to resize to the left half of the right monitor.

Current behavior:
The "edges" between monitors are completely ignored. Resizing windows works fine when dragging to either the left edge of the left side monitor or the right edge of the right side monitor. Keyboard shortcuts work as intended.

David Barth (dbarth) on 2011-02-09
Changed in compiz (Ubuntu):
importance: Undecided → Low
tags: added: bitesize
Gord Allott (gordallott) wrote :

Confirmed here using twinview, dragging to the left on my left monitor works, dragging to the right on the right monitor works but nothing else. i would imagine that if you have three monitors the center one would not have any behaviour at all.

Changed in compiz (Ubuntu):
status: New → Confirmed

On Wed, Feb 9, 2011 at 6:36 PM, Gord Allott <email address hidden> wrote:
> Confirmed here using twinview, dragging to the left on my left monitor
> works, dragging to the right on the right monitor works but nothing
> else. i would imagine that if you have three monitors the center one
> would not have any behaviour at all.
>

Indeed. We use global screen edges for detection.

What should be done is to use output edges instead. That's easy enough.

> ** Changed in: compiz (Ubuntu)
>       Status: New => Confirmed
>
> --
> You received this bug notification because you are a member of compiz
> packagers, which is subscribed to compiz in ubuntu.
> https://bugs.launchpad.net/bugs/710912
>
> Title:
>  Compiz grid edges do not work with nvidia twinview
>
> _______________________________________________
> Mailing list: https://launchpad.net/~compiz
> Post to     : <email address hidden>
> Unsubscribe : https://launchpad.net/~compiz
> More help   : https://help.launchpad.net/ListHelp
>

--
Sam Spilsbury

David Barth (dbarth) wrote :

Confirmed by Gord

Sebastien Bacher (seb128) wrote :

It doesn't work either on a 1 screen config with intel here

Sebastien Bacher (seb128) wrote :

sorry, different issue

Changed in compiz (Ubuntu):
status: Confirmed → Fix Committed
status: Fix Committed → Fix Released
Uli Tillich (utillich) wrote :

Has the fix landed yet?
It is not working for me with all updates installed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers