Ubuntu

/usr/bin/xterm is not functional in natty

Reported by Robert Clark on 2011-01-10
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

I have the latest natty Alpha update, and when I open /usr/bin/xterm with compiz enabled under the "classic Ubuntu Desktop", the xterm opens up with a title bar and a border, and the text area is transparent. I do not see a shell prompt, and typing "exit" does not work in this window. None of the title bar buttons work either. I am able to raise and lower this window from the task bar, but that is the only functionality that I can get with this xterm.

Bothe konsole and gnome-terminal appear to function properly.

The hardware is a DELL laptop Latitiude D830 with a:

[ 21.902] (II) NVIDIA(0): NVIDIA GPU Quadro NVS 135M (G86GL) at PCI:1:0:0 (GPU-0)

Please see attached Xorg.0.log file for further X environment and nvidia driver information.

Robert Clark (robert-a-clark) wrote :
affects: ubuntu → xterm (Ubuntu)
Changed in xterm (Ubuntu):
status: New → Incomplete

.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 260.19.29 Wed Dec 8 12:08:56 PST 2010
 GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-1ubuntu2)
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/allscreens/options/active_plugins'
CompositorRunning: compiz
DistUpgraded: Fresh install
DistroCodename: natty
DistroRelease: Ubuntu 11.04
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current, 260.19.29, 2.6.37-11-generic, x86_64: installed
 nvidia-current, 260.19.29, 2.6.37-12-generic, x86_64: installed
GraphicsCard: Subsystem: ASRock Incorporation Device [1849:0242]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101224)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 002: ID 0718:0628 Imation Corp.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
NonfreeKernelModules: nvidia
Package: xterm 267-0ubuntu1
PackageArchitecture: amd64
ProcEnviron:
 LANGUAGE=it_IT:it:en_GB:en
 PATH=(custom, user)
 LANG=it_IT.UTF-8
 LC_MESSAGES=it_IT.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-12-generic root=UUID=c10817a9-2c62-4ae0-a189-e0b86f5b00c4 ro vt.handoff=7 quiet splash
ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
Renderer: Hardware acceleration
Tags: natty natty ubuntu
Uname: Linux 2.6.37-12-generic x86_64
UnitySupportTest:

UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 11/03/2005
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.50
dmi.board.asset.tag: 00000000
dmi.board.name: K8NF4G-SATA2
dmi.board.version: 1.00
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.50:bd11/03/2005:svn:pnK8NF4G-SATA2:pvr1.00:rvn:rnK8NF4G-SATA2:rvr1.00:
dmi.product.name: K8NF4G-SATA2
dmi.product.version: 1.00
version.libdrm2: libdrm2 2.4.22-2ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx 7.9+repack-1ubuntu3
version.xserver-xorg: xserver-xorg 1:7.5+6ubuntu6
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.13.2-1ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.13.901-2ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20100805+b96170a-0ubuntu1

tags: added: apport-collected natty ubuntu

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in xterm (Ubuntu):
status: Incomplete → Confirmed
Fabio Marconi (fabiomarconi) wrote :

reproduced in 20110111

Julien Cristau (jcristau) wrote :

Not an xterm bug. I blame compiz, or your nvidia driver.

Changed in xterm (Ubuntu):
status: Confirmed → Invalid

On Tue, 11 Jan 2011, Fabio Marconi wrote:

> ** Package changed: ubuntu => xterm (Ubuntu)
>
> ** Changed in: xterm (Ubuntu)
> Status: New => Incomplete

another duplicate of 644943 (bug in compiz).

--
Thomas E. Dickey
http://invisible-island.net
ftp://invisible-island.net

Thomas Dickey (dickey-his) wrote :

On Tue, 11 Jan 2011, Julien Cristau wrote:

> Not an xterm bug. I blame compiz, or your nvidia driver.

Oddly, I'm only seeing this recurring problem from Ubuntu users...

--
Thomas E. Dickey
http://invisible-island.net
ftp://invisible-island.net

Fabio Marconi (fabiomarconi) wrote :

This happens without nvidia-drivers too

description: updated
affects: xterm (Ubuntu) → compiz (Ubuntu)
Changed in compiz (Ubuntu):
status: Invalid → Confirmed
Fabio Marconi (fabiomarconi) wrote :

Sorry, i've forget compiz enabled.
This issue is not reproducible in metacity.

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 694010, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers