Windows that hide themselves when closed don't appear in any "this workspace" switcher

Bug #684731 reported by Chow Loong Jin on 2010-12-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Compiz Core
High
Sam Spilsbury
Unity
Fix Released
High
Sam Spilsbury
compiz (Ubuntu)
Undecided
Sam Spilsbury
unity (Ubuntu)
Undecided
Unassigned

Bug Description

  affects ubuntu/compiz
  assignee smspillaz

When opening and closing a window just after starting Compiz, some windows end
up not appearing in any per-workspace switcher, including the Scale, Static
Application Switcher, and Ring Switcher.

1. Restart compiz.
2. Start Banshee
3. Activate "Toggle scale for current workspace/output", and notice that
Banshee's window is selectable here
4. Close its window (it doesn't quit because it stays in the Sound Menu)
5. Reopen Banshee's window via the Sound Menu or any other way
6. Repeat step #3, notice that this time, Banshee's window is gone.

The same goes for Liferea and Pidgin's buddy list windows. The common factor
here seems to be that the windows affected are windows that can be closed
(Alt+F4/press the "x") and reopened without the application quitting. This seems
to be a regression from a fairly recent change in git, as I haven't noticed this
issue before.

--
Kind regards,
Loong Jin

Changed in compiz (Ubuntu):
status: New → Confirmed
Changed in unity:
milestone: none → 4.18.0
milestone: 4.18.0 → 4.16.0
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in compiz-core:
status: New → Confirmed
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → 0.9.5.96
Changed in unity:
status: New → Confirmed
Didier Roche (didrocks) on 2011-09-15
Changed in unity:
milestone: 4.16.0 → 4.18.0
Didier Roche (didrocks) on 2011-09-26
Changed in unity:
milestone: 4.18.0 → 4.20.0
Changed in compiz-core:
importance: Undecided → High
Changed in unity:
importance: Undecided → High
Changed in compiz-core:
status: Confirmed → Fix Released
Changed in unity:
status: Confirmed → Fix Released
Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
Changed in compiz-core:
milestone: 0.9.5.96 → 0.9.7.0
Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers