Ubuntu

Emacs resizes larger than available size

Reported by Greg Cordts on 2010-10-25
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Unity
Low
Unassigned
compiz (Ubuntu)
Low
Unassigned
unity (Ubuntu)
Low
Unassigned

Bug Description

Upon opening Emacs, it resizes larger than the available screen size. The vertical height is too big and the minibuffer is completely covered.

I've installed jde, emacs-goodies-el, and pylint which all have some Emacs components, but I recall this happening prior to this too.

When emacs first starts, the minibuffer is visible. However, it resizes itself and unity does not accommodate the change.

I've attached a screenshot. When this happens, restore then maximize makes the window the right size.

Greg Cordts (gregcor) wrote :
Didier Roche (didrocks) wrote :

It's basically the same issue than with evolution (normal mode) and others applications. This should be fixed in 11.04 with hidable launcher.

Changed in unity:
status: New → Triaged
importance: Undecided → Low
Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Joshua Gay (joshuagay) wrote :

So, when emacs first opens and maximizes this is the case.

But, if you then undoc it (unmaximize it), and then click the maximize button, it works correctly.

Neil J. Patel (njpatel) on 2010-12-01
Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
milestone: none → 3.4
Neil J. Patel (njpatel) wrote :

Hi, can you please see if it's still an issue for Unity in natty? I believe this has been fixed now.

Changed in unity:
milestone: 3.4 → 3.2.16
status: Triaged → Incomplete
Matt Sturgeon (mattsturgeon) wrote :

If this is Triaged on Unity (Ubuntu), why is it Incomplete on Unity?

Didier Roche (didrocks) wrote :

Because it will be nice if the unity team sync the package and upstream bug :)

Changed in unity (Ubuntu):
status: Triaged → Incomplete
Neil J. Patel (njpatel) on 2011-01-27
Changed in unity:
milestone: 3.2.16 → 3.6
Mirco Müller (macslow) wrote :

Greg, can you please verify with current untiy, that is is no longer and issue, so we can mark it as fixed? Thanks in advance!

Paul Sladen (sladen) wrote :

I can reproduce this:

  1. Type 'emacs'.
  2. Emacs starts aligned to the bottom of the screen
  3. Emacs resizes itself to be taller
  4. Bottom of window is now below the bottom of the screen

Alex Launi (alexlauni) on 2011-02-12
Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
tags: added: compiz-0.9
Neil J. Patel (njpatel) on 2011-02-28
Changed in unity:
assignee: Neil J. Patel (njpatel) → Sam "SmSpillaz" Spilsbury (smspillaz)
milestone: 3.6 → 3.6.4
status: Confirmed → Triaged
Didier Roche (didrocks) on 2011-03-01
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Didier Roche (didrocks) on 2011-03-10
Changed in unity:
milestone: 3.6.4 → 3.6.6
Didier Roche (didrocks) on 2011-03-17
Changed in unity:
milestone: 3.6.6 → 3.6.8
Didier Roche (didrocks) on 2011-03-24
Changed in unity:
milestone: 3.6.8 → 3.8
Didier Roche (didrocks) on 2011-03-28
Changed in unity:
milestone: 3.8 → 3.8.2
Omer Akram (om26er) on 2011-03-31
Changed in compiz (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in unity:
milestone: 3.8.2 → 3.8.4
Didier Roche (didrocks) on 2011-04-07
Changed in unity:
milestone: 3.8.4 → 3.8.6
Didier Roche (didrocks) on 2011-04-11
Changed in unity:
milestone: 3.8.6 → 3.8.8
Didier Roche (didrocks) on 2011-04-14
Changed in unity:
milestone: 3.8.8 → 3.8.10
David Barth (dbarth) on 2011-04-18
Changed in unity:
milestone: 3.8.10 → 3.8.12
David Barth (dbarth) wrote :

I don't see the bug anymore. I'll just de-scope for now and mark "invalid". i'm not so sure there was a real fix for it, but it's more a consequence of the numerous fixes that were made on compiz.

Changed in unity:
milestone: 3.8.12 → none
status: Triaged → Invalid
Changed in compiz (Ubuntu):
status: Triaged → Invalid
Changed in unity (Ubuntu):
status: Triaged → Invalid
Changed in unity:
assignee: Sam "SmSpillaz" Spilsbury (smspillaz) → nobody
Didier Roche (didrocks) on 2011-05-27
Changed in unity:
status: Invalid → Fix Committed
Changed in compiz (Ubuntu):
status: Invalid → Fix Committed
Changed in unity (Ubuntu):
status: Invalid → Fix Released
Changed in unity:
milestone: none → 3.8.16
Neil J. Patel (njpatel) on 2011-06-16
Changed in unity:
status: Fix Committed → Fix Released
Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers