Clock / calendar / locations applet opens on wrong position of screen

Bug #631664 reported by Emiel Molenaar
286
This bug affects 57 people
Affects Status Importance Assigned to Milestone
Compiz
Unknown
Unknown
GNOME Panel
Unknown
Medium
Release Notes for Ubuntu
Undecided
Unassigned
compiz (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-panel

What did I expect to happen:

The applet opens at the bottom right of my screen, on top of the panel.

What really happened:

The applet opens at the half left of my screen (see attachment).

Further info:

Fully upgraded beta installation of Maverick (AMD64), upgraded from Lucid with update-manager -d.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gnome-panel 1:2.30.2-1ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Mon Sep 6 17:00:46 2010
GConfNonDefault:
 /apps/panel/general/applet_id_list=[clock_screen0,notification_area_screen0,applet_0]
 /apps/panel/general/object_id_list=[object_3,object_4,object_5]
 /apps/panel/general/toplevel_id_list=[top_panel_screen0]
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gnome-panel

Revision history for this message
Emiel Molenaar (emiel-molenaar) wrote :
Revision history for this message
Pedro Villavicencio (pedro) wrote :

Is this reproducible everytime? could you try with a new user created there? which window manager are you using? compiz or metacity?

Changed in gnome-panel (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
tags: added: likely-dup
removed: clock-applet
Revision history for this message
Emiel Molenaar (emiel-molenaar) wrote :

I've done another dist-upgrade and the problem is fixed now.

Changed in gnome-panel (Ubuntu):
status: Incomplete → Fix Released
Revision history for this message
Kees Cook (kees) wrote :

I have this problem still, on up-to-date maverick. It does not appear to be a problem if the applet is in the upper-right panel instead of the lower-right. This is a regression from Lucid, and a regression from a month or so ago in Maverick.

Changed in gnome-panel (Ubuntu):
status: Fix Released → Confirmed
tags: added: regression-potential
Kees Cook (kees)
Changed in gnome-panel (Ubuntu):
milestone: none → ubuntu-10.10
Revision history for this message
Emiel Molenaar (emiel-molenaar) wrote :

You are right, the problem *was* fixed a few days ago but it's back right now on up-to-date maverick.

Revision history for this message
Jordon Bedwell (envygeeks) wrote :

This seems to have been fixed again.

Revision history for this message
bunghole (mienjung) wrote :

And there it goes again. -_-

Strange shit...

Revision history for this message
Hadrien Dussuel (dbkblk) wrote :

I also have this behavior on an up-to-date maverick. My panel is at the bottom and the applet open -after 2 or 3s- in the right middle of the screen !

Revision history for this message
Luis Nogueira (lnogueir-med) wrote :

I have the same bug! Up-to-date maverick, gnome-panel is at the bottom!

Revision history for this message
Kantastisk (kantastisk) wrote :

this is either a bug with Compiz or gnome, but there seems to be a little confusion over whose "fault" it is.This is the bug report at gnome. https://bugzilla.gnome.org/show_bug.cgi?id=622254

someone opened a new bug at http://bugs.opencompositing.org/show_bug.cgi?id=1307 over at Compiz, but I can't get that site to load (and haven't been able to for a few days now...).

Enough of that, here's a temporary workaround: Go to the "Place Windows" plugin of ccsm and under the tab "Fixed Window Placement" find the box "Windows with fixed positions" and click "new". Select the + icon and under "Type" choose "window title". click your calendar applet, then the "grab"-button and then click your open calendar. the resulting value should be something like "title=Calendar" or whatever it is in your language. Click add and under x and y positions choose the farthest settings to the right. Finally check "Keep in workarea" and you should be good to go.
-Either that or disable compiz and hope for another fix.

Changed in gnome-panel (Ubuntu Maverick):
milestone: ubuntu-10.10 → maverick-updates
Revision history for this message
Vish (vish) wrote :

Heh, I thought i was the only one affected by this bug ;p

I had noticed this bug since RC[fresh install maverick with clean /home]
and have been using the workaround Kantastisk mentions in comment #10 since then.

affects: gnome-panel (Ubuntu) → compiz (Ubuntu)
Vish (vish)
tags: added: regression-release
removed: regression-potential
tags: removed: amd64 apport-bug
Revision history for this message
bunghole (mienjung) wrote :

Thx @ Kantastisk - works fine for me! :)

Revision history for this message
martin (braaart) wrote :

I can confirm this bug is duplicated by bug 656192 which I reported. In answer to the question from Alexander van Loon, yes it is related to desktop effects - just turned them OFF* and my calendar now sits neatly just above the clock and not half off the screen..
*Ubuntu Menu/System/Preferences/Appearance/Visual Effects

[URL=http://brainstorm.ubuntu.com/idea/21924/][IMG]http://brainstorm.ubuntu.com/idea/21924/image/1/[/IMG][/URL]

Revision history for this message
juliobahar (yahalla-julio) wrote :

I happened to see this on 64-bit 10.10 ubuntu not on the 32-bit.
kantastisk solution worked for me. Thanks

Revision history for this message
Thilo Schüller (thilo-schueller) wrote :

Thanks for the workaround in post #10, Kantastisk - worked for me, too!

Revision history for this message
WartHog (tomus-suddenlink) wrote :

Thanks for the workaround.
But regarding the following >>

"Click add and under x and y positions choose the farthest settings to the right.
Finally check "Keep in workarea" and you should be good to go."

Rather than check the keep in workspace box, it might be better to keep that unchecked,
and find and enter the correct numbers for x and y placement.

Revision history for this message
John Kuang (xiphosurus) wrote :

regarding Kantastisk's workaround, using the "Grab" doesn't help get the right window title, resulting in ALL windows opening at the bottom right. to fix that, i manually entered "name=clock-applet" as the value. hope this helps someone.

Revision history for this message
Kantastisk (kantastisk) wrote :

#17

using "title=Calendar" won't make all of your windows open in the bottom right. I think you did something wrong for that to happen (maybe you didn't select the open calendar after selecting grab?). But if "name=clock-applet" works just as well (or even better, somehow?) then peace be upon it.

Revision history for this message
sim909 (srizzi) wrote :

I had the same problem of Kantastisk, trying to grab the calendar results in just an empty "title=", which matches all windows and therefore places all windows in same position. Manually entering "title=Calendar" fixed it. Need to open another bug for the grab function?

Also, 'Click add and under x and y positions choose the farthest settings to the right. Finally check "Keep in workarea" and you should be good to go' didn't work in my dual screen configuration, the calendar was being placed in apparently random corners of my left screen (the laptop), entering sensible numbers as WartHog suggested made it work, plus checking "keep in workarea" makes placement work correctly when I have the extra monitor disconnected. Another bug yet?...

Revision history for this message
Neel (neel2312) wrote :

Thank you Kantastisk, sim909, John Kuang and WartHog.. your comments helped me fix this issue.

Using updated Maverick amd64

Revision history for this message
Danny Trunk (danny-trunk-deactivatedaccount) wrote :

Same here, attached the xprop output.

Revision history for this message
Cd-MaN (x-at-y-or-z) wrote :

I have the same problem with an up-to-date 10.10 and the panel at the bottom. Disabling visual effects fixed it for me (and it is also faster :-)).

Revision history for this message
praveenmarkandu (praveenmarkandu) wrote :

if im not mistaken, the first time i encoutered this problem, i moused over one of the indicator-applets and then clicked the gnome-clock-applet immediately. that is when it first jumped possibly because the indicator applet was in the way and pushed it out of position. cant confirm this though

Revision history for this message
tellapu (tellapu) wrote :

@martin: Thanks that works for me as well (desktop effects - just turned them OFF* and my calendar now sits neatly just above the clock and not half off the screen.. *Ubuntu Menu/System/Preferences/Appearance/Visual Effects)

BUT every time I boot the computer it will go back to natural visual effects (and I have the problem again), is there a way to change it permanently to visual effects NONE?

Revision history for this message
martin (braaart) wrote :

Hmm, not sure. For me it stays off after rebooting, and I guess all those kinds of settings should return after a reboot as you left them before shutdown. Perhaps another program you are using is controlling Compiz? If you don't get an answer from someone here you could try posting a question in Answers.

Revision history for this message
tellapu (tellapu) wrote :

@martin (25): thanks for an answer. Answers? Do you mean answers.com??

Revision history for this message
martin (braaart) wrote :

No, sorry, I meant the section of launchpad where you can post a question about something if it's not a bug. Just click on Answers at the top of this page and you get questions related to Compiz or go to https://answers.launchpad.net/ubuntu/

Revision history for this message
tellapu (tellapu) wrote :

I see, thanks for the tip! This morning I tried to change some effects in the Compiz settings manager, but no success.

Revision history for this message
Tomasz Bywalec (t-bywalec) wrote :

I have the same issue on Maverick, with gnome-panel placed at the bottom of the screen and clock applet in the right part of panel - after opening dropdown, it is displayed at the top of the screen (and only part of it is visible). Fortunately, Kantastisk's workaround did the trick for me.

Revision history for this message
Andrew Cowie (afcowie) wrote :

Bug still entent on Maverick. Shouldn't need to be doing window placement workaournds; Last time I checked the clock applet is GDK_WINDOW_TYPE_HINT_DOCK and if so, Compiz is in error by repositioning it to the middle of the right-hand side. It should be docked on the panel.

AfC

Victor Vargas (kamus)
Changed in compiz (Ubuntu):
status: Confirmed → Triaged
Revision history for this message
Andrzej Kłapeć (solidslash) wrote :

Also present in Natty.

tags: added: natty
Changed in compiz (Ubuntu):
milestone: maverick-updates → natty-alpha-3
Revision history for this message
Craig (craig-rouse) wrote :

Thanks for the workaround Kantastisk. Very minor, but incredibly annoying bug!

Revision history for this message
Sam_ (and-sam) wrote :

Regarding comment #10 from Kantastisk, thanks a lot for the idea of the workaround. Have already alacarte, gconf-editor a.o. in there, but didn't think of adding clock-applet.
Open CCSM, plugin 'place'.
http://wiki.compiz.org/Plugins/Place

Click on clock applet. (here on bottom panel)

Open a terminal:
$ xprop|grep WM_CLASS|cut -d\" -f4
Clock-applet

## After the cmd, cursor turns into a cross, click on clock-applet which reveals window class.
On 1680x1050 screen I placed it beside the right panel: class=Clock-applet, x 1251, y 167
and I'll leave it right there - compiz rules.

Revision history for this message
tellapu (tellapu) wrote :

Thanks a lot Kantastisk (#10)! I waited first for a fix, but I realized that this will take a while ...

Revision history for this message
Sadashiv (sadashiv-30) wrote :

Thanks kantastisk !. It works now. I guess its the problem of Compiz :) .Hope they fix it in Natty!

Revision history for this message
Sam Spilsbury (smspillaz) wrote : Re: [Compiz] [Bug 631664] Re: Clock / calendar / locations applet opens on wrong position of screen

On Thu, Dec 30, 2010 at 11:48 AM, Sadashiv <email address hidden> wrote:
> Thanks kantastisk !. It works now.  I guess its the problem of Compiz :)
> .Hope they fix it in Natty!
>

It is fixed in natty.

> --
> You received this bug notification because you are a member of compiz
> packagers, which is subscribed to compiz in ubuntu.
> https://bugs.launchpad.net/bugs/631664
>
> Title:
>  Clock / calendar / locations applet opens on wrong position of screen
>
> _______________________________________________
> Mailing list: https://launchpad.net/~compiz
> Post to     : <email address hidden>
> Unsubscribe : https://launchpad.net/~compiz
> More help   : https://help.launchpad.net/ListHelp
>

--
Sam Spilsbury

Changed in compiz (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Zamiere Vonthokikkeiin (kikkeartworx) wrote :

Workaround without ccsm:

gconftool-2 -t list -s --list-type=bool /apps/compiz/plugins/place/screen0/options/position_constrain_workarea [true]
gconftool-2 -t list -s --list-type=string /apps/compiz/plugins/place/screen0/options/position_matches ["name=clock-applet"]
gconftool-2 -t list -s --list-type=int /apps/compiz/plugins/place/screen0/options/position_x_values [32767]
gconftool-2 -t list -s --list-type=int /apps/compiz/plugins/place/screen0/options/position_y_values [32767]

Changed in gnome-panel:
importance: Unknown → Medium
stoja (stojabreak)
Changed in ubuntu-release-notes:
status: New → Incomplete
Steve Langasek (vorlon)
Changed in ubuntu-release-notes:
status: Incomplete → New
Revision history for this message
Patrick Dickey (pdickeybeta) wrote :

I can confirm this still happens in Ubuntu 10.10 x86 with all of the available updates (as of April 1, 2011 at 2100 UTC). I have a third panel which I added to the right side of the screen, and that started it for me. However moving the panel to any other location does not fix this issue. I haven't tried deleting the panel though.

Revision history for this message
Vladimir (vzmname-ya) wrote :

I had the same problem, but when I did what Zamiere Vonthokikkeiin wrote in #37 answer, everything became great. Maybe somebody knows which file contains these lines? I want to add it to distribution with UCK.

Revision history for this message
Sam_ (and-sam) wrote :

Vladimir,
GUI: CCSM -> preferences
allows to save profiles.
Manual settings in gconf-editor via gconftool are in a .xml file.
~/.gconf/apps/compiz/plugins/place/screen0/options

Revision history for this message
Vladimir (vzmname-ya) wrote :

Thank you very much Sam_

Revision history for this message
Andrew Cowie (afcowie) wrote :

Can the uptream fix that's been included in Natty be backported or patched into the Maverick package?

AfC

Revision history for this message
Bartlomiej (bartoleo) wrote :

I had the same problem on 10.10 x64, thanks Zamiere Vonthokikkeiin i've solved. For me his method is easiest. Tanks!

Revision history for this message
Colin Watson (cjwatson) wrote :

I don't think this ever needed a release note (it's annoying, but cosmetic), but in any case since it's fixed in Natty it doesn't need a Natty release note.

Changed in ubuntu-release-notes:
status: New → Invalid
Revision history for this message
Luc Pi (oluc) wrote :

(its not cosmetic, in some cases (vertical panel) the menu is out of the screen = unusable)

Adolfo Jayme (fitojb)
no longer affects: compiz (Ubuntu Maverick)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.