Typo in "protanopia" color filter

Bug #599206 reported by Gael Lafond on 2010-06-28
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned
compiz-fusion-plugins-main (Ubuntu)
Undecided
Unassigned
compizconfig-settings-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: compiz

There is a Typo in "protanopia" color filter. It is spell "protonopia" in the configuration interface. The filter file is spell correctly so the filter is not working unless you rename it to "protanopia" in the graphical configuration interface (executable /usr/bin/ccsm).

Reproduce the Bug
1
. Load ccsm
2. Activate color filter by checking the box
3. Click color filter to configure it
4. Delete a few filter to have an idea of that filter is activated (keep "grayscale" and "protonopia")
5. Press keys <Super>f or <Super>d to activate the filter
6. Press keys <Ctrl><Super>s to switch between the 2 filters
You will notice that you can have Grayscale (twice due to an other Bug I guess) and a not found filter without any error message that will just display the normal screen as if the color filter was disabled.

Solution:
1. Load ccsm
2. Click Color filter to configure it
3. Click on "protonopia" filter
4. Click on Edit button
5. Rename it to "protanopia"
6. Close the interface

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: compiz 1:0.8.4-0ubuntu15
ProcVersionSignature: Ubuntu 2.6.32-22.36-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
CompizPlugins: [core,ccp,move,resize,place,decoration,gnomecompat,session,commands,mousepoll,colorfilter,text,png,dbus,vpswitch,workarounds,neg,resizeinfo,imgjpeg,regex,svg,snap,wall,animation,expo,fade,ezoom,scale,scaleaddon,staticswitcher]
Date: Mon Jun 28 13:38:58 2010
ProcEnviron:
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: compiz

Gael Lafond (gaellafond) wrote :
Gael Lafond (gaellafond) wrote :

Sorry for the noise: The debug info and logs files had been automatically added, but they are not needed. I can't find how to delete them.

description: updated
Alan Bell (alanbell) on 2010-10-30
Changed in compiz (Ubuntu):
status: New → Confirmed
Alan Bell (alanbell) wrote :

think the bug is in ccsm rather than compiz itself

Changed in compizconfig-settings-manager (Ubuntu):
status: New → Confirmed

Just fixed it upstream ;-)

http://git.compiz.org/compiz/plugins/colorfilter/commit/?id=d385c10d93798c5d4221b8e535151492ab59c28f

On Sun, Oct 31, 2010 at 12:01 AM, Alan Bell <email address hidden> wrote:
> ** Changed in: compiz (Ubuntu)
>       Status: New => Confirmed
>
> --
> Typo in "protanopia" color filter
> https://bugs.launchpad.net/bugs/599206
> You received this bug notification because you are a member of compiz
> packagers, which is subscribed to compiz in ubuntu.
>
> _______________________________________________
> Mailing list: https://launchpad.net/~compiz
> Post to     : <email address hidden>
> Unsubscribe : https://launchpad.net/~compiz
> More help   : https://help.launchpad.net/ListHelp
>

--
Sam Spilsbury

Alan Bell (alanbell) wrote :

yup, the upstream fix looks good, line 41 of compiz-fusion-plugins-main-0.8.6/metadata/colorfilter.xml.in
            <value>protonopia</value>

Changed in compiz (Ubuntu):
status: Confirmed → Incomplete
status: Incomplete → Invalid
Changed in compizconfig-settings-manager (Ubuntu):
status: Confirmed → Invalid
Changed in compiz-fusion-plugins-main (Ubuntu):
status: New → Confirmed
Sam Spilsbury (smspillaz) wrote :

It's a typo in the xml file, and has been fixed upstream, like I said.

On Sun, Oct 31, 2010 at 12:13 AM, Alan Bell <email address hidden> wrote:
> think the bug is in ccsm rather than compiz itself
>
> ** Also affects: compizconfig-settings-manager (Ubuntu)
>   Importance: Undecided
>       Status: New
>
> ** Changed in: compizconfig-settings-manager (Ubuntu)
>       Status: New => Confirmed
>
> --
> Typo in "protanopia" color filter
> https://bugs.launchpad.net/bugs/599206
> You received this bug notification because you are a member of compiz
> packagers, which is subscribed to compiz in ubuntu.
>
> _______________________________________________
> Mailing list: https://launchpad.net/~compiz
> Post to     : <email address hidden>
> Unsubscribe : https://launchpad.net/~compiz
> More help   : https://help.launchpad.net/ListHelp
>

--
Sam Spilsbury

Alan Bell (alanbell) wrote :

tested in Natty, works a treat

Changed in compiz-fusion-plugins-main (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers