Compiz application switcher uses blurry, pixelated icons

Bug #598861 reported by Tomasz Chrzczonowicz on 2010-06-26
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: compiz

Steps to reproduce:

1. Enable Compiz
2. Minimize some apps
3. Invoke application switcher (ALT+TAB)

What happens:

The minimized applications are represented with blurry, pixelated icons that look awful.

What should happen:

The minimized applications should be represented with properly looking icons.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: compiz 1:0.8.4-0ubuntu15
ProcVersionSignature: Ubuntu 2.6.32-22.36-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
Architecture: amd64
CompizPlugins: [core,ccp,move,resize,place,decoration,workarounds,maximumize,neg,text,grid,gnomecompat,commands,vpswitch,svg,titleinfo,imgjpeg,regex,dbus,resizeinfo,session,mousepoll,png,loginout,animation,wall,expo,fade,ezoom,scale,scaleaddon,staticswitcher]
Date: Sat Jun 26 19:10:28 2010
EcryptfsInUse: Yes
MachineType: O.E.M O.E.M
PackageArchitecture: all
PciDisplay: 00:02.0 VGA compatible controller [0300]: Intel Corporation 4 Series Chipset Integrated Graphics Controller [8086:2e32] (rev 03)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-22-generic root=UUID=4178e655-dc39-4c41-9969-3923cb603471 ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=pl_PL.utf8
 SHELL=/bin/bash
RelatedPackageVersions:
 xserver-xorg 1:7.5+5ubuntu1
 libgl1-mesa-glx 7.7.1-1ubuntu3
 libdrm2 2.4.18-1ubuntu3
 xserver-xorg-video-intel 2:2.9.1-3ubuntu5
 xserver-xorg-video-ati 1:6.13.0-1ubuntu5
SourcePackage: compiz
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
dmi.bios.date: 06/30/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 080015
dmi.board.name: G41S/G41S-K
dmi.board.vendor: FOXCONN
dmi.board.version: 1.0
dmi.chassis.type: 3
dmi.chassis.vendor: O.E.M
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr080015:bd06/30/2009:svnO.E.M:pnO.E.M:pvr:rvnFOXCONN:rnG41S/G41S-K:rvr1.0:cvnO.E.M:ct3:cvr:
dmi.product.name: O.E.M
dmi.sys.vendor: O.E.M
system: distro = Ubuntu, architecture = x86_64, kernel = 2.6.32-22-generic

Tomasz Chrzczonowicz (tch) wrote :
qwerty (matiasjrossi) wrote :

Come on!! No one else ever noticed this? Compiz is great, but the switcher always looked like crap.

Travis Watkins (amaranth) wrote :

Compiz can only use the icons the application tells X about. These apps are expecting their icons to only be shown on a 24px panel so they set low resolution icons.

Changed in compiz (Ubuntu):
status: New → Invalid

For the record, KDE applications show 128x128 icons.

On Tue, Dec 28, 2010 at 3:57 AM, Travis Watkins <email address hidden> wrote:
> Compiz can only use the icons the application tells X about. These apps
> are expecting their icons to only be shown on a 24px panel so they set
> low resolution icons.
>
> ** Changed in: compiz (Ubuntu)
>       Status: New => Invalid
>
> --
> You received this bug notification because you are a member of compiz
> packagers, which is subscribed to compiz in ubuntu.
> https://bugs.launchpad.net/bugs/598861
>
> Title:
>  Compiz application switcher uses blurry, pixelated icons
>
> _______________________________________________
> Mailing list: https://launchpad.net/~compiz
> Post to     : <email address hidden>
> Unsubscribe : https://launchpad.net/~compiz
> More help   : https://help.launchpad.net/ListHelp
>

--
Sam Spilsbury

Tomasz Chrzczonowicz (tch) wrote :

@Travis: So what can be done about it? Should we report bugs against every application that does this? Or is this GNOME system-wide policy?

Sam Spilsbury (smspillaz) wrote :

On Fri, Jan 7, 2011 at 12:20 PM, Tomasz Chrzczonowicz
<email address hidden> wrote:
> @Travis: So what can be done about it? Should we report bugs against
> every application that does this? Or is this GNOME system-wide policy?
>

The options are:

1) Wait for the new spread stuff to land where we'll use bamf for hi-res icons
2) Make window->getIcon wrappable, create a plugin to use bamf to get
the hi-res icon
3) Ask GNOME nicely to make their _NET_WM_ICON a bit bigger :)

> --
> You received this bug notification because you are a member of compiz
> packagers, which is subscribed to compiz in ubuntu.
> https://bugs.launchpad.net/bugs/598861
>
> Title:
>  Compiz application switcher uses blurry, pixelated icons
>
> _______________________________________________
> Mailing list: https://launchpad.net/~compiz
> Post to     : <email address hidden>
> Unsubscribe : https://launchpad.net/~compiz
> More help   : https://help.launchpad.net/ListHelp
>

--
Sam Spilsbury

Tomasz Chrzczonowicz (tch) wrote :

> The options are:
>
> 1) Wait for the new spread stuff to land where we'll use bamf for hi-res icons
> 2) Make window->getIcon wrappable, create a plugin to use bamf to get
> the hi-res icon
> 3) Ask GNOME nicely to make their _NET_WM_ICON a bit bigger :)

I'm sorry, but I'm not a hacker, neither am I knowledgeable about X and
GTK. Could you please explain what that means for and end user?

Also, I run GNOME Shell that is packaged for Maverick, and the icons in
its task switcher are of similar size to that of Compiz task switcher
icons, and yet they don't have this problem. Please see enclosed
screenshot.

BTW can't this _NET_WM_ICON property be set in Ubuntu? Would that mean
patching every GTK application?

Sam Spilsbury (smspillaz) wrote :

On Fri, Jan 7, 2011 at 2:57 PM, Tomasz Chrzczonowicz
<email address hidden> wrote:
>> The options are:
>>
>> 1) Wait for the new spread stuff to land where we'll use bamf for hi-res icons
>> 2) Make window->getIcon wrappable, create a plugin to use bamf to get
>> the hi-res icon
>> 3) Ask GNOME nicely to make their _NET_WM_ICON a bit bigger :)
>
> I'm sorry, but I'm not a hacker, neither am I knowledgeable about X and
> GTK. Could you please explain what that means for and end user?

All applications set a window property which contains pixel data about their
application icon, so that window managers and task switchers can display
that icon where it is appropriate.

>
> Also, I run GNOME Shell that is packaged for Maverick, and the icons in
> its task switcher are of similar size to that of Compiz task switcher
> icons, and yet they don't have this problem. Please see enclosed
> screenshot.

Unfortunately it seems like g-s is using the desktop file to get the big icon
and not using _NET_WM_ICON (or updating their applications for big icons).

This behavior is non standards compliant.

>
> BTW can't this _NET_WM_ICON property be set in Ubuntu? Would that mean
> patching every GTK application?
>
>
> ** Attachment added: "gnome-shell-task-switcher.png"
>   https://bugs.launchpad.net/bugs/598861/+attachment/1786679/+files/gnome-shell-task-switcher.png
>
> --
> You received this bug notification because you are a member of compiz
> packagers, which is subscribed to compiz in ubuntu.
> https://bugs.launchpad.net/bugs/598861
>
> Title:
>  Compiz application switcher uses blurry, pixelated icons
>
> _______________________________________________
> Mailing list: https://launchpad.net/~compiz
> Post to     : <email address hidden>
> Unsubscribe : https://launchpad.net/~compiz
> More help   : https://help.launchpad.net/ListHelp
>

--
Sam Spilsbury

Changed in compiz (Ubuntu):
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers