cannot drag windows by titlebar across workspaces

Bug #557547 reported by Sébastien Pierre on 2010-04-07
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: compiz

Upgrading to 10.04 or clean install of 10.04.2 isnt possible to drag windows draging by titlebar across workspaces (I'm using compiz):

 - Move to the first workspace (out of 2 or more)
 - Open a new window
 - Drag the window by the title bar, and move it to the right edge

Expected behaviour: after a fraction of second, I should be on the 2nd workspace with the dragged window still under my cursor
What happens: I stay on the same workspace, so I have to switch to "Expose" view, as I can't also drag the windows using the Workspace switcher.

There might be an option, but I'm not aware of it -- and it's a regression from 9.10 in my case.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: compiz-core 1:0.8.4-0ubuntu13
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic i686
Architecture: i386
CompizPlugins: [core,ccp,move,resize,place,decoration,dbus,mousepoll,gnomecompat,png,svg,imgjpeg,text,commands,neg,wall,snap,animation,scale,scaleaddon,expo,staticswitcher,regex,resizeinfo,workarounds,ezoom,vpswitch,fade,session]
Date: Wed Apr 7 14:59:22 2010
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
MachineType: LENOVO 7448CTO
PciDisplay: 00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-19-generic root=UUID=ec9b3a13-7e3f-44d4-b7a4-0454de0aefc9 ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=fr_CA.utf8
 SHELL=/usr/bin/zsh
RelatedPackageVersions:
 xserver-xorg 1:7.5+3ubuntu1
 libgl1-mesa-glx 7.7-4ubuntu1
 libdrm2 2.4.18-1ubuntu2
 xserver-xorg-video-intel 2:2.9.1-3ubuntu1
 xserver-xorg-video-ati 1:6.12.192-2ubuntu2
SourcePackage: compiz
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
dmi.bios.date: 12/19/2008
dmi.bios.vendor: LENOVO
dmi.bios.version: 7WET31WW (2.02 )
dmi.board.name: 7448CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr7WET31WW(2.02):bd12/19/2008:svnLENOVO:pn7448CTO:pvrThinkPadX200T:rvnLENOVO:rn7448CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 7448CTO
dmi.product.version: ThinkPad X200T
dmi.sys.vendor: LENOVO
system: distro = Ubuntu, architecture = i686, kernel = 2.6.32-19-generic

Travis Watkins (amaranth) wrote :

This is an intentional change. Per https://wiki.ubuntu.com/OneHundredPaperCuts/Spec/495687 :

"Edge flipping on move is disabled because (1) it can be triggered accidentally and confuse users, (2) it is a bit awkward to use, and (3) it's not symmetrical (it's disabled on the top edge because it is too easy to perform accidentally there)."

You can change this by installing compizconfig-settings-manager and enabling this feature again.

Changed in compiz (Ubuntu):
status: New → Invalid
Changed in compiz (Ubuntu):
status: Invalid → Confirmed
Kangarooo Jānis (kangarooo) wrote :

Travis u do realize thats no reason- look at 11.04 people beeing pressed to use what they dont want.
Here its needed that people know workspaces and therefor theres no need to disable this funcionality.
It was made couse its good. SO its a regresion.
BTW if theres anyone who can be confused thats a user who wants 1 workspace so he can make 4 to 1.

description: updated
summary: - cannot drag windows across workspaces
+ cannot drag windows by titlebar across workspaces

@Kangarooo, please observe the code of conduct. This has been a design decision and can be configured via CCSM. Thank you for the bug report.

Changed in compiz (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers