No audio feedback for keyboard a11y features

Bug #514943 reported by Luca Ferretti on 2010-01-31
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-control-center

No sound or audio is played for keyboard accessibility features (sticky, slow and bounce keys).

Steps to reproduce:
 * Open System -> Preferences -> Keyboard
 * Select Accessibility tab
 * Activate "Simulate simultaneous keypresses"
 * Clic "Audio Feedback" button
 * Activate "Beep when a modifier key is pressed"
 * Press Shift or Ctrl key

Expected result
 The system should play a sound (or pc speaker should beep)

Current result
 No sound

ProblemType: Bug
Architecture: amd64
Date: Sun Jan 31 01:21:09 2010
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
NonfreeKernelModules: fglrx
Package: gnome-control-center 1:2.28.1-0ubuntu1
ProcEnviron:
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-17.54-generic
SourcePackage: gnome-control-center
Uname: Linux 2.6.31-17-generic x86_64

Luca Ferretti (elle.uca) wrote :
Luca Ferretti (elle.uca) wrote :

Reassigning to compiz. Switching to metacity the audio feedback works properly.

affects: gnome-control-center (Ubuntu) → compiz (Ubuntu)
Travis Watkins (amaranth) wrote :

Does this still happen in lucid? I have a feeling it is the same "compiz doesn't use libcanberra, pulseaudio doesn't reroute Xorg PC speaker beeps to it's own sound" problem as bug 301174. If so the pulseaudio side was fixed which makes up for compiz not supporting this DE-specific library in its core code (probably never going to happen).

Changed in compiz (Ubuntu):
status: New → Incomplete
Luca Ferretti (elle.uca) wrote :

I tried to run compiz in my VirtualBox virtual machine, but it failed (at least it was totally unusable). I'll try to ask to someone with a lucid "real" installation

arky (arky) wrote :

Able to reproduce this bug in lucid

Changed in compiz (Ubuntu):
status: Incomplete → Confirmed

Still reproducible in Oneiric

Socket (nick-regist) wrote :

Even in Precise (12.04.1) is still not working

Nicola Larosa (teknico) wrote :

I confirm comment #3: after fixing bug #301174, the accessibility beeps work too.

They seem to be implemented using XBell: the command "xset b [0-100]" sets their volume, while the "System Sounds" slider in pavucontrol does not.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers