[i945] Compiz desktop freezes using Intel 82945G/GZ Integrated Graphics and i915 driver

Bug #492271 reported by Marcelo Lotif on 2009-12-04
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned
Karmic
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned
Karmic
High
Unassigned

Bug Description

Binary package hint: compiz

I've upgraded from Jaunty to Karmic and since then my machine is locking every time i try to enable compiz effects through System > Preferences > Appearance, tab Visual Effects. Selecting any option but "No Effects" will cause the system to totally lock up: screen locked, mouse not moving, keyboard not responding (caps lock or num lock leds not responding when pressing the keys), hit the power button cause no effect, I have to turn the machine off by holding the power button and turn it on again.

I'm using ubuntu in this machine since the 8.04 version (compiz almost fully enabled), everything was working fine until I upgraded to Karmic.

My machine specs are the following (from the HardInfo program):
Computer: Compaq Presario PC SG3310BR
Processor: Intel Celeron 430 1.8 GHZ
Memory: 1535 MB
Operating System: Ubuntu 9.10
Resolution: 1152x864
Monitor: AOC Spectrum 4Vn
OpenGL Renderer: Mesa DRI Intel 945G GEM 20090712 2009Q2 RC3 x86/MMX/SSE2
XOrg Version: 1.6.4
VGA Compatible Controller: Intel Corporation 82945G/GZ Integrated Graphics Controller, Kernel Modules - i915

UPDATE:
If your hardware is any different than this, it's recommended to file a separate bug report for your issue and mention this or another possible duplicate issues in the bug description.
Some people are collecting important data to solve this issue in a wiki page:
https://wiki.ubuntu.com/X/Lucidi945Freezes
If you experience similar problems with Karmic+this graphic card, it's recommended to make some tests and fill the table that's in this wiki page.

Nigel Babu (nigelbabu) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it without more information.

Please run the command 'apport-collect BUGNUMBER' which will attach necessary information.

Changed in compiz (Ubuntu):
status: New → Incomplete

Architecture: i386
CompizPlugins: [core,move,resize,place,decoration,animation,ccp,dbus,mousepoll,gnomecompat,png,svg,imgjpeg,text,commands,neg,video,wall,snap,scale,scaleaddon,expo,staticswitcher,regex,resizeinfo,workarounds,ezoom,vpswitch,extrawm,fade,session]
DistroRelease: Ubuntu 9.10
MachineType: Compaq-Presario KQ381AA-AC4 SG3310BR
Package: compiz 1:0.8.4-0ubuntu2
PackageArchitecture: all
PciDisplay: 00:02.0 VGA compatible controller [0300]: Intel Corporation 82945G/GZ Integrated Graphics Controller [8086:2772] (rev 02)
ProcCmdLine: root=UUID=9bfcdb30-7d8e-4550-a11d-f03f1faa53d0 ro locale=pt_BR i915.modeset=0 quiet splash
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=pt_BR.UTF-8
 LANGUAGE=pt_BR.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu7
 libgl1-mesa-glx 7.6.0-1ubuntu4
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.0-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
Uname: Linux 2.6.31-14-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 11/26/2007
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: v5.13
dmi.board.name: Lucknow
dmi.board.vendor: Foxconn
dmi.board.version: 1.0
dmi.chassis.type: 3
dmi.chassis.vendor: Foxconn
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrv5.13:bd11/26/2007:svnCompaq-Presario:pnKQ381AA-AC4SG3310BR:pvr:rvnFoxconn:rnLucknow:rvr1.0:cvnFoxconn:ct3:cvr:
dmi.product.name: KQ381AA-AC4 SG3310BR
dmi.sys.vendor: Compaq-Presario
system: distro = Ubuntu, architecture = i686, kernel = 2.6.31-14-generic

Changed in compiz (Ubuntu):
status: Incomplete → New
tags: added: apport-collected

Marcelo, are you using the default video drivers, or did you install some other drivers?

Marcelo Lotif (mlotifjava) wrote :

I think I have the default drivers. There's nothing on System > Administration > Hardware drivers.

Marcelo Lotif (mlotifjava) wrote :

And I've installed no driver since the OS install.

WeatherGod (ben-v-root) wrote :

Marcelo, just so that you are aware, I am waiting for more information from other people with similar issue that you have. I am not ignoring your report.

Marcelo Lotif (mlotifjava) wrote :

Ok!

Thank you for the attention.

Olivier PONCET (ponceto) wrote :

Same problem for me.

When compiz is running on a i945 based motherboard, the X server freeze short after logging. The only way to resolve this trouble, is to disable compiz.

Architecture: i386
CompizPlugins: [core,move,resize,place,decoration,animation,ccp,dbus,mousepoll,gnomecompat,png,svg,imgjpeg,text,commands,neg,video,wall,snap,scale,scaleaddon,expo,staticswitcher,regex,resizeinfo,workarounds,ezoom,vpswitch,extrawm,fade,session]
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
MachineType: MSI MS-7267
Package: compiz 1:0.8.4-0ubuntu2
PackageArchitecture: all
PciDisplay: 00:02.0 VGA compatible controller [0300]: Intel Corporation 82945G/GZ Integrated Graphics Controller [8086:2772] (rev 02)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-16-generic root=UUID=f8b32010-01d1-471e-8446-b733af935e8f ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 LANG=fr_FR.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-16.53-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu10
 libgl1-mesa-glx 7.6.0-1ubuntu4
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.0-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
Uname: Linux 2.6.31-16-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
dmi.bios.date: 11/29/2007
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: V17.7
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: MS-7267
dmi.board.vendor: MSI
dmi.board.version: 4.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrV17.7:bd11/29/2007:svnMSI:pnMS-7267:pvr4.0:rvnMSI:rnMS-7267:rvr4.0:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: MS-7267
dmi.product.version: 4.0
dmi.sys.vendor: MSI
system: distro = Ubuntu, architecture = i686, kernel = 2.6.31-16-generic

33 comments hidden view all 113 comments
WeatherGod (ben-v-root) on 2010-01-13
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed

WeatherGod: Looks like the people are seeing this bug report and doing the apport-collect thing without reading the comments. Should I edit the bug description and put a recommendation to file a separate bug report for each new case and put the wiki link to spread the idea to the people?

On Wed, Jan 13, 2010 at 05:32:56PM -0000, Marcelo Lotif wrote:
> Looks like the people are seeing this bug report and doing
> the apport-collect thing without reading the comments.
---end quoted text---

I did the apport-collect thing after I checked that I have the same
graphics controller as the original reporter.

--
 ‎أحمد المحمودي (Ahmed El-Mahmoudy)
  Digital design engineer
 GPG KeyID: 0xEDDDA1B7 (@ subkeys.pgp.net)
 GPG Fingerprint: 8206 A196 2084 7E6D 0DF8 B176 BC19 6A94 EDDD A1B7

right, but what I think he's trying to do is separate your bug report to collect more information from you. The problem may or may not be in your graphics card, it may also depends from other important information from your system. I don't know, I'm just asking if it's better, he understand more from the inner working, what he says it's better, it's probably the best way to go.

WeatherGod (ben-v-root) wrote :

As a general rule, it is a good idea to file separate bugs for different hardwares. Even better would be to mention in the description for the new bug report the possible similarity to an existing bug report.

In this case, I think we are ok, as you are both using the same onboard intel graphics controlers.

WeatherGod (ben-v-root) on 2010-01-13
summary: - ubuntu 9.10 totally freezes when compiz is enabled
+ Compiz desktop freezes using Intel 82945G/GZ Integrated Graphics and
+ i915 driver
description: updated
Bryce Harrington (bryce) on 2010-01-18
summary: - Compiz desktop freezes using Intel 82945G/GZ Integrated Graphics and
- i915 driver
+ [i945] Compiz desktop freezes using Intel 82945G/GZ Integrated Graphics
+ and i915 driver
Bryce Harrington (bryce) on 2010-02-25
tags: added: lucid
Bryce Harrington (bryce) on 2010-02-27
tags: added: freeze
tags: added: compiz
Bryce Harrington (bryce) on 2010-03-02
summary: - [i945] Compiz desktop freezes using Intel 82945G/GZ Integrated Graphics
- and i915 driver
+ [i945] [i945] Compiz desktop freezes using Intel 82945G/GZ Integrated
+ Graphics and i915 driver
Bryce Harrington (bryce) on 2010-03-02
summary: - [i945] [i945] Compiz desktop freezes using Intel 82945G/GZ Integrated
- Graphics and i915 driver
+ [i945] Compiz desktop freezes using Intel 82945G/GZ Integrated Graphics
+ and i915 driver
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Thanks for reporting this bug to help making the Intel graphics driver
better. We hear from upstream that a number of bugs (possibly including
this one) have been fixed in the newer DRM code from the 2.6.33 kernel.
I don't know if your bug is one of the ones fixed in this release,
though, but we've prepared a PPA with this DRM update. Would you mind
installing this, rebooting, and testing if the original issue can be
reproduced with it or not?

The DRM PPA is here:

    https://edge.launchpad.net/~apw/+archive/red

Note there could be new bugs... please file these as new reports using
the command 'ubuntu-bug linux' (for kernel or DRM or KMS bugs) or
'ubuntu-bug xorg' if you suspect them to be X.org issues.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete

Hello,

On Fri, Mar 05, 2010 at 02:03:12AM -0000, Bryce Harrington wrote:
> I don't know if your bug is one of the ones fixed in this release,
> though, but we've prepared a PPA with this DRM update. Would you mind
> installing this, rebooting, and testing if the original issue can be
> reproduced with it or not?
>
> The DRM PPA is here:
>
> https://edge.launchpad.net/~apw/+archive/red
---end quoted text---

  The bug is on a karmic installation not lucid. Hence the packages
  there won't help I'm afraid.

--
 ‎أحمد المحمودي (Ahmed El-Mahmoudy)
  Digital design engineer
 GPG KeyID: 0xEDDDA1B7
 GPG Fingerprint: 8206 A196 2084 7E6D 0DF8 B176 BC19 6A94 EDDD A1B7

Bryce Harrington (bryce) wrote :

Ahmed, very well, then I'll set a karmic task and close out the lucid one.

Anyone with an issue similar to this but on lucid please file a NEW bug using 'ubuntu bug xorg'.

Changed in xserver-xorg-video-intel (Ubuntu Karmic):
status: New → Confirmed
importance: Undecided → High
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Fix Released

Architecture: i386
CheckboxSubmission: d29cec1195810bbf76a8e3ebc5948333
CheckboxSystem: abf102d6ef41328208f5c1554651535a
CompizPlugins: [core,workarounds,dbus,resize,crashhandler,mousepoll,decoration,svg,wall,place,png,text,imgjpeg,move,regex,animation,scale,expo,ezoom,switcher]
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
MachineType: Dell Computer Corporation Dimension 2400
Package: xserver-xorg-video-intel 2:2.9.0-1ubuntu2.1
PackageArchitecture: i386
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-20-generic root=UUID=8aeac3db-0417-4cca-860c-4d282f6740ac ro nomodeset quiet splash
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-20.58-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu10
 libgl1-mesa-glx 7.6.0-1ubuntu4
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.0-1ubuntu2.1
 xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
Uname: Linux 2.6.31-20-generic i686
UserGroups: adm admin audio cdrom dialout fuse lpadmin netdev plugdev root sambashare vboxusers
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
XsessionErrors:
 (gnome-settings-daemon:1937): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (nautilus:1972): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (polkit-gnome-authentication-agent-1:1998): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (gnome-panel:1971): Gdk-WARNING **: /build/buildd/gtk+2.0-2.18.3/gdk/x11/gdkdrawable-x11.c:952 drawable is not a pixmap or window
 (firefox:15741): GLib-WARNING **: g_set_prgname() called multiple times
dmi.bios.date: 12/02/2003
dmi.bios.vendor: Dell Computer Corporation
dmi.bios.version: A05
dmi.board.name: 0C2425
dmi.board.vendor: Dell Computer Corp.
dmi.board.version: A01
dmi.chassis.type: 15
dmi.chassis.vendor: Dell Computer Corporation
dmi.modalias: dmi:bvnDellComputerCorporation:bvrA05:bd12/02/2003:svnDellComputerCorporation:pnDimension2400:pvr:rvnDellComputerCorp.:rn0C2425:rvrA01:cvnDellComputerCorporation:ct15:cvr:
dmi.product.name: Dimension 2400
dmi.sys.vendor: Dell Computer Corporation
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-20-generic

Pedro Villavicencio (pedro) wrote :

Thanks for the report, it has been some time without any response or feedback in this bug report and we are wondering if this is still an issue for you with the latest release of Ubuntu the Natty Narwhal, May you please test with that version and comment back if you're still having or not the issue? Please have a look at http://www.ubuntu.com/download to know how to install that version.Thanks in advance.

Changed in compiz (Ubuntu):
status: New → Incomplete
Changed in compiz (Ubuntu Karmic):
status: New → Incomplete
Rolf Leggewie (r0lf) on 2011-10-19
Changed in xserver-xorg-video-intel (Ubuntu Karmic):
status: Confirmed → Won't Fix
Changed in compiz (Ubuntu Karmic):
status: Incomplete → Won't Fix
Displaying first 40 and last 40 comments. View all 113 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments