[compiz] applets with Dock type window leave shadow

Bug #449272 reported by darthanubis on 2009-10-12
64
This bug affects 12 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Low
Unassigned
Nominated for Karmic by Mike Pelley
gnome-applets (Ubuntu)
Low
Unassigned
Nominated for Karmic by Mike Pelley
gnome-utils (Ubuntu)
Low
Unassigned
Nominated for Karmic by Mike Pelley

Bug Description

Binary package hint: compiz

Steps to reproduce this sub-bug:

1. Add GNOME Invest applet to a panel.
2. In its preferences, add some stock symbols, like GOOG, AMD, INTC (thanks darthanubis in #ubuntu+1 for these sample symbols).
3. Close the preferences.
4. Click the applet.

If you have a window over the invest applet, or maximised, you won't see a shadow in compiz. Minimise all windows, however, and you'll see the shadow. Now click the Invest applet button again to dismiss it and only the shadow stays.

ProblemType: Bug
Architecture: amd64
CompizPlugins: [core,move,resize,place,decoration,animation,ccp,annotate,gnomecompat,screenshot,svg,png,extrawm,water,mousepoll,commands,inotify,text,shift,ring,session,firepaint,workarounds,imgjpeg,regex,vpswitch,thumbnail,titleinfo,video,resizeinfo,dbus,crashhandler,wobbly,fade,group,animationaddon,trailfocus,showdesktop,cube,3d,scale,gears,rotate,cubeaddon,scaleaddon,expo,ezoom,switcher,staticswitcher]
Date: Mon Oct 12 01:31:49 2009
DistroRelease: Ubuntu 9.10
MachineType: System manufacturer System Product Name
NonfreeKernelModules: nvidia
Package: compiz 1:0.8.3+git20091005-0ubuntu5
PackageArchitecture: all
PciDisplay: 01:00.0 VGA compatible controller [0300]: nVidia Corporation G96 [GeForce 9500 GT] [10de:0640] (rev a1)
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.31-13-generic root=UUID=67904705-b186-4d51-96e3-0dae4399346c ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-13.44-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.6.0-1ubuntu2
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.0-1ubuntu1
 xserver-xorg-video-ati 1:6.12.99+git20090825.fc74e119-0ubuntu3
SourcePackage: compiz
Uname: Linux 2.6.31-13-generic x86_64
dmi.bios.date: 04/29/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0601
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5Q SE2
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0601:bd04/29/2009:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5QSE2:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
system: distro = Ubuntu, architecture = x86_64, kernel = 2.6.31-13-generic

Related branches

darthanubis (darthanubis) wrote :
Changed in compiz (Ubuntu):
status: New → Confirmed
ex-oficio (wilkinson-luke) wrote :

i have this bug when using the invest applet or the dictionary applet. these are panel applets. when they are opened and closed a shadow reamins on the destop, overlaying icons etc. only happens with compiz, not metacity.

to reproduce:

use compiz
add invest or dictionary applet to panel
click widget to open the applet window
click widget to close the applet window
observe shadow.

screenshot attached

regards,
ex-oficio

ex-oficio (wilkinson-luke) wrote :

i should say, im using nvidia 185.18.36 and 64bit ubuntu.

darthanubis (darthanubis) wrote :

Thank you, because I thought this bug would be dismissed as just one person having this issue. I have this issue on two of my 64bit, Nvidia, 9.10 systems.

ex-oficio (wilkinson-luke) wrote :

i believe this is a duplicate of this bug:

https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/152264

Travis Watkins (amaranth) wrote :

I've added gnome-applets and gnome-utils tasks to this bug because these applets should not be using the dock type for their windows as that causes problems with metacity compositing as well (but just a bad effect instead of a lingering shadow).

Even after fixing this bug in compiz these two should be fixed to use a different window type.

Changed in compiz (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Changed in gnome-applets (Ubuntu):
status: New → Confirmed
Changed in gnome-utils (Ubuntu):
status: New → Confirmed
summary: - Invest applet drop down leaves a shadow on desktop
+ [compiz] applets with Dock type window leave shadow
Travis Watkins (amaranth) wrote :

Here is the test case from bug 458385 to trigger this bug in compiz.

ssbastos (bastos-sergio) wrote :

This problem affects me too... I thought the problem was related to the nvidia graphics card that I was using, but I recently installed ubuntu 9.10 x64 on a laptop with an ATI Radeon card and the problem is still there...

Changed in gnome-applets (Ubuntu):
importance: Undecided → Low
Changed in gnome-utils (Ubuntu):
importance: Undecided → Low

Just worked around this by changing the "Show windows" rule in "Window decorations" from "CompizConfig Settings Manager" to "(any) & !(type=Dock)".

Seems to work OK and is similar to what needs to be done to fix seamless-RDP.

Jaunty -> Karmic upgraded, Intel integrated graphics chipset.
00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)

RodGer (rodger) wrote :

Hello everybody. Bravo for helping the software we all freely share. That's ubuntu spirit.

I think that this certain bug report is more generalized than it should be. I'll explain myself right away. The problem does not affect every window which is type=Dock. For example the clock applet as also the gnome panel its self are dock type windows but you can hide them without any problem of remaining shadow. This is the reason for having a separate fix for the bug #428783 which was about the clock. The same way, the dictionary applet requires a different, separate fix.

@ roadSurfer: You suggested a nice work around. I'll make a little correction. Setting the "Shadow windows" rule to "(any) & !(type=Dock)" also removes the shadow from the panel which is not very nice (though it's not a big problem). I suggest to isolate just the problematic applet windows setting the rule to "(any) & !(class=Gnome-dictionary-applet) & !(class=Invest-applet)".

I think it's clear that the bug does not affect every dock type window and as so I think that the summary should refer only to the invest applet.

RodGer (rodger) on 2009-11-24
summary: - [compiz] applets with Dock type window leave shadow
+ [compiz] Invest applet drop down leaves a shadow on desktop

I also confirmed that this bug affects me too. Ah! and a little correction of my comment above: "Bravo for helping
++improve++ the..."

darthanubis (darthanubis) wrote :

I don't know how or when this got resolve for me. But I no longer have this issue.

Travis Watkins (amaranth) wrote :

If you look at the test case you can see it affects every Dock type window that is hidden rather than destroyed. The clock was fixed by making destroyed windows get their shadow cleaned up properly, this one apparently needs hidden windows to get their shadow cleaned up properly. It is a rather general problem though.

summary: - [compiz] Invest applet drop down leaves a shadow on desktop
+ [compiz] applets with Dock type window leave shadow
RodGer (rodger) wrote :

Gnome panel is also a dock type window that is hidden (use show hide buttons or auto-hide) but it has no problem. Is there any other (than invest and dictionary applet) example of a dock type window that is hidden rather than destroyed?

Sorry but I'm learning.How can you see if a dock type window is hidden or destroyed? Where can I find the source code of compiz (in what prog. language it is written?) ? Which way are the dock type windows defined in compiz source code?

Travis Watkins (amaranth) wrote :

Actually the panel moves and resizes, it doesn't actually hide. Explaining how compiz works would take longer than it'll take to fix this problem. :)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.8.4-0ubuntu9

---------------
compiz (1:0.8.4-0ubuntu9) lucid; urgency=low

  [ Michael Vogt ]
  * 061_KWD_stubs.patch: updated to be less horrible, thanks
    to Danny Baumann

  [ Travis Watkins ]
  * debian/patches/015_draw_dock_shadows_on_desktop.patch:
    - don't draw shadows for invisible dock windows (LP: #449272)
 -- Travis Watkins <email address hidden> Thu, 10 Dec 2009 13:11:08 -0600

Changed in compiz (Ubuntu):
status: Triaged → Fix Released
Norman Perelson (simplr) wrote :

Nobody has mentioned the Drawer applet. It affects that too.

RodGer (rodger) wrote :

Indeed, it affects the drawer applet to. When you close the drawer the shadow remains remains until I click on the desktop. The main problem is solved but not totally. Also, the test case, Travis Watkins posted, still gives the same result: the little window lives a shadow that won't go away no matter what you do.

The bug is partially fixed. I don't know if we should open the bug again. If anybody still has a problem, after updating his system, please let us know.

RodGer (rodger) wrote :

Sorry for my mistakes in the previous comment. Here it is corrected:
Indeed, it affects the drawer applet too. When you close the drawer the shadow remains until you click on the desktop. The main problem is solved but not totally. Also, the test case, Travis Watkins posted, still gives the same result: the little window leaves a shadow that won't go away no matter what you do.

The bug is partially fixed. I don't know if we should open the bug again. If anybody still has a problem, after updating his system, please let us know.
See full activity log

Travis Watkins (amaranth) wrote :

Both the test case and the drawer work perfectly on my up-to-date lucid system.

sirald66 (sirald66) wrote :

Jaunty (9.04) seemed to be fine, where Karmic (9.10) introduced the problem.

Why is the solution in Lucid (10.04) and not applied to Karmic?

[For those with the touchpad mouse jump/lock problem, I'm told the solution is also in Lucid. This development cycle is starting to remind me of Microsoft -- where before the bugs are crushed, new features+bugs are introduced; a never ending story.]

Sebastien Bacher (seb128) wrote :

the applet is deprecated in GNOME3 and oneiric, closing the bug

Changed in gnome-utils (Ubuntu):
status: Confirmed → Invalid

"[Bug 449272] Re: [compiz] applets with Dock type window leave shadow"
Launchpad Bug Tracker doc

"[Bug 449272] Re: [compiz] applets with Dock type window leave shadow"
Launchpad Bug Tracker doc

Conte

Good day!

We considered your resume to be very attractive and we thought the vacant position in our company could be interesting for you.

Our firm specializes in online services in the matter of business administration.
We cooperate with different countries and currently we have many clients in yours region.
Due to this fact, we need to increase the number of our destination representatives' regular staff.

Part-time and full-time employment are both currently important.
We offer a flat wage from $1500 up to $7000 per month.

If you are interested in our offer, please visit our web page.

Attention! Accept applications only on this and next week.

Respectively submitted
Personnel department

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers