Ubuntu

Visual Effects setting is not saved between sessions

Reported by Paul Elms on 2009-10-04
64
This bug affects 11 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: compiz

I am using a fresh install of Karmic beta using compiz version 1:0.8.3+git20090917-0ubuntu4.

Setting the Visual Effects in System->Preferences->Appearance to Normal or Extra works OK until I log out. When I log back in the Visual Effects setting has returned to None, ie: it's setting was not saved with the session. I can reset Visual Effects back to Normal or Extra with no problem, until I log off again.
 I would expect the Visual Effects to remain set at the level previously requested.

ProblemType: Bug
Architecture: amd64
CompizPlugins: [core,move,resize,place,decoration,animation,ccp,dbus,mousepoll,gnomecompat,png,svg,imgjpeg,text,neg,video,wall,snap,scale,scaleaddon,expo,staticswitcher,regex,resizeinfo,workarounds,ezoom,vpswitch,extrawm,fade,session]
Date: Sun Oct 4 08:19:11 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/compiz
InterpreterPath: /bin/dash
MachineType: Dell Inc. XPS M1330
NonfreeKernelModules: nvidia
Package: compiz-wrapper 1:0.8.3+git20090917-0ubuntu4
PciDisplay: 01:00.0 VGA compatible controller [0300]: nVidia Corporation G86 [GeForce 8400M GS] [10de:0427] (rev a1)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-11-generic root=UUID=8e495c1d-45ec-4f87-8bfd-8d5884e6a41e ro quiet splash
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.6.0~git20090817.7c422387-0ubuntu7
 libdrm2 2.4.13-1ubuntu1
 xserver-xorg-video-intel 2:2.8.1-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090825.fc74e119-0ubuntu2
SourcePackage: compiz
Uname: Linux 2.6.31-11-generic x86_64
dmi.bios.date: 11/19/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A14
dmi.board.name: 0PU073
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA14:bd11/19/2008:svnDellInc.:pnXPSM1330:pvr:rvnDellInc.:rn0PU073:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: XPS M1330
dmi.sys.vendor: Dell Inc.
system: distro = Ubuntu, architecture = x86_64, kernel = 2.6.31-11-generic

Paul Elms (scifly) wrote :
gmicsko (gmicsko) wrote :

Workaround:

System -> Preferences -> Startup Applications -> Add

Name: Compiz start
Command: compiz --replace
Comment:

Makoto (makotothedragon) wrote :

Confirming bug, workaround will not work for me on this system.

darrengoddard (goddarddarren) wrote :

also confirming bug and work around not working. as a relative newbie i cannot offer any more assistance without advice. is there anything else i can report to help solve this bug...

Ryan B (coffebean) wrote :

I set this work around yesterday, after loging in today the settings were lost again along with added start application (workaround).

Makoto (makotothedragon) wrote :

DIFFERENT WORKAROUND FOUND:

In order to successfully save the settings you want to be saved, you must set your desktop-preferences to "none". By this I mean:

1) Right click on your Desktop
2) Select "Change Desktop Background"
3) Select the Visual Effects Tab
4) Set to "none"

After that, go back into compizconfig-settings-manager and configure it the way you like. Then, to invoke it, type "compiz --replace" in Alt+F2.

This workaround has worked with my machines.

Ryan B (coffebean) wrote :

I agree that the "DIFFERENT WORKAROUND" works Makoto, but this still requires a manual restart of compiz after login. Having "compiz --replace" in (System-Preferences-Startup Applications) should start compiz automagicaly at login.

Ryan B (coffebean) wrote :

I agree that the "DIFFERENT WORKAROUND"

DIFFERENT WORKAROUND worked fr me as well. I am a novice to Ubuntu. A note: I had "compiz --replace -c emerald &" in my startup, probably because I use Mac4Lin. I tried and substitute it with the simpler "compiz --replace" and now the settings of compiz are saved and everything work after I login again and also after I reboot.

Ryan B (coffebean) wrote :

I played around with the settings and reinstalling some packages and the issues seems to have gone away. seems like there may be a bug in the initial install config, but is fixed after completely uninstalling and then reinstalling compiz, as well as using the DIFFERENT WORKAROUND.

Richard Corner (rcorner) wrote :

I also had the experience of Gnome's Visual Effects reverting to "none" each time I logged out. But it turned out to be not so much a bug as a case of non-obvious UI design. I got what I wanted as follows:

1. Log in to a Gnome session
2. Go to System > Preferences > Appearance > Visual Effects
3. Select "Extra"
4. Click "Close"
5. Go to System > Preferences > Startup Applications > Options
6. Click "Remember Currently Running Application"

This gives a notice that the session has been saved. Then I configured Compiz the way I wanted it and logged off. Next time I logged on Compiz was running by default and my settings were preserved.

Same issue with Lucid Beta 1. Richard Corner's work around of 5 Mar 10 works (nice hack Richard).

flm (flmommens) wrote :

Same issue with Lucid Beta 2.
This is particularly painful as I don't have any window decoration when the settings are to "none", issue which seems to be linked to Bug #554106

Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. Is this still an issue with the latest release of Ubuntu the Natty Narwhal? May you please check and comment back? Thanks in advance!.

Changed in compiz (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for compiz (Ubuntu) because there has been no activity for 60 days.]

Changed in compiz (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers