update-manager does not focus password dialogue box

Bug #436852 reported by QPrime on 2009-09-25
44
This bug affects 6 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: update-manager

update-manager does not focus password dialogue box when password is requested. This may cause obvious confusion for the user.

ProblemType: Bug
Architecture: i386
Date: Fri Sep 25 15:55:36 2009
DistroRelease: Ubuntu 9.10
Package: update-manager 1:0.125.4
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-10.35-generic
SourcePackage: update-manager
Uname: Linux 2.6.31-10-generic i686

Related branches

QPrime (mwells) wrote :
QPrime (mwells) wrote :

Additionally, there are occasions when all password input is rejected (but the Gnome panel indicates the app has elevated privs), and the update must be aborted and restarted. These two symptoms *may* be related.

Tim Lunn (darkxst) wrote :

I am also experiencing the password focus issue

Every other app that throws up the admin auth password dialog can just type password in, however for update manage I have to click on the password field to give it focus.

QPrime (mwells) wrote :

Hi Tim, sorry to say this but... "glad I'm not the only one experiencing this issue". Are you also getting intermittent password rejection, despite the fact that privs seem to get elevated after after the initial password entry? I have a feeling this may be related to the general aptd issues that have been highlighted in various bug reports. I'm liking many of the apt front-end enhancements in Karmic, but right now things seem a little shaky heading into beta.

affects: update-manager (Ubuntu) → compiz (Ubuntu)
Travis Watkins (amaranth) wrote :

Having it fail even though it says you have privileges is a different bug, please file it separately. This one is due to a bug in compiz (or polkit, not sure yet). I have a potential fix for compiz but I'm still discussing what the best option is with upstream.

Changed in compiz (Ubuntu):
importance: Undecided → High
status: New → Triaged
QPrime (mwells) wrote :

Thanks for the attention on this bug. I'm currently running two Karmic test boxes (one with compiz and one with metacity), both systems exhibit the same dialogue focus issue. I'll open another bug report for the privs issue.

Travis Watkins (amaranth) wrote :

We've got a fix (really more of a workaround) for this in the compiz packaging bzr. It will be in the next upload of compiz to karmic.

Changed in compiz (Ubuntu):
status: Triaged → Fix Committed
Travis Watkins (amaranth) wrote :

Anyone testing the fix for bug 433851 should open up compizconfig settings manager, go into general options, and change the focus prevention match in the focus tab to "any" to revert this change so they can properly test. Once that bug is fixed we'll revert this change.

QPrime (mwells) wrote :

WRT my post #6... after more testing on unpatched installations I cannot reproduce this on my metacity text box, but can do so consistently on my compiz test box. It seems that the general consensus pointing to compiz is correct. Will patch and see what happens.

QPrime (mwells) wrote :

Additional irc channel talks indicate that others have seen a hard to reproduce metacity issue related to this bug (and a fix may be forthcoming). No more comments from me on this issue unless some consistently reproducible breakage is fixed or something that was previously working becomes consistently broken.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.8.3+git20091005-0ubuntu5

---------------
compiz (1:0.8.3+git20091005-0ubuntu5) karmic; urgency=low

  * New snapshot from upstream stable git:
     - compiz.real crashed with SIGSEGV in blurDrawWindow()
       (LP: #353236)
     - Windows disappear if resolution is changed to something smaller
       than window size (LP: #414134)
     - compiz.real crashed with SIGSEGV in handleEvent() (LP: #430518)
     - Windows that span screen width or height cannot be resized
       in that dimension (LP: #137134)
     - Reducing number of workspaces leaves windows inaccessible
       (LP: #189259)
     - "Snap Inverted" in Wobbly Windows compiz plugin broken
       (LP: #366822)
     - Problem when resizing and the Panels
       (LP: #408030)
  * debian/control:
    - make compiz package depend on compiz-gnome | compiz-kde (LP: #172385)
  * debian/patches/015_draw_dock_shadows_on_desktop.patch:
    - fix clock/calendar shadow not going away (LP: #428783)
      thanks to Erkin Bahceci
  * debian/patches/029_default_options:
    - add a focus prevention match to allow polkit windows to steal focus
      otherwise they never get focus (LP: #436852)
  * debian/compiz-gnome.gconf-defaults:
    - change /apps/gwd/blur_type to all since it only does anything if blur
      is enabled and is usually what is wanted (LP: #158376)
    - turn constrain_y back on (LP: #82654)
  * debian/rules:
    - add commands plugin to default active_plugins (LP: #355018)

 -- Travis Watkins <email address hidden> Mon, 05 Oct 2009 15:42:00 +0200

Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released

Just confirming that this issue has been fixed with this update of compiz.

On 06/10/09 01:15, Launchpad Bug Tracker wrote:
> This bug was fixed in the package compiz - 1:0.8.3+git20091005-0ubuntu5
>
> ---------------
> compiz (1:0.8.3+git20091005-0ubuntu5) karmic; urgency=low
>
> * New snapshot from upstream stable git:
> - compiz.real crashed with SIGSEGV in blurDrawWindow()
> (LP: #353236)
> - Windows disappear if resolution is changed to something smaller
> than window size (LP: #414134)
> - compiz.real crashed with SIGSEGV in handleEvent() (LP: #430518)
> - Windows that span screen width or height cannot be resized
> in that dimension (LP: #137134)
> - Reducing number of workspaces leaves windows inaccessible
> (LP: #189259)
> - "Snap Inverted" in Wobbly Windows compiz plugin broken
> (LP: #366822)
> - Problem when resizing and the Panels
> (LP: #408030)
> * debian/control:
> - make compiz package depend on compiz-gnome | compiz-kde (LP: #172385)
> * debian/patches/015_draw_dock_shadows_on_desktop.patch:
> - fix clock/calendar shadow not going away (LP: #428783)
> thanks to Erkin Bahceci
> * debian/patches/029_default_options:
> - add a focus prevention match to allow polkit windows to steal focus
> otherwise they never get focus (LP: #436852)
> * debian/compiz-gnome.gconf-defaults:
> - change /apps/gwd/blur_type to all since it only does anything if blur
> is enabled and is usually what is wanted (LP: #158376)
> - turn constrain_y back on (LP: #82654)
> * debian/rules:
> - add commands plugin to default active_plugins (LP: #355018)
>
> -- Travis Watkins <email address hidden> Mon, 05 Oct 2009 15:42:00
> +0200
>
> ** Changed in: compiz (Ubuntu)
> Status: Fix Committed => Fix Released
>
>

I still have this issue, and it's consistent in latest Ubuntu Beta

QPrime (mwells) wrote :

Prior to the latest round of updates I was also still experiencing this on a metacity based test box. With the latest updates it appears that auth. has been reverted to system modal. While I actually prefer the window modal method of authentication, I'm not complaining, either way is fine. Consistency of operation is far more important to me (and I suspect other users as well). If the Policykit discussion https://bugzilla.gnome.org/show_bug.cgi?id=596260 gets sorted out then my preference is window modal, but until then I'm quite happy with the revert to system modal.

Focus issue is no longer a problem on my metacity test box.

Alecz20 (alexguzu) wrote :

On default installation of Ubuntu 10.10 this issue still happens

I open Ubuntu Software Center, then I selects software to install, and I click Install.

The pox pops up, but when I try to type my password, it appears in clear text as a search box of Ubuntu Software Center window.

I have to first click on the Authentication Window box, then enter the password.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.