compiz (+static) application switcher crash if no popup is used

Bug #430462 reported by Kitt Tientanopajai on 2009-09-16
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Medium
Unassigned

Bug Description

I bind "Alt-Tab" to "Next window (No popup)", and when I press the keys, compiz crashes (X/GDM works still). This affects both "Application Switcher" and "Static Application Switcher". Setting "Alt-Tab" to the default "Next window" (with popup) works just fine though.

This happens after I safe-upgrade in 2009-09-15

This is my system
- Linux peorth 2.6.31-10-generic #32-Ubuntu SMP Thu Sep 10 23:33:50 UTC 2009 i686 GNU/Linux
- Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
- linux-image-2.6.31-10-generic = 2.6.31-10.32
- xserver-xorg = 1:7.4+3ubuntu5
- xserver-xorg-video-intel = 2:2.8.1-1ubuntu1
- compiz = 1:0.8.3+git20090914-0ubuntu1

Kitt Tientanopajai (kitty) wrote :

Seemingly, bugs have been fixed by compiz 1:0.8.3+git20090917-0ubuntu1.

Changed in compiz (Ubuntu):
status: New → Fix Released
Kitt Tientanopajai (kitty) wrote :

Reopen, it happened again at least after 9.10 beta
compiz 1:0.8.3+git20090917-0ubuntu4

Changed in compiz (Ubuntu):
status: Fix Released → Confirmed
status: Confirmed → New
Travis Watkins (amaranth) wrote :

Do you get an apport dialog asking you to submit a report when this happens? I cannot reproduce and without a crash report we have no way of knowing what is going on.

Changed in compiz (Ubuntu):
status: New → Incomplete
Erkin Bahceci (cornelius1) wrote :

Kitt, does this happen every time you use the switcher, completely randomly, or in a certain situation, like when a window closes (or opens) while using switcher?

Kitt Tientanopajai (kitty) wrote :

cornelius: it happens every time I press alt-tab to switch to next window

travis: apport cannot capture the crash, I don't know why. apport-cli shows no pending crash reports.

both: I just tried to bind "alt-tab" to "next window (no popup)" in "application switcher". It works fine now. But, for the same binding in "static application switcher", it crashes. If apport could capture the crash I'll post here.

Travis Watkins (amaranth) wrote :
Changed in compiz (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
Travis Watkins (amaranth) wrote :
Travis Watkins (amaranth) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 430518, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers