shadow remains on desktop after closing clock applet window

Bug #428783 reported by Dmitry Savin on 2009-09-13
196
This bug affects 30 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Medium
Unassigned
mesa (Ubuntu)
Medium
Unassigned
xorg-server (Ubuntu)
Medium
Unassigned

Bug Description

Steps to produce the bug:
1. Enable Desktop Effects
2. Close all windows (desktop should be visible)
3. Click on the clock applet info in system tray
4. Click on it again
5. You see a trace on desktop on the place where clock applet window was.

NVIDIA 185-series proprietary driver, GF 7300 GT card.

Description: Ubuntu karmic (development branch)
Release: 9.10

Related branches

Dmitry Savin (envelsavinds) wrote :
affects: gnome-applets (Ubuntu) → ubuntu
petski (petski) on 2009-09-17
affects: ubuntu → compiz (Ubuntu)
Nate Wiebe (natew) wrote :

i get the same problem.. karmic 9.10 (fully updated) with nvidia 190.32 proprietary drivers. Screenshot below.

Changed in compiz (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Michael Stempin (mstempin) wrote :

Confirming this with Intel Graphics on an Dell XPS M1330.
Let me know if you need more info on this.

I Also confirm with an X1950XT - open source radeon driver

axoin (axoin) wrote :

Confirming on IBM T43
Video Card is ATI Technologies Inc M22 [Mobility Radeon X300]

Mankeys (mankeys) wrote :

I also get this same problem.
Ubuntu 9.10 Alpha 6 (update).
ATI Radeon 9600 (open drivers).

Geir Ove Myhr (gomyhr) wrote :

From the number of duplicates and subscribers, it seems that this bug affects many people across different hardware. It's not useful to get more confirmaiton of this bug in comments, but please use the "Does this bug affect you?" feature if you want yourself to be counted. It may be interesting to know if any hardware is _not_ affected.

Since this issue is the same on different hardare, it is not a problem with the device drivers and compiz is probably a good place to put it. However, I guess the rendering is actually done at a lower level so the actual bug may be in mesa or xorg-server. I'm marking this bug as Triaged, although it could probably use some more xorg-logs. The duplicate bugs 427921 and 429084 have more logs.

Changed in compiz (Ubuntu):
status: Confirmed → Triaged
Changed in mesa (Ubuntu):
status: New → Triaged
Changed in xorg-server (Ubuntu):
status: New → Triaged
Changed in mesa (Ubuntu):
importance: Undecided → Medium
Changed in xorg-server (Ubuntu):
importance: Undecided → Medium

confirmed at me on intel driver

Travis Watkins (amaranth) wrote :

Fixed in compiz packaging bzr, will be in next upload.

Changed in xorg-server (Ubuntu):
status: Triaged → Invalid
Changed in mesa (Ubuntu):
status: Triaged → Invalid
Changed in compiz (Ubuntu):
status: Triaged → Fix Committed
Geir Ove Myhr (gomyhr) wrote :

For people who are eager to verify this, the compiz packaging bzr is at [1] and the commit that should fix this is revision 304 [2].

[1]: https://code.launchpad.net/~compiz/compiz/ubuntu
[2]: http://bazaar.launchpad.net/~compiz/compiz/ubuntu/revision/304

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.8.3+git20091005-0ubuntu5

---------------
compiz (1:0.8.3+git20091005-0ubuntu5) karmic; urgency=low

  * New snapshot from upstream stable git:
     - compiz.real crashed with SIGSEGV in blurDrawWindow()
       (LP: #353236)
     - Windows disappear if resolution is changed to something smaller
       than window size (LP: #414134)
     - compiz.real crashed with SIGSEGV in handleEvent() (LP: #430518)
     - Windows that span screen width or height cannot be resized
       in that dimension (LP: #137134)
     - Reducing number of workspaces leaves windows inaccessible
       (LP: #189259)
     - "Snap Inverted" in Wobbly Windows compiz plugin broken
       (LP: #366822)
     - Problem when resizing and the Panels
       (LP: #408030)
  * debian/control:
    - make compiz package depend on compiz-gnome | compiz-kde (LP: #172385)
  * debian/patches/015_draw_dock_shadows_on_desktop.patch:
    - fix clock/calendar shadow not going away (LP: #428783)
      thanks to Erkin Bahceci
  * debian/patches/029_default_options:
    - add a focus prevention match to allow polkit windows to steal focus
      otherwise they never get focus (LP: #436852)
  * debian/compiz-gnome.gconf-defaults:
    - change /apps/gwd/blur_type to all since it only does anything if blur
      is enabled and is usually what is wanted (LP: #158376)
    - turn constrain_y back on (LP: #82654)
  * debian/rules:
    - add commands plugin to default active_plugins (LP: #355018)

 -- Travis Watkins <email address hidden> Mon, 05 Oct 2009 15:42:00 +0200

Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released

I updated to the latest packages and the shadow is still here for me...

Changed in compiz (Ubuntu):
status: Fix Released → Confirmed
Erkin Bahceci (cornelius1) wrote :

Alvin, is that still with the clock applet or with another window?

And after updating to the latest packages, you restarted compiz (or logged out and back in), right?

Mike Basinger (mike.basinger) wrote :

The artifacts are gone for me.

David Hardstone (dhardstone) wrote :

I updated and they're gone for me too...

QPrime (mwells) wrote :

working correctly after an update and restart on my NV11 based test box.

The clock applet. Additionally, issue #408030 also is not resolved for me, but other issues in this version are (at least the polkit focus issue) are working. Here's some possibly relevant information:

amd64
nVidia driver 185
clean install as of about 5 days ago

For those that it's working, what's you hardware?

Yup, I rebooted a couple of times.

Dan Andreșan (danyer) wrote :

gone :)

nvidia 6200 agp, amd 32bit, nvidia 185

added a picture showing the shadow and compiz version

David Hardstone (dhardstone) wrote :

Alvin, the Compiz update that fixes this problem was only available to me when I reloaded and updated my system after reading your first comment saying the problem wasn't fixed for you. Maybe if you try updating again you'll see the compiz update come in?

David Hardstone (dhardstone) wrote :

Oh, I take that back :)

Acer FX laptop
1920x1200
nVidia 9800 GTS

David Hardstone (dhardstone) wrote :

Though I noticed from your screenshot that only the 'compiz' package was up to date. compiz-plugins, compiz-wrapper etc are at 1:0.8.3+git20091005-0ubuntu5 for me.

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released

So the question is, why is my system showing as fully updated then?

Dave, how did you get them? According to synaptic, the only one that was updated was compiz.

David Hardstone (dhardstone) wrote :

Hmm strange. I just did a normal update and Update Manager pulled them all in. Aparrently the compiz package itself is just a metapackage which would explain why the big Compiz fix didn't fix your problem. You could try updating again in a while to make sure mirrors etc have time to update? I don't know too much about how it all works but that's what I'd guess.

It looks like the packages were built for x86 but not amd64...

Or at least the packages were not released on amd64.

Changed in compiz (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Confirmed
David Hardstone (dhardstone) wrote :

The updated packages solved the problem for me (i386 version).

manzur (sl-solaris) wrote :

It DOES NOT solve the problem for me (AMD64 version)

Chris Coulson (chrisccoulson) wrote :

This is fixed already (even on amd64) - it just hasn't been published to your mirror yet. FWIW, the amd64 build only finished 45 minutes ago.

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released

Of course i checked both the main repo and the US mirror and it wasn't there. But it's there as of today so good enough.

This bug seems fixed for the clock applet with most people I talk with, though it subsists on the Invest applet specifically.

Steps to reproduce this sub-bug:

1. Add GNOME Invest applet to a panel.
2. In its preferences, add some stock symbols, like GOOG, AMD, INTC (thanks darthanubis in #ubuntu+1 for these sample symbols).
3. Close the preferences.
4. Click the applet.

If you have a window over the invest applet, or maximised, you won't see a shadow in compiz. Minimise all windows, however, and you'll see the shadow. Now click the Invest applet button again to dismiss it and only the shadow stays, which is exactly the symptom of this bug.

Is this the same issue, or should I start another bug?

Miloš Mandarić (mandzo18) wrote :

It's fixed for me also.

it is NOT fixed for me as Louis Simard said about the Invest applet

Sandro Mani (sandromani) wrote :

Just a side curiosity, why are shadows of those applets treated differently than the shadows of other objects in the first place? Note for instance that while windows / menus drop shadows on whatever is behind them, the clock applet seems to only drop a shadow if the desktop is behind it (but not if a window is behind it).

Travis Watkins (amaranth) wrote :

This is a different issue, the shadow for that window _never_ goes away. The bug talked about in this report was a damage issue so the shadow would go away after moving another window over it.

Travis Watkins (amaranth) wrote :

Note: There is a bug in compiz with the handling of this but there is also a bug in the invest-applet marking itself as a dock type window when it isn't. You can see this by running the metacity compositor and noticing you can't see a shadow for this window if there is another window under it, the same as in compiz. If the invest-applet bug is fixed it will work around the bug in compiz so we don't have to worry about it.

manzur (sl-solaris) wrote :

Just a side curiosity, why are shadows of those applets treated differently than the shadows of other objects in the first place?

I wonder the same, with all due respect thing compiz code should be cleaned

manzur (sl-solaris) wrote :

Just a side curiosity, why are shadows of those applets treated differently than the shadows of other objects in the first place?

I wonder the same, and with all due respect I think that compiz code should be cleaned

Travis Watkins (amaranth) wrote :

I think you have no idea what you're talking about. We've specifically added code to compiz to treat _NET_WM_WINDOW_TYPE_DOCK windows differently when drawing shadows because otherwise the shadows draw on top of all other windows. We do the same thing metacity does in this case.

darthanubis (darthanubis) wrote :

it is NOT fixed for me as Louis Simard said about the Invest applet

Dmitry Savin (envelsavinds) wrote :

Yeah, it is stll not fixed for Invest applet. But remaining shadow cannot be removed just draging window above it. The only way to remove it is to close Invest applet and than drag cause destop to redraw.

Travis Watkins (amaranth) wrote :

Please file a new bug report.

darthanubis (darthanubis) wrote :

Please provide more detail as to WHY we should file a seperate bug report for the invest applet in gnome-applets still leaving shadows after dropdown has receded? Why diffuse the issue further?

Travis Watkins (amaranth) wrote :

Because it's a different bug? You're free to argue with me, I'll fix the bug anyway. Eventually. Having a separate bug report keeps it on my radar.

Generally issues that require different fixes are filed as different bugs. Not sure why this is so hard to understand.

darthanubis (darthanubis) wrote :

Fixing all these bugs must have you stressed out. Don't see why your attitude is so tart. No reason to go out of your way to alienate the helpful user base. I could care less about some "argument" with someone I NEED to reach a COMMON goal, stamp out bugs.

Refocus, apologize to your mother for embarrassing her with your poor manners, and lets get back to making this release the best.

summary: - shadow remains on desktop after closing applet window
+ shadow remains on desktop after closing clock applet window
Dan Andreșan (danyer) wrote :

@darthanubis,

please read this bug title and descriptions. It is about the *clock* applet. This was fixed

The Investor applet shadow is another bug, specifically related to the Investor applet code.
If you want to help, please fill it as a *new* bug.

Using harsh language is not helpful.

Thank you.

darthanubis (darthanubis) wrote :

https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/449272

Thank you Dan. I agree, and understand as to the why now.

RodGer (rodger) wrote :

Here: https://bugs.launchpad.net/ubuntu/+source/gnome-utils/+bug/484850 is a similar problem with the gnome-dictionary-applet.
Can somebody help to track which is the problematic package? Is it compiz? Why? In the clock applet window, how did you know that the problem is with compiz and not with the applet?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers