File name in title bar not updated

Bug #37650 reported by Martin Visser on 2006-04-01
8
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Low
MOTU

Bug Description

If one open a folder with images in Eye of Gnome and uses "Previous" and "Next" to view other files in the folder, eog doesn't update the title bar with the correct file name. The task bar title associated with the program does update.

I attach a screen shot showing this

Sebastien Bacher (seb128) wrote :

Thanks for your bug. What version of Ubuntu do you use? That issue is supposed to be fixed with dapper and that works fine for me

Changed in eog:
assignee: nobody → desktop-bugs
status: Unconfirmed → Needs Info
Martin Visser (martinvisser99) wrote :

This was installed from the 20060329.2 daily and installed all updates released since.

eog is 2.14.0

Here's how to reproduce the problem.
1) Create three images. 1.png, 2.png and 3.png.
2) Open 1.png in eog.
3) Click Next in eog's toolbar.
4) Eog's titlebar doesn't reflect the name of the new image.
5) Now rename those file to a.png, b.png and c.png.
6) The problem goes away.

It looks the problem has been fixed for certain filename cases, but not all.

Sebastien Bacher (seb128) wrote :

That works fine for me with your example. Does anybody else get that issue?

Changed in eog:
status: Needs Info → Unconfirmed
Daniel Holbach (dholbach) wrote :

Works fine for me too.

Martin Visser (martinvisser99) wrote :

Well,

I just did another apt-get update, install upgrade and the problem is still apparent using eog 2.14.1. I have uploaded a tarball with 6 images showing the exact problem. I also have a screenshot showing the title bar with the mismatch between icon/image shown and title.

Please extract the tarball and view with eog. Watch the titlebar while pressing Next & Prev

Ramon de Ruiter (won) wrote :

Works for me in Dapper.

Cafuego (cafuego) wrote :

I experience the same problem, the task bar title is updated, but the application window title isn't.

Dapper, Eog 2.14.1-0ubuntu1.

Changed in eog:
status: Unconfirmed → Confirmed
Daniel Holbach (dholbach) wrote :

Still can't reproduce with your set of pictures.

Martin Visser (martinvisser99) wrote :

Hoo-woo, I think I know what you guys are missing. I just found that the problem occurs when I run Xgl + compiz + gnome-window-decorator. I realised this when I noticed the text in the titlebar was left-justified on my computer whereas my son's was centred - and I realised he was running vanilla X. So I am guessing that eog is passing the
baton to the the window manager (metacity or gnome-window-decorator) correctly but it g-w-d isn't correctly updating it.

If the eog maintainers Daniel or Sebastian can somehow reassign this to the approriate package that might be a good thing

Martin Visser (martinvisser99) wrote :

Bug #38121:
gnome-window-decorator does not update titles

This looks to be culprit

Sebastien Bacher (seb128) wrote :

Martin, if you do use buggy non-standard softwares thanks to mention that when filling bug so we don't waste efforts to figure why we don't get the issue

Martin Visser (martinvisser99) wrote :

Sebastian, if you talk to all your bug reporters like that you won't get any bug reports. I spent at least 2 hours of my time over the last week trying to determine what the root cause of the bug was.

I searched for similar bug reports on malone

I refined the use case and presented screen shots and samples that demonstrate the issue.

I actually downloaded the eog source and added debug statements to see if I could see where gtk calls might be going wrong

I watched the other comments and tried to get other people to confirm or deny through the ubuntu-au mailing list.

As soon as I realised that the problem was probably related to Xgl/compiz I tested and informed malone.

Xgl/ compiz are in dapper universe. So if you are saying that you don't want any bug reports from people that have universe software installed then please make this clear.

I'm sorry that I have wasted the time of the Ubuntu community. I might think twice of wasting my own time

Sebastien Bacher (seb128) wrote :

No I don't comment on bug like that usually sorry if you took it wrongly. We are few people working on the "standard" desktop and we are busy enough without tracking xgl and compiz issues, that's rather the MOTU land. We appreciate the work you did and might be the wrong case to comment on since you actually did try to figure what was wrong which is not the case of a part of the users land.
We would expect though that people playing with new shiny universe stuff mention it when sending a bug, that would make the job easier for everybody. It's pretty frustrating to spend efforts because the bug description was not mentionning the version of Ubuntu used, neither that xgl and compiz were running. For universe bugs, the desktop team doesn't want them since we are busy enough with the standard desktop but the MOTU will be happy to take it! I'm reassigning the bug but it has been marked duplicated. Keep work the good work we appreciate people participating, really!

Changed in eog:
assignee: desktop-bugs → motu
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers