window decorations disappear on login

Bug #371585 reported by SilverLoz on 2009-05-04
This bug report is a duplicate of:  Bug #197820: No window decorations. Edit Remove
26
This bug affects 2 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by ErikBerglund

Bug Description

This follows an upgrade from Intrepid to Jaunty. After rebooting, the window decorations are missing from all windows (i.e. they have no border so they cannot be dragged or resized and the maximise, minimise and close buttons are absent.)

The fix is to go System>Preferences>Appearance and on the Visual Effects tab change the selection from "None" to "Normal" or "Extra". This restores normal behaviour. However on reboot, the setting is lost and the problem has returned, changing the selection of Visual Effect again fixes the problem for that session only.

It may or may not be significant that I ran the Computer Janitor and removed everything found (except the .deb files). I use an nVidia graphics card, but i don't think this is significant (here's someone with the same problem using an ATi card: http://ubuntuforums.org/showthread.php?p=7208683)

faultygearbox (faultygearbox) wrote :

I have the same exact problem. I would have use the words above to describe this, as that is the sequence I encounter every time I reboot (which is not often though, as I hibernate).

This does not seem to be an nVidia/ATi problem, as I'm running intel graphics..

This seems to be user related since with my user, doing logout and login does loose windows decoration, but with a new user, everything is fine.

oh and I did use the janitor too.

John Washburn (washburnello) wrote :

I'm having this issue too. Every time I log in the window decorations are missing. For now I right click the desktop and select change desktop background, then go to visual effects and select something to get the window decorations back. I however did not use the Janitor tool, but think it's related to some configs.

John Washburn (washburnello) wrote :

I think i found it. I renamed my .gconf folder to .gconf_old and logged out and back in. All was perfectly well after that. I proceeded to copy a folder from .gconf_old to .gconf then log out/in. I did this for every folder in .gconf_old hoping via the process of elimination to find the culprit. ".gconf/desktop/gnome/session/required_components/%gconf.xml" is what was messing things up for me so i just set all my .gconf_old stuff back to .gconf except the "required_components" folder and now all is well. Hope this helps someone finding the bug that causes this to happen whether it's something in ubuntu or just me ;)
Since there wasn't a sessions folder in the auto generated .gconf folder to compare to my bad %gconf.xml, I'm attaching the culprit file in hope's that it can be used to maybe find the problem.

summary: - window decorations disappear on reboot
+ window decorations disappear on login
faultygearbox (faultygearbox) wrote :

That works for me too.

renaming ".gconf/desktop/gnome/session/required_components/" to ".gconf/desktop/gnome/session/required_components_old/" and then reboot, did work for me. Thanks!

Well, that does work, but temporary. After a while (reboot, login, logout) the required_components is back and the bug too.

faultygearbox (faultygearbox) wrote :

Alexandre:
I moved the whole .gconf to get a new fresh one. And it has worked after log-out/log-in, reboot, log-out, log-in.
(You will lose window-settings / themes / saved networks etc, but I couldn't bother tracking down the exact problem).

This is just a guess, but it seems like you are moving something that is within a "session", which sounds to me is something that gets generated during boot-up and/or when you log-in, meaning that the problem is elsewhere in gconf that actually generates this incorrect config.
   Again, this is just a guess based on the path to required_components, I haven't had a look.

faultygearbox (faultygearbox) wrote :

Small update:
The "session" directory doesn't even exist for me anymore. So obviously something else in gconf incorrectly creates it.

LegolasWood (sarah-kho) wrote :

Hi
I performed a clean install of 9.04 but kept my entire home directory. so something from past may cause the following problem for me:

When I right click on the top panel to add something to the panel, it just shows two menu entries:
Code:

*Help*
*About Panel*

Based on the fact that the right click menu items are not appearing, I miss the following capabilities:

- Can not add anythign to panels or remove anything from panels
- Can not move panel.

I tried to remove the required components directory and it did not help me. Please let me know if you have some workaround for this problem or you know how to overcome this problem.

Thanks

dah bien-hwa (dahbien-hwa) wrote :

I'm getting the initial problem (disappearing window decorator's after reboot) too.
I didn't use this mentioned "Janitor"-Software.
And the fix suggested above (removing ~/.gconf) didn't work either.
With me, this started after an intrepid->jaunty update.
If needed, I'd be glad to provide more details!

LegolasWood (sarah-kho) wrote :

Hi
My problem fixed with the following command:

gconftool-2 --type bool --set /apps/panel/global/locked_down "false"

Thanks

@ LegolasWood : That's nice, but this is not what this issue is about.

@ faultygearbox : I'll try that. Thanks.

affects: ubuntu → gnome-desktop (Ubuntu)
Changed in gnome-desktop (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

gnome-desktop is the about GNOME dialog and a library nothing to do with this issue

affects: gnome-desktop (Ubuntu) → compiz (Ubuntu)
oneafrikan (gareth-knight) wrote :

Got the problem sorted for me, hope this sorts it out for others too:

To get Metacity working, the dirty hack is to add:

metacity --replace

to the list of startup applications, which seems to work fine if you’re set against compiz.

I was, but after trying it a bit the last two days it’s much much better than when I last tried it a year ago, so I’ve taken most of the gee whiz out and kept some of the usable stuff.

So to use compiz, I’ve installed all the relevant Compiz packages in synaptic, as well as “Compiz Fusion Icon”, which actually turned out to be the missing link, as well as adding:

fusion-icon

to the list of startup apps. So now I have the Fusion Icon in the Notification area next to the volume applet, but most importantly my windows have decoration / borders, I can alt+tab, and switch between workspaces (each one has a diff purpose for me).

ref:
http://www.oneafrikan.com/archives/2009/05/19/jaunty-jackalope-upgrade-issues-evolution-window-decoration-workspace-switcher-alt-tab-not-working/

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers