SIGWINCH causes brief hang

Bug #367581 reported by aarons on 2009-04-26
4
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: compiz

This is definitely something that appears in 9.04 and not 8.10. I ran into this problem before when I installed some 9.04 packages onto my 8.10 system, and reverting those packages back to the versions from 8.10 helped. Unfortunately I can't remember exactly what the packages were, but they were whatever is required to be upgrade to run the newest digikam version.

So I previous had the problem and solved it, but then today decided to do a complete upgrade to 9.04 and the problem has returned.

Using compiz with the resize plugin: When you release the mouse button when resizing a window, the system briefly freezes for about 2 seconds. My videocard is a Mobility Radeon HD 3400 Series using the ati-provided flgrx drivers. This bug does not seem to be related to that driver version. The machine is a dell studio 1537, running x86_64.

I remember thinking that this was caused by some kde libraries, so I'll try uninstalling a bunch of stuff to see if it resolves to narrow down the problem.

aarons (aarons-ubuntu) wrote :

Update:

I am pretty certain now this is not actually a compiz problem. The behavior shows up with whatever the fallback window-manager is. Running ltrace on gtk-window-decorator once I fell out of a crashed compiz I discovered that the 2 second pause is occuring with SIGWINCH. Indeed, testing other things that cause that signal, such as creating a window, restoring a window, etc, causes the brief pause. So I'd change the package this bug is filed for, but I'm not sure which package is actually broken.

summary: - compiz window resize causes brief hang
+ SIGWINCH causes brief hang
aarons (aarons-ubuntu) wrote :

I traced the problem to one of the xorg packages. Right now I have all the xorg packages held at their versions from 8.10, and the problem has gone away. I'll enter a new bug for xorg and this one can be closed.

Robert Ancell (robert-ancell) wrote :

This bug report is being closed due to your last comment regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status . Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in compiz (Ubuntu):
status: New → Fix Released
aarons (aarons-ubuntu) wrote :

Well, "Fixed Release" isn't really the right status, since the actual problem still exists. I believe the bug to be in the fglrx driver though, so "Invalid" seems more appropriate.

Changed in compiz (Ubuntu):
status: Fix Released → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers