"Sticky" field in Window Rules in Compiz Settings Manager doesn't check "Always on Visible Workspace"

Bug #367055 reported by David M. Karr on 2009-04-25
4
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: compiz

Ubuntu 8.10. Compiz 1:0.7.8-0ubuntu4.1.

(I first asked about this in the Compiz Support forum, and in user-ubuntu, to no avail.)

I installed the "fusion-icon" package so I could access the Compiz Settings Manager. I brought it up and went to the "Window Rules" section. I edited the "Sticky" field and set it to the following value:

    class=Emacs | class=Gnome-system-monitor

I determined these values by running "xprop WM_CLASS | cut -d\" -f4" and clicking on both the Emacs window and the System Monitor window.

I then tabbed out of the field and then clicked the "Back" button (Note that the process for "saving" values you set in these dialogs is ambiguous, as there is no "Save" operation.). I then closed the settings manager.

I then killed all existing instances of the System Monitor and Emacs. I brought up both applications. I checked the right-click menu on the icon and title bar, and neither window had the "Always in Visible Workspace" checkbox checked.

I then restarted the box, logged back in, started Emacs and System Monitor again, and they still did not have the AiVW checkbox checked. I went back into Compiz Settings Manager and verified the value I entered for the "Sticky" field was still there.

Robert Ancell (robert-ancell) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release? Thanks in advance.

Changed in compiz (Ubuntu):
status: New → Incomplete

Thanks, but it will be quite a while before I can do this. I don't plan on upgrading my current box, but I plan on getting another box sometime in the relatively near future, which I'll install (at least) 9.04 on.

Travis Watkins (amaranth) wrote :

This seems to be working correctly now in karmic. If you can still reproduce please reopen this bug.

Changed in compiz (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers