[Jaunty] Calendar applet popup opens under focused windows

Bug #355330 reported by Damiano Dallatana
98
This bug affects 9 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Low
Unassigned
Jaunty
Low
Unassigned

Bug Description

Binary package hint: compiz

I am using compiz 0.8.2-0ubuntu6 on Ubuntu 9.04 amd64, it-IT l10n.

With recent updates, I discovered the calendar popup that shows up clicking on the clock applet of GNOME panel opens under the focused window.

Steps to reproduce:
1. open a window and make sure it covers the top-right corner of the desktop and it is focused
2. click on the clock applet

Expected result: the calendar popup opens on top of the focused window
What happens: the calendar popup stays under the focused window

I attach a screenshot of the problem.
It seems to be the same problem of bug #131050 fixed in Gutsy, and the workaround described on that bug works for me (clicking on the focused window after steps 1 and 2 make the popup appear).
I also tried using a Guest account, but I cannot reproduce the problem.

Revision history for this message
Damiano Dallatana (damidalla) wrote :
Revision history for this message
Ludovico Cavedon (cavedon) wrote :

Confirming bug.
Workaround in bug #131050 works.

Changed in compiz (Ubuntu):
status: New → Confirmed
tags: added: regression-potential
Changed in compiz (Ubuntu Jaunty):
importance: Undecided → Low
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.8.2-0ubuntu7

---------------
compiz (1:0.8.2-0ubuntu7) jaunty; urgency=low

  * handle NO_FOCUS_MASK windows properly (LP: #355330)

 -- Michael Vogt <email address hidden> Mon, 06 Apr 2009 14:12:42 +0200

Changed in compiz (Ubuntu Jaunty):
status: Confirmed → Fix Released
Revision history for this message
Topher (hunt-topher) wrote :

This is not fixed for me, on a fully upgraded Ubuntu Jaunty beta system. I have compiz package version 1:0.8.2-0ubuntu6. I noticed this with the Gnome-Do application, which appears behind an active window when summoned, and can confirm it also with the calendar pop-down applet.

I don't know what the "ubuntu6" part means instead of "ubuntu7". Does that mean my update manager didn't detect a newer version of Compiz available?

Can anyone else confirm that this is not solved?

Revision history for this message
Chris Coulson (chrisccoulson) wrote :

Topher - this is fixed in the latest version. Please upgrade to the latest version and try again

Revision history for this message
Ernesto Menéndez (pyalec) wrote :

@Topher

Try:

apt-get update
apt-get dist-upgrade

Revision history for this message
Topher (hunt-topher) wrote :

Thanks for the help, guys. When I re-ran the update process it detected some extra packages that hadn't upgraded properly before. Confirming fixed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers