I/O warning : failed to load external entity

Bug #344053 reported by Սահակ on 2009-03-17
110
This bug affects 22 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Low
Unassigned
Nominated for Karmic by Սահակ
Nominated for Lucid by Սահակ

Bug Description

Booting from Ubuntu 9.04 Live CD I get the following warning message in .xsession-errors file:

I/O warning : failed to load external entity "/home/ubuntu/.compiz/session/1043119e9cf87de33f123725997285809400000049470017"

Սահակ (petrosyan) on 2009-03-17
description: updated
Changed in compiz:
status: New → Confirmed
Changed in compiz (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Andreas (andreas-kotowicz) wrote :

I see this error message in my .xsession-errors file (ubuntu 10.04):

I/O warning : failed to load external entity "/home/user/.compiz/session/10d25c55e671baf78d127419533628510600000015610032"

Travis Watkins (amaranth) wrote :

This is really not a problem. It just means you didn't save your session.

Changed in compiz (Ubuntu):
status: Triaged → Invalid
Սահակ (petrosyan) wrote :

if it is not a problem then the warning message should not be displayed

How can a fresh session be generated then. Or all sessions wiped out so a fresh one can be created? I am getting this also.

mercutio22 (macabro22) wrote :

Idem.

Jeff (jdorenbush) wrote :

I get this warning too, which might not be much of a problem at all, but I would still like to address it.

funicorn (funicorn) wrote :

Firstly the error msg in .xsession-errors adds difficulty of troubleshooting, secondly I suspect that the error msg indicates
gnome will first try to recover the saved compiz session, find no saved and output the error msg, then start a new one.
Obviously this slows down the loading speed of gnome desktop when logging in.

simulyant (valery-otryvankin) wrote :

I have the same message in my ~/.xsession-errors file under Ubuntu 10.10 Netbook Edition on ASUS EeePC 900:

I/O warning : failed to load external entity "/home/val/.compiz/session/<filen>".

Compiz works. But I want to delete this warning. On my desktop with Ubuntu 10.10 compiz has similar configuration and installed from the same source. And there is no such warning in ~/.xsession-errors.

I find workaround. if disable Session Management plugin in Compiz Config settings Manager and logout/login then the message disappeared. But it is not the solution, because on my desktop with the same configuration (only OS Ubuntu 10.10 rather than Ubuntu 10.10 Netbook Edition) there is no such message.

May be Ubuntu Netbook Edition doesn't use gnome-session so Session Management in CCSM doesn't work (http://otvety.google.ru/otvety/thread?tid=5c2806c977ec6253)?

simulyant (valery-otryvankin) wrote :

After every reboot file name in the warning "/home/val/.compiz/session/<filename>" is different.

simulyant (valery-otryvankin) wrote :

I tried to save session via System - Preferences - Startup Applications - button "Remember Currently Running Applications". I also tried to reset compis settings by CCSM - Preferences - button "Reset to Defaults". After reboot the warning still appeares.

Changed in compiz (Ubuntu):
status: Invalid → Confirmed
simulyant (valery-otryvankin) wrote :

I tried to delete file ~/.xsession-errors. But after reboot it creates again with the same warning.

simulyant (valery-otryvankin) wrote :

The problem solved by deleting Compiz Fusion from System - Preferences - Startup Applications. On my desktop Compiz Fusion didn't exist in System - Preferences - Startup Applications.

Changed in compiz (Ubuntu):
status: Confirmed → Invalid

I get this error message in 11.04 beta, accompanied by the following, which may or may not be related:

Sometimes, ~20% of the time, when an application gains focus, or is maximized, the window displays is blank and white. The window does not display application content until some combination of minimizing, maximizing, changing focus, or restarting the application is performed. The exact sequence seems to vary.

Chico Miraglia (miraglia) wrote :

I get this message on .Xsession errors, using 64 bit 12.04 LTS

I get this message in 12.10

Սահակ (petrosyan) on 2012-12-29
Changed in compiz (Ubuntu):
status: Invalid → Confirmed
Sedat Dilek (dileks) wrote :

I hit the same problem after "ubuntu" (unity-3d) profile was BROKEN here.
To workaround this, I used "unity-2d".

compiz-session-ids are stored at different places.
unity-2d: ~/.compiz/session/
ubuntu (unity-3d): ~/.compiz-1/session/

When switching at the X-login-manager (LightDM) from "unity-2d" to "ubuntu" (unity-3d) you will hit the warning.
NOTE: ~/.compiz/ dir gets removed.

Sedat Dilek (dileks) wrote :

The profiles in LightDM are called "Ubuntu" and "Ubuntu-2d".

NOTE: Check ~/.dmrc file!

Julian Alarcon (alarconj) wrote :

Ok, I'm still getting this warning on Ubuntu 13.04 fully updated:

I/O warning : failed to load external entity "/home/darkhole/.compiz/session/10feb45e4f48274a12136340188589842900000018690036"

rdesfo (rdesfo) wrote :

Ubuntu 13.04

Also still seeing warning

Սահակ (petrosyan) wrote :

I am no longer seeing this bug on Ubuntu 14.04

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released

This bug is back in 15.4 64-bit. At least it is back if you try to auto-start a gui application from a .desktop file.

Սահակ (petrosyan) on 2015-06-21
Changed in compiz (Ubuntu):
status: Fix Released → New
Սահակ (petrosyan) on 2016-10-29
Changed in compiz (Ubuntu):
status: New → Fix Released
Thomas Mayer (thomas303) wrote :

I've seen this in 16.04 today (kernel 4.8):

Feb 18 06:27:03 lat61 gnome-session[3242]: compiz (core) - Info: Starting plugin: session
Feb 18 06:27:03 lat61 gnome-session[3242]: I/O warning : failed to load external entity "/home/userX/.compiz/session/105f9b802130b2ad8c148739562211578000000032420003"

Սահակ (petrosyan) wrote :

can you reproduce this in Ubuntu 16.10?

Thomas Mayer (thomas303) wrote :

@petrosyan I'm still on fully up-to-date 16.04, Kernel 4.8 via HES packages.

I've just seen this again in syslog:

gnome-session[3496]: I/O warning : failed to load external entity "/home/userX/.compiz/session/106261e716d9321ea1149497258226461600000034960003"

This time, my whole gnome session crashed after this error occured.

I was left with the login box, after that all desktop applications were closed. That implies data loss of unsaved data in applications that were open before the crash.

Սահակ (petrosyan) on 2017-05-30
Changed in compiz (Ubuntu):
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers