compiz.real crashed with SIGSEGV in glXCreateContext()

Bug #341720 reported by Angel Guzman Maeso on 2009-03-12
12
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Low
Martin Pitt
compiz (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: compiz

Just enable compiz --replace

$ glxinfo
name of display: :2.0
Xlib: extension "GLX" missing on display ":2.0".
Xlib: extension "GLX" missing on display ":2.0".
Xlib: extension "GLX" missing on display ":2.0".
Xlib: extension "GLX" missing on display ":2.0".
Fallo de segmentación (core dumped)

Maybe compiz should be show a error o exception if glxinfo is broken in glXCreateContext()

ProblemType: Crash
Architecture: i386
CrashCounter: 1
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/compiz.real
MachineType: TOSHIBA 00000000000000000000
Package: compiz-core 1:0.8.2-0ubuntu2
ProcCmdLine: root=UUID=590c22cb-5c99-4270-a154-4e6df62d1b4c ro splash locale=es_ES vga=792
ProcCmdline: compiz.real --replace --sm-disable --ignore-desktop-hints ccp --loose-binding --indirect-rendering
ProcEnviron:
 PATH=(custom, user)
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.28-9.31-generic
Signal: 11
SourcePackage: compiz
StacktraceTop:
 ?? () from /usr/lib/libGL.so.1
 ?? () from /usr/lib/libGL.so.1
 glXCreateContext () from /usr/lib/libGL.so.1
 addScreen ()
 addDisplay ()
Title: compiz.real crashed with SIGSEGV in glXCreateContext()
UserGroups: adm admin audio cdrom dialout dip floppy kvm lpadmin netdev plugdev powerdev pulse-rt sambashare scanner video

Angel Guzman Maeso (shakaran) wrote :

StacktraceTop:?? () from /usr/lib/libGL.so.1
?? () from /usr/lib/libGL.so.1
glXCreateContext () from /usr/lib/libGL.so.1
addScreen (display=0x95da4a8, screenNum=0,
addDisplay (name=0x0) at ../../src/display.c:2373

Changed in compiz:
importance: Undecided → Medium
Brian Murray (brian-murray) wrote :

Martin - this bug report doesn't have a NonfreeKernelModules: bit in the description yet "fglrx" does show up in ProcModules.txt. Do you know why it might not show up in this report?

Brian Murray (brian-murray) wrote :

There isn't an fglrx driver for Jaunty yet, and the one you are trying to use is not appropriate for the X server you are running.

[atiddxSetup] X version mismatch - detected X.org 7.1.-1.902, required X.org 7.4.-1.906

Subsequently, X falls back to using the ati driver, which should be good for your video card, but you have the libGl from the fglrx driver which is causing another failure and the resulting crash in compiz.

Angel Guzman Maeso (shakaran) wrote :

I have to reinstall de package xserver-xorg-core, because some file as /usr/lib/libGL.so.1 maybe not are present.

This bug is for request and show a message of error or exception when compiz crash with SIGSEGV in glXCreateContext(). These should be useful.

Now this is the ouput:

$ compiz --replace
Checking for Xgl: not present.
xset q doesn't reveal the location of the log file. Using fallback /var/log/Xorg.0.log
Detected PCI ID for VGA:
Checking for texture_from_pixmap: Aborted (core dumped)
not present.
Trying again with indirect rendering:
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Checking screen 1Comparing resolution (1440x900) to maximum 3D texture size (2048): Passed.
Checking for Software Rasterizer: Not present.
Checking for nVidia: not present.
Checking for FBConfig: present.
running under gnome seesion, checking for gnomecompat
Checking for Xgl: not present.
/usr/bin/compiz.real (cube) - Warn: Failed to load slide: /usr/share/gdm/themes/Human/ubuntu.png

Martin Pitt (pitti) wrote :

Bryan, thanks for pointing this out. This will happen if "modinfo fglrx" does not print anything or fails; thus I guess the module is not really available? It also has this strange "(P)" after it, I newer saw that before.

Martin Pitt (pitti) wrote :

For the apport side of things, let's err on the side of caution and consider an invalid module as nonfree.

Changed in apport (Ubuntu):
assignee: nobody → pitti
importance: Undecided → Low
status: New → Triaged
tags: added: compiz-crash
Martin Pitt (pitti) wrote :

apport trunk r1498

Changed in apport (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 1.6-0ubuntu1

---------------
apport (1.6-0ubuntu1) karmic; urgency=low

  * New upstream release:
    - Add support for kernel crashes, thanks to Michael Vogt!
    - apport/ui.py, run_crash(): Do not re-collect information if we already
      have a Dependencies field. This happens when calling apport on an already
      pre-processed .crash file with -c. (LP: #394497)
    - apport/hookutils.py, pci_devices(): Deliver all matching devices, not
      just the last one. (LP: #398906)
    - hookutils.py, _get_module_license(): Return "invalid" if modinfo fails,
      so that they do not count as "free". (LP: #341720)
    - packaging-apt-dpkg.py: Support additional custom native origins in
      /etc/apport/native-origins.d/ . (LP: #386052)
    - packaging-apt-dpkg.py: Drop PPA origin hack, launchpad behaves properly
      now
    - apport-gtk: Avoid focus stealing when being called without arguments (i.
      e. auto-launched). LP: #396243)
    - apport-kde: Use standard gettext again
    - Fix handling of PC lacking disassembly due to invalid memory location.
  * debian/local/apport-collect: Tag bugs with "apport-collected" on success.
    (LP: #391392)

 -- Martin Pitt <email address hidden> Wed, 15 Jul 2009 18:02:59 +0200

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released
Travis Watkins (amaranth) wrote :

It appears this was caused by installing an incompatible driver and it was crashing in that driver so compiz couldn't catch it ahead of time.

Changed in compiz (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers