No screen updates when using desktop-effects with vnc

Bug #333564 reported by Rocko on 2009-02-23
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
vino
New
Undecided
Unassigned
compiz (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by Rocko
Nominated for Karmic by Josh Leverette

Bug Description

Binary package hint: compiz

This bug is a regression in vino/compiz for Jaunty that is probably a duplicate of https://bugs.launchpad.net/bugs/77442, but that bug is marked as fix released so nothing seems to be happening with it.

The problem is that when you vnc into a computer running Jaunty with compiz enabled, the vnc window is never updated after the initial refresh. The mouse and keyboard events still get sent from the vnc window, however. With compiz disabled vnc is refreshed as expected.

Version information:

kernel 2.6.28-8-generic
xserver-xorg-core 2:1.5.99.902-0ubuntu7
vino 2.25.91-0ubuntu1
compiz 1:0.7.9+git20090211-0ubuntu4
nvidia 180.29-0ubuntu2

Daniel Aronoff (da0487) wrote :

I can confirm this behavior in Jaunty Alpha 5 amd64. This was not a problem in Intrepid. Same versions of the kernel and nvidia as above.

Daniel Aronoff (da0487) on 2009-03-12
Changed in compiz:
status: New → Confirmed
Rocko (rockorequin) wrote :

It's still a problem with compiz 1:0.8.2-0ubuntu5 and vino 2.26.0-0ubuntu1.

I can also confirm that this exists and still remains an issue.

Rocko (rockorequin) wrote :

Jaunty beta is still using compiz 1:0.8.2-0ubuntu5 and vino 2.26.0-0ubuntu1 so it still has this problem.

Isn't remote desktop an important part of Ubuntu, since it's built in as a standard package? And since effects are enabled by default for cards that support them, won't this be a problem for many Ubuntu users who install or upgrade to Jaunty and will think "it just doesn't work"? But there doesn't seem to be any interest in fixing it...?

An easy way to reproduce this is to vnc into localhost with effects turned on. Normally the vnc window goes into a crazy infinite refresh loop, but with the current Jaunty software you just get a static vnc window.

Rocko (rockorequin) wrote :

Marking as confirmed for vino, since the previous time this occurred (see bug #77442) it was in vino.

I've got compiz 1:0.8.2-0ubuntu7 now and the problem is still present.

http://bugzilla.gnome.org/show_bug.cgi?id=383147 says:

server/vino-fb.c (vino_fb_init_xdamage):
          Check if we are running at a composited screen and disable XDamage
          extension. We should remove this check when XDamage work perfectly
          with 3d desktop

so perhaps it has something to do with recent changes to the way compiz handles XDamage with nvidia cards.

Changed in vino:
status: New → Confirmed
Rocko (rockorequin) wrote :

I installed jaunty on a PC with an ATI card and the bug is not present there, so it must be a problem to do with the nvidia/compiz/vino interaction.

Rocko (rockorequin) wrote :

It's not just with nvidia: I get the same problem if I vnc into a VM with desktop effects turned on running on VirtualBox 2.2 (the VM is running the Jaunty RC). It's fine if I turn desktop effects off.

(Just a note for reproducing this: to get desktop effects running on a VBox VM, you need to enable 3d in its settings and to install the VBox guest additions.)

Changed in vino:
importance: Undecided → Unknown
status: Confirmed → Unknown
Rocko (rockorequin) wrote :

This might be a duplicate of https://bugs.launchpad.net/bugs/353126 (linked to https://bugs.freedesktop.org/show_bug.cgi?id=12255).

The currently linked gnome bug, http://bugzilla.gnome.org/show_bug.cgi?id=383147 says that it is resolved.

Changed in vino:
status: Unknown → Fix Released
Rocko (rockorequin) wrote :

The fix clearly isn't released; I think attaching it to the (fixed ages ago) Gnome bug was a mistake. Either there has been a regression or there's another bug.

Changed in vino:
importance: Unknown → Undecided
status: Fix Released → New

Good day,

This is a duplicate of bug 353126. Though this bug was reported first, that one seems to be a focal point of the related traffic so I am going to mark this as such.

Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.