Ubuntu

With focus_on_map = FALSE, window still opens in front

Reported by Matthew Paul Thomas on 2009-02-23
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Compiz
Confirmed
Unknown
compiz (Ubuntu)
Medium
Michael Vogt
Jaunty
Medium
Michael Vogt

Bug Description

Binary package hint: compiz

When a window is opened with focus_on_map = FALSE, it opens unfocused as expected, but it still opens in front of all other windows. It should instead open in the background, as happens with Metacity.

(This is desired for the new Update Manager behavior in Ubuntu Jaunty.)

description: updated
Changed in compiz:
status: Unknown → Confirmed
Changed in compiz:
assignee: nobody → mvo
Cody Russell (bratsche) wrote :

compiz is technically not breaking any specs here (although that's not really a reason not to make this change.. having functional compatibility between compiz and metacity is very desirable). The spec just says that the window should not be focused, but it doesn't say anything about the Z-order of the window.

The simple solution would be for Update Manager to use gdk_window_lower()

Cody Russell (bratsche) wrote :

Uhh.. actually, you probably have to have already mapped the window so that may not work.

Matthew Paul Thomas (mpt) wrote :

In the upstream bug report I suggested a way of allowing applications to open a window either unfocused frontmost or unfocused in the background. In the meantime, though, I think it's reasonable for a window opened unfocused to open in the background by default, especially since (1) that's what Metacity does, and (2) we have no specific examples of windows that rely on the opposite behavior.

On Monday 16 March 2009 22:50:02 Matthew Paul Thomas wrote:
> (2) we have no specific examples of windows that rely on the opposite behavior.

The guide lines had a few examples, like firefox download window and a few others

--
Hi, I'm BUGabundo, and I am Ubuntu (whyubuntu.com)
(``-_-´´) http://LinuxNoDEI.BUGabundo.net && Ubuntu LoCoTeam Portugal http://ubuntu-pt.org
Linux user #443786 GPG key 1024D/A1784EBB

Matthew Paul Thomas (mpt) wrote :

If you're referring to <https://wiki.ubuntu.com/NotificationDesignGuidelines#Normal%20window>, they're specific about opening unfocused windows in the background, not the foreground.

Pedro Villavicencio (pedro) wrote :

setting this to triaged, per previous comments , the bug is also assigned to a developer and it was send upstream. thanks all.

Changed in compiz (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Robert Ancell (robert-ancell) wrote :
Changed in compiz (Ubuntu Jaunty):
status: Triaged → Fix Committed
Michael Vogt (mvo) wrote :

Thanks Robert for your fix. I'm hesitant to revert the commit entirely because that may become a burden in the future if area of the upstream code change that are covered by the patch. I commited a smaller version that should just change the behavior of the mapping code. I uploaded it to the compiz PPA. Please review/test and if all is fine I will upload to jaunty.

Thanks,
 MIchael

Robert Ancell (robert-ancell) wrote :

Running the following PyGTK program in metacity, compiz_ubuntu5 and compiz_ubuntu6 shows the behaviour has reverted to opening in the background as expected:
<snip>
import gtk
w = gtk.Window()
w.set_focus_on_map(False)
w.show()
gtk.main()
</snip>

I can't give 100% certainty other behaviour is correct as compiz does not run well on my hardware. It behaves as a window manager so I'd say tested.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.8.2-0ubuntu6

---------------
compiz (1:0.8.2-0ubuntu6) jaunty; urgency=low

  * debian/patches/050_stacking.patch:
    - map windows with focus_on_map=FALSE in the background
      (just like metacity) (LP: #333284)

 -- Michael Vogt <email address hidden> Thu, 02 Apr 2009 10:30:24 +0200

Changed in compiz (Ubuntu Jaunty):
status: Fix Committed → Fix Released

I don't know if this is the correct bug, but in karmic running compiz, when right click in gnome-panel > properties... the window opens in the front as expected... but right clicking in Ubuntu One applet > Preferences... i never see the window appears. It still appears in the background...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.