Ubuntu

Okular starts in full-screen mode, without toolbar if last used maximized

Reported by joehill on 2009-02-14
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
KDE Graphics
Invalid
Undecided
Unassigned
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: okular

Whenever I open a close a maximized (not full-screen) document in okular, then open any other document (not necessarily the one I had open), the document now opens in full-screen mode 100% of the time. Nearly all of the time, the toolbar is missing as well, even though I have never told okular not to display the toolbar and I rarely use full-screen mode intentionally. Okular should remember the previous display state and preferences, including whether it was full-screen or not and whether it was displaying the toolbar or not, so I don't have to reset these things every time I open it

I'm using Ubuntu 8.10, okular 4:4.1.4-0ubuntu1~intrepid1. I've been experiencing this problem for about the past month or two. I don't think this occurred in earlier versions of okular. It doesn't happen in any other applications I'm aware of.

skorasaurus (skoraw) wrote :

(same thing happens to me as well).

Changed in okular:
status: New → Confirmed
affects: okular (Ubuntu) → kdegraphics (Ubuntu)
mrmeep (domino1241) wrote :

I was having the same problem.

go into ~/.kde/share/config/okularrc and change the parameter "Fullscreen=true" to "Fullscreen=false"

http://ubuntuforums.org/showthread.php?p=7240737#post7240737

Jonathan Thomas (echidnaman) wrote :

Is this still a problem with KDE 4.3? I cannot reproduce it in Kubuntu 9.10/KDE 4.3.2

Changed in kdegraphics (Ubuntu):
status: Confirmed → Incomplete
Jonathan Thomas (echidnaman) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as requested in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the "Status" column, and change the status back to "New". Thanks again!

Changed in kdegraphics:
status: New → Invalid
Changed in kdegraphics (Ubuntu):
status: Incomplete → Invalid
Changed in kdegraphics (Ubuntu):
status: Invalid → New

I have this problem with kubuntu 11.10

I checked ~/.kde/share/config/okularrc and it contains "Fullscreen=false"

opening a PDF file from dolphin will be fullscreen.
If I resize it and open another PDF, the new one is fullscreen and the first one is also back to fullscreen.

The bug does not always appear.
It might be linked to calling ocular from dolphin.
I did not notice it immediately for example when calling it from Kile.

Maarten Bezemer (veger) wrote :

This upstream report seems quite similar https://bugs.kde.org/show_bug.cgi?id=251384, expect that the upstream issue only occurs with compiz enabled.
So, could you guys confirm whether you are using compiz or not?
If so, this issue is already reported upstream, otherwise a new upstream report needs to be filed.

Changed in kdegraphics (Ubuntu):
status: New → Incomplete
karim Mirras (karim-yan) wrote :

I've got the some problem for a while (till a come across this http://moonbd.blogspot.com/2010/01/okular-starts-fullscreen.html) this is not a bug fix, but a workaround...
this problem affects dolphin as well, it is related to the way these apps interact with compiz, I guess this problem doesn't occur with metacity WM,

affects: kdegraphics (Ubuntu) → compiz (Ubuntu)
Changed in compiz (Ubuntu):
status: Incomplete → New
karlrt (karlrt) wrote :

i've got the same problem (12.04) and https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/329337/comments/2 helped me.

The legacy fullscreen mode disable thing was not for me: http://moonbd.blogspot.com/2010/01/okular-starts-fullscreen.html

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Photon (michael-kogan) wrote :

I experience the same bug on Arch Linux with Okular and Compiz 0.8.8. In ~/.kde/share/config/okularrc the option "Fullscreen=false" is already set. However, there is following entry in this file:

[MainWindow]
Height 1024=1025
State=AAAA/wAAAAD9AAAAAAAABQAAAAOtAAAABAAAAAQAAAAIAAAACPwAAAABAAAAAgAAAAEAAAAWAG0AYQBpAG4AVABvAG8AbABCAGEAcgEAAAAA/////wAAAAAAAAAA
ToolBarsMovable=Disabled
Width 1280=1281

1280x1024 is the resolution I'm using, so obviously the window size is one pixel larger than my screen's resolution by one px in each direction. Changing the values to something like 1027x1023 makes Okular start in window mode (yay!), but unfortunately, each time I start Okular these values are again set to 1281x1025, so next time Okular starts in fullscreen mode again.

Any hints here?

Richard Hansen (a7x) wrote :

The following ugly workaround works for me:

  cd ~/.kde/share/config
  rm okularrc
  ln -s /dev/null okularrc

This prevents okular from saving any settings, so it never starts in full-screen mode.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.