Window decorations in title bar missing with compiz enabled

Bug #327793 reported by Gianfranco Liporace on 2009-02-10
106
This bug affects 14 people
Affects Status Importance Assigned to Milestone
compiz (Fedora)
Invalid
High
compiz (Mandriva)
Fix Released
Medium
compiz (Ubuntu)
Medium
Michael Vogt
metacity (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,
with ubuntu Jaunty and latest upgrades, the titlebar is displayed but empty (no window title, no buttons to close, minimize and maximize a windows).
Included a screenshot of the bug.

Related branches

Created attachment 331253
blanktitlebars.png

Started happening recently, but I'm not sure if it's a gnome component or compiz. I have compiz-0.7.8-12.fc11.x86_64 installed. rawhide is current on my system except for the kernel.

Windows are working. The close, maximize, and minimize buttons all work, but the title bars are all grey.

Attaching a screen shot.

Thanks for the bug report. We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Created attachment 331453
Xorg.0.log

Created attachment 331454
Xorg.1.log

Created attachment 331455
Xorg.3.org

Created attachment 331456
Xorg.2.log

Created attachment 331457
Xorg.4.log

Created attachment 331458
Xorg.5.log

I have no xorg.conf. Attaching all of the Xorg.?.log files that I have.

I disabled desktop effects and title bars are back, for whatever that's worth.

Thanks.

Gianfranco Liporace (dr.kabuto) wrote :
Kevin Lange (kevinlange) wrote :

The precise issue here is an assertion failure in libmetacity:
(gtk-window-decorator:5737): metacity-CRITICAL **: meta_frame_style_draw_with_style: assertion `style_gtk->colormap == gdk_drawable_get_colormap (drawable)' failed

(gtk-window-decorator:5737): metacity-CRITICAL **: meta_frame_style_draw_with_style: assertion `style_gtk->colormap == gdk_drawable_get_colormap (drawable)' failed

(gtk-window-decorator:5737): metacity-CRITICAL **: meta_frame_style_draw_with_style: assertion `style_gtk->colormap == gdk_drawable_get_colormap (drawable)' failed
(This message repeats every time a decoration redraw is attempted)

Julian Alarcon (julian-alarcon) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in metacity.
For future reference you might be interested to know that a lot of applications have bug reporting functionality built in to them. This can be accessed via the Report a Problem option in the Help menu for the application with which you are having an issue. You can learn more about this feature at https://wiki.ubuntu.com/ReportingBugs.

Jeffrey Baker (jwbaker) wrote :

I opened this bug against compiz. I do not understand why my bug was duped against a metacity bug, since I'm not running metacity. Nevertheless: confirmed.

Changed in metacity:
status: New → Confirmed
Carey Underwood (cwillu) wrote :

Got this too.

The window controls are there, but invisible/grey. If you click in the grey bar where the close button is, for instance, it'll close.

Running "compiz-decorator --replace --metacity-theme blahblah" brings back normal looking window controls, with the builtin compiz theme instead of the selected theme.

Carey Underwood (cwillu) on 2009-02-11
Changed in compiz:
status: Confirmed → New
Gianfranco Liporace (dr.kabuto) wrote :

Hi,
to Julian: window managers doesn't have a bug report function build-in ;)

meborc (meborc) wrote :

i can confirm this bug on nvidia 8600M GT with jaunty 180 nvidia driver

Alex Bachmeier (cebalrai) wrote :

Bug confirmed:
9.04-amd64,2.6.28-7-generic #20-Ubuntu SMP, nvidia 180.27-0ubuntu1.
Nvidia Quadro 140NVS (Thinkpad T61)
metacity ver. 2.25.144-0ubuntu1

Martin Olsson (mnemo) wrote :

Confirm with x64, intel G45, all themes borked (both the "Dust" one I was using and the built-in ones).

Michael Vogt (mvo) wrote :

I close the metacity task, this is a problem that compiz needs to catch up with the latest changes in the libmetacity code.

Changed in compiz:
assignee: nobody → mvo
importance: Undecided → Medium
milestone: none → jaunty-alpha-5
status: New → In Progress
Changed in metacity:
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.7.9+git20090211-0ubuntu1

---------------
compiz (1:0.7.9+git20090211-0ubuntu1) jaunty; urgency=low

  * build from the 0.8 git branch
    - fixes focus problem (LP: #274407)
    - fixes problem with latest libmetacity decoration (LP: #327793)
    - enable new gnomecompat plugin by default
  * debian/patches:
   - updated 013-add-cursor-theme-support.patch
   - updated 018_use_metacity_settings.patch
   - updated 029_default_options
   - updated 035_ignore_workspaces
   - updated 037_fullscreen_stacking_fixes.patch (mostly merged upstream
     just the move plugin changes remain)
   - dropped 027_default_to_gnome_terminal
   - dropped 040_resolve-animation-fade-conflict_from_upstream.patch
   - dropped 047_no_display_compiz_desktop.patch
   - dropped 048_from_git_fix_placement.patch
   - dropped 050-scale-keybinding-toggle.patch
   - dropped 051-new-kde4-plasma-api.patch

 -- Michael Vogt <email address hidden> Tue, 10 Feb 2009 10:39:03 +0100

Changed in compiz:
status: In Progress → Fix Released
Noel J. Bergman (noeljb) wrote :

No, Michael, I am sorry but this bug is *NOT* fixed.

Before this latest update, I saw the problem described as "the window controls are there, but invisible/grey. If you click in the grey bar where the close button is, for instance, it'll close." HOWEVER, *after* installing the latest fix this morning, the entire title bar is gone.

zniavre (zniavre2048-gmail) wrote :

hello

can confirm bug still here and now emerald also broken

i hav found in gconf-editor > apps > gwd to unselect use metacity theme but now it does not work anymore

Martin Olsson (mnemo) wrote :

I just got these updates (below) and then I rebooted. Now all my decorations are gone.
Turn off compiz using System::Preferences::Appearence::Visual Effects == "None" is a workaround.

Get:1 http://archive.ubuntu.com jaunty/main libdecoration0 1:0.7.9+git20090211-0ubuntu1 [56.8kB]
Get:2 http://archive.ubuntu.com jaunty/main compiz-gnome 1:0.7.9+git20090211-0ubuntu1 [354kB]
Get:3 http://archive.ubuntu.com jaunty/main compiz-plugins 1:0.7.9+git20090211-0ubuntu1 [512kB]
Get:4 http://archive.ubuntu.com jaunty/main compiz-wrapper 1:0.7.9+git20090211-0ubuntu1 [41.9kB]
Get:5 http://archive.ubuntu.com jaunty/main compiz-core 1:0.7.9+git20090211-0ubuntu1 [246kB]
Get:6 http://archive.ubuntu.com jaunty/main evolution-dbg 2.25.90-0ubuntu2 [7294kB]
Get:7 http://archive.ubuntu.com jaunty/main evolution 2.25.90-0ubuntu2 [2496kB]
Get:8 http://archive.ubuntu.com jaunty/main evolution-common 2.25.90-0ubuntu2 [17.3MB]
Get:9 http://archive.ubuntu.com jaunty/main evolution-plugins 2.25.90-0ubuntu2 [110kB]

Jeffrey Baker (jwbaker) on 2009-02-11
Changed in compiz:
status: Fix Released → Confirmed
Max Bowsher (maxb) wrote :

To those of you reporting that the bug is not fixed: Please ensure you have also got the following package updates as well:

compiz-fusion-plugins-extra (0.7.8-0ubuntu3) jaunty; urgency=low
compiz-fusion-plugins-main (0.7.8-0ubuntu6) jaunty; urgency=low
libcompizconfig (0.7.8-0ubuntu3) jaunty; urgency=low

These are necessary rebuilds that go with the new compiz itself.

Ok, i assume bug is fixed and problem is only network latency between ubuntu mirror services. I am up to date on IT mirror, but bug is here as of 16:21 CET. Will wait some hours (libcompizconfig is not even reported as a known package) and then be back here if in case.

Sorry, found libcompizconfig0
                                            ^
I have installed

compiz-fusion-plugins-extra 0.7.8-0ubuntu2
compiz-fusion-plugins-main 0.7.8-0ubuntu5
libcompizconfig0 0.7.8-0ubuntu2

Waiting for mirror to catch up.

Martin Olsson (mnemo) wrote :

I got another set of updates now and this fixes the problem indeed (set "main server" under System::Administration::Software Sources) to speed up the process.

Changed in compiz:
status: Confirmed → Fix Released
Noel J. Bergman (noeljb) wrote :

Working for me now, too. Today's updates came as:

2009-02-11 07:38:53 status installed compiz-wrapper 1:0.7.9+git20090211-0ubuntu1
2009-02-11 07:38:53 status installed compiz-core 1:0.7.9+git20090211-0ubuntu1
2009-02-11 07:38:53 status installed compiz-plugins 1:0.7.9+git20090211-0ubuntu1
2009-02-11 07:38:56 status installed compiz-gnome 1:0.7.9+git20090211-0ubuntu1

2009-02-11 11:46:05 status installed compiz-fusion-plugins-main 0.7.8-0ubuntu6
2009-02-11 11:46:05 status installed compiz-fusion-plugins-extra 0.7.8-0ubuntu3
2009-02-11 11:46:05 status installed libcompizconfig0 0.7.8-0ubuntu3
2009-02-11 11:46:05 status installed compiz 1:0.7.9+git20090211-0ubuntu1

After the second batch of updates, the decorations came back.

> These are necessary rebuilds that go with the new compiz itself

Is a missing dependency declaration that should have kept the update together?

~/.xsession-errors
<skip>
(gtk-window-decorator:6648): metacity-CRITICAL **: meta_frame_style_draw_with_style: assertion `style_gtk->colormap == gdk_drawable_get_colormap (drawable)' failed
(gtk-window-decorator:6648): metacity-CRITICAL **: meta_frame_style_draw_with_style: assertion `style_gtk->colormap == gdk_drawable_get_colormap (drawable)' failed
...

Temporary solution
Use /apps/gwd/use_metacity_theme.

MatthewHawn (steamraven) wrote :

As of now, I am still having this problem with the latest updates. Here are the versions installed:

compiz 1:0.7.9+git20090211-0ubuntu4
compiz-core 1:0.7.9+git20090211-0ubuntu4
compiz-fusion-plugins-extra 0.7.9+git20090213-0ubuntu1
compiz-fusion-plugins-main 0.7.9+git20090213-0ubuntu2
compiz-gnome 1:0.7.9+git20090211-0ubuntu4
compiz-plugins 1:0.7.9+git20090211-0ubuntu4
compiz-wrapper 1:0.7.9+git20090211-0ubuntu4
compizconfig-backend-gconf 0.7.8-0ubuntu2
compizconfig-settings-manager 0.7.8-0ubuntu3
libcompizconfig0 0.7.8-0ubuntu4

I have an Nvidia 8600 GTS. I upgraded this install from Hardy, to Intrepid, to Jaunty. I cleared out my xorg.conf with dbkg-reconfigure -phigh xserver-xorg and added back in the Nvidia driver through hardware drivers. I have attached the xorg.conf.

From reading some other forums and bug reports, I also ran nvidia-xconfig --composite --add-argb-glx-visuals. There was no change after reboot

There appear to be no errors in Xorg.0.log

If you need anything else, I would be happy to supply it.

Changed in compiz:
status: Unknown → Confirmed
status: Unknown → In Progress
Musashi (slice39) wrote :

https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/340895

I'm still affected by this bug have all the latest. I couldn't figure out how to merge (or add to duplicate) the bug I submitted.

Changed in compiz (Mandriva):
status: Confirmed → Fix Released
Malcolm (malcolmdean) wrote :

This bug just appeared for me after the updates of April 23-24, 2009.

Martin Olsson (mnemo) wrote :

I've updated to the release candidate bits for jaunty and using ALT-PrintScreen and compiz I still get no borders included in the screenshot. Even though most other distros seem to have fixed this bug, the fix is not yet included in Ubuntu. Changing "fix released" back to "fix commited".

Changed in compiz (Ubuntu):
status: Fix Released → Fix Committed
Max Bowsher (maxb) wrote :

@Mushashi
Based on the further discussion that occurred n bug 340895, it sounds like whatever the problem was, it was a different one to this bug.

@Malcolm
It's unlikely that any problem you started experiencing so long after this bug was fixed has the same root cause, please file a separate bug if you still have a problem.

@martin
This bug concerns the decorations being present but appearing as a flat solid grey, on the actual screen - *not* the decorations being omitted from screenshots. Please file a separate bug.

Also, for future reference, "Fix Committed" means that a fix is known and waiting to be uploaded. Therefore, it's not the right status to set when reopening a bug - use "New" or "Confirmed" for that, as appropriate.

Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
iextreme (pixelazion) wrote :

I'm having similar problem, I updated from 8.10 to 9.04 after the update, everytime I open an application (e.g gedit) it always opens up maximized and the most annoying part is that the maximized window doesn't have a title bar or whatsoever, i'm also on compiz, even running emerald with it has the same problem.

iextreme (pixelazion) wrote :

false alarm for me my bad, i just figured it out after my post, but what the hell is "maximus" doing in my system, I do not remember installing it during 8.10 and neither during the 9.04 update. please take a look at the update config on this one, it so annoying.

This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]

Switching incorrect assignees to the default one.

banza (banza) wrote :

Remove "maximus" helped me too.

in my case, it's installed with "ubuntu-netbook-remix 1.171"

Hi David, Sangu.

It looks like you hit the same as https://bugzilla.redhat.com/show_bug.cgi?id=484056 (gtk-window-decorator: ghost-like title bars...)

That has been fixed.
So closing this ticket.

Regards.
And happy 2009 ending.

--
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 484056 ***

Changed in compiz (Fedora):
status: In Progress → Invalid
w4w4n (wawan) on 2010-01-20
Changed in compiz (Ubuntu):
assignee: Michael Vogt (mvo) → w4w4n (wawan)
w4w4n (wawan) on 2010-01-20
Changed in compiz (Ubuntu):
status: Fix Released → Confirmed
Max Bowsher (maxb) wrote :

w4w4n: You have altered bug metadata on an old bug without providing any rationale for doing so. Please do not do that.

Changed in compiz (Ubuntu):
assignee: w4w4n (wawan) → Michael Vogt (mvo)
status: Confirmed → Fix Released
w4w4n (wawan) wrote :

I'm really sorry guys,
I'm don't really know how to use this website, so I try something ...... and apparently it's not a good thing to do :(
And I not good at English too ....

I got this problem when enabling compiz in Karmic Koala (and yes, I'm using nvidia) ...... and I have solved it .....

1. Open up a terminal and type sudo su (enter your password)
2. Type gedit /etc/X11/xorg.conf
3. From the xorg.conf file, find the section called Section "Device" and just before EndSection, add the following and save the file:
          Option "AddARGBVisuals" "True"
          Option "AddARGBGLXVisuals" "True"

4. Here is an example of an edited Section (your Section may vary):
          Section "Device"
          Identifier "Videocard0"
          Driver "nvidia"
          VendorName "NVIDIA Corporation"
          BoardName "GeForce 6150"
          Option "AddARGBVisuals" "True"
          Option "AddARGBGLXVisuals" "True"
          EndSection

   5. Restart Ubuntu and the titlebar with related window decorations should reappear

I got this from here http://www.pendrivelinux.com/ubuntu-desktop-effects-fixing-the-missing-titlebar/

Greya (grreya) wrote :

I have the same problem with the window decorations. I found to solve it but just until the next reboot
I have compiz settings off, and I even had my compiz uninstalled when this problem occurred.
Temporary solution: I turn Compiz effects to Normal > I wait for it to apply > "Keep settings" > Turn back to Compiz effects Off (for when it's on - it slows down everything).

Today I found what the problem is - it is XORG!
I've tried the solution proposed by w4w4n and I found out that my xorg.conf file is gone! I remember there was some xorg updates recently - so, I suppose, the bug is due to these recent xorg updates which, apparently, deleted the existant xorg.cong file !without backup!

I have a xorg.conf backup - but I cannot reach it for the moment (I'm far from home). What should I do to reconfigure xorg without failure?

Thanks, I hope it will help!

This bug came up on up to date fedora-12. I am not sure what caused it, appeared after i upgraded the packages yesterday.

The updated gtk packages are

Feb 18 14:41:33 Installed: 1:gtk+-1.2.10-69.fc12.i686
Feb 18 14:59:22 Updated: libchamplain-gtk-0.4.3-1.fc12.i686
Feb 18 15:00:16 Installed: transmission-gtk-1.83-2.fc12.i686
Feb 18 15:00:35 Updated: GConf2-gtk-2.28.0-4.fc12.i686
Feb 18 15:01:31 Installed: report-gtk-0.7-1.fc12.i686
Feb 18 15:07:05 Updated: ibus-gtk-1.2.0.20100111-2.fc12.i686

I notice the gtk-window-decorator is not running and manually running it does not have any impact.

Thanks

Raj

I was able to identify my problem to missing modulepath's. Once I added them, the compiz and gtk-window-decorator works as designed.

Sorry for the confusion. Raj

fermulator (fermulator) wrote :

w4w4n wrote on 2010-01-20:

CONFIRMED. Applying those options to the Device section in xorg.conf restores window decorations in compiz.

Changed in compiz (Mandriva):
importance: Unknown → Medium
Liam Proven (lproven) wrote :

This bug has reappeared as of 7 May 2017 in 16.04.

Changed in compiz (Fedora):
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.