Compiz causes system freeze (need to hard reboot)

Bug #283056 reported by Piraja on 2008-10-14
This bug report is a duplicate of:  Bug #541492: MASTER: [i845] GPU lockup. Edit Remove
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by Brian Rogers
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by Brian Rogers

Bug Description

After upgrading from Hardy to Intrepid (kernel 2.6.27-7-generic), "Alt+F2 > compiz --replace" and/or going to System > Preferences > Appearance > Visual Effects and changing from "None" to "Normal" (I did not even try "Extra" yet) results immediately* in plain desktop background view, the open window(s) and panels disappearing. No key combination (Ctrl+Alt+Backspace, Ctrl+Alt+Del, Ctrl+Alt+F3, etc. etc.) has any effect, so I have to do hard reboot. I have tried this three times after having upgraded yesterday from Hardy on my desktop PC,* and each time the result is the same, i.e. need to hard-reboot.

I have had Intrepid on my laptop (Acer TravelMate 2354, with recent RAM upgrade from 256 to 768 MB) for several weeks now with no such problems, but upgrading to Intrepid on this desktop machine** was not as successful.

*) Later correction: The crash is not as immediate as I first remembered. Before the "Appearances" window and the panels disappear and the desktop freezes, the Appearances manager starts "searching for available drivers".

**) Compaq Evo D510 SFF, 512 MB RAM, Intel Celeron 2 GHz, Intel 845 graphics card.*** Ubuntu 8.10 installed on external HDD (WD, 500 GB USB drive).

***) EDIT/UPDATE: Could this be a monitor / graphics card / drivers related issue? My monitor is ViewSonic Optiquest Q201wb, not listed in "Screen and Graphics Preferences" / "Model" (instead, it is recognized as just "Plug'n'Play"). As I wrote in "*" above, the crash happens when the Appearances manager searches for available drivers.

I am attaching my "etc/x11/xorg.conf" and "var/log/Xorg.0.log" files. I hope this helps.

description: updated
description: updated
Brian Rogers (brian-rogers) wrote :

I saw this issue on a Gateway E-4000 with an Intel 845G graphics chip and 768 MB of RAM. It causes booting of the latest Intrepid live CD to fail when compiz loads at startup. The pointer can be moved, but nothing else responds.

I'm attaching the Xorg log file from the same system updated to 8.10 through the update manager. After logging in, X freezes right away because of Compiz. I hit the power button, and the system was able to shut down. I think that's because the login didn't complete, so the power button was still triggering a direct shutdown rather than bringing up the shutdown dialog first.

Removing compiz allowed me to log in. Without compiz, glxinfo and glxgears worked without issue.

Brian Rogers (brian-rogers) wrote :

Also, I tried booting the previous 2.6.24 kernel and the same freeze occurred.

Daniël H. (daan-is-here) wrote :

Confirmed
When I enter Compiz in the terminal I notify this line
"Checking for XGL: XGL not present"
I can't read the other lines as they are rolling too fast.
Intel 845G
Compaq Evo D51S.

Changed in xserver-xorg-video-intel:
status: New → Confirmed
TristanB (tristan-buckmaster) wrote :

I have exactly the same problem.

My System:
Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device
Pentium 4 2.5GHz
512 Ram

Brian Rogers (brian-rogers) wrote :

This is a driver bug, not a compiz bug. Marking compiz task as invalid.

Changed in compiz:
status: New → Invalid
Brian Rogers (brian-rogers) wrote :

Counting myself, there are four people encountering this freeze, and we all have Intel 845 chips. We need more people with this chip to try Intrepid, to figure out if this chip is working for some people, or if 845 support is broken across the board.

Absorbed (abs0rb3d) wrote :

I have the same problem using Intrepid with all the updates.

lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 03)

Dimitrios Symeonidis (azimout) wrote :

absorbed, this bug report is a duplicate of bug 259385:
https://bugs.launchpad.net/bugs/259385

please follow that other bug report

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers