Intrepid CD Live Gnome desktop fails

Bug #277344 reported by jerrylamos on 2008-10-03
This bug report is a duplicate of:  Bug #541492: MASTER: [i845] GPU lockup. Edit Remove
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Low
Unassigned
xserver-xorg-video-ati (Ubuntu)
Undecided
Unassigned

Bug Description

Intrepid daily build level 20081001 boot on IBM Thinkpad R31, 32 bit Celeron 1 gHz, Intel graphics

CD Live Boot goes as far as brown screen with pointer, which moves, then shortly hangs up.

In chasing the bug, Install worked O.K. Trying to run it gets same result as CD live.

Farthest it will go is to do Ctrl-Alt-F1 when brown screen first appears. Looking at the root command line prompt, I can hear the hard drive run as Gnome starts up.

Ctrl-Alt-F7 to display the gdm. Gnome desktop appears, new background, top & botton mines, applets, the whole bit. Then about one second later the desktop disappears except for the background screen & pointer, and the computer is hung up.

Note, Xubuntu & Kubuntu run O.K. It's just Ubuntu with Gnome that doesn't. I'm entering this from the dual boot Intrepid early Alpha 5 which works.

Using the dual boot there are some log entries about the time of failure, daemon.log, user.log, and dmesg which I'll attach.

jerrylamos (jerrylamos) wrote :
jerrylamos (jerrylamos) wrote :

2nd of 3 logs modified at failure time

jerrylamos (jerrylamos) wrote :

3rd to last of the 3 logs modified at failure time

jjos (jbenjos) wrote :

I am going to assign this bug to gnome-panel as it looks as the most likely candidate. If you have any additional information that could accurately pin this to a specific package please let us know. Thank you for taking time to help make Ubuntu better.

Sebastien Bacher (seb128) wrote :

thank you for your bug report, that looks rather an incorrect cdimage, you should try to download and burn it again, could you also attach your .xsession-errors log after trying to login? could you start an another session and run gnome-session there and see if it starts correctly?

Changed in gnome-panel:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
jerrylamos (jerrylamos) wrote :

This morning I downloaded Intrepid Beta from the official site onto the Thinkpad, verified MD5 sums, verified CD Image on the Thinkpad so its CD drive is O.K.
Beta CD fails the same way as the 20080930 and the 20081001 fail.
Installed the Beta CD on another computer, runs O.K. for a Beta so the CD is O.K.
Installed the Beta CD on the Thinkpad. Install proceeds normally. Boot it up and fails the same way as in the bug report. Either a regular boot or recovery mode & startx and gnome desktop freezes the computer as in the description above.
Alpha 5 runs fine, using it now, so the computer is O.K.

Attached is /home/jerry/.xsession-errors from the Beta. It's got a pile of errors consistent with the logs previously attached above.

One of the first lines says:
x-session-manager[5567]: WARNING: Unable to find provider 'gnome-wm' of required
 component 'windowmanager'

Thanks for looking at this. Jerry

jerrylamos (jerrylamos) wrote :

Just to see if I could get any display manager running on the Beta install I did:
boot in recovery mode
select root prompt
dhclient
ifconfig
apt-get install xfce4
startxfce4

which came right up. I'm making this entry now from that setup which runs Firefox 3.03 O.K.

Before going through all this I tested startx which fires up gnome, and which freezes as described in the bug description. Power off and try xfce4 which works.

Jerry

jerrylamos (jerrylamos) wrote :

ATI is noted at the top. This is an IBM Thinkpad R31 with Intel graphics, see attached lspci.

00:02.0 VGA compatible controller [0300]: Intel Corporation 82830 CGC [Chipset Graphics Controller] [8086:3577] (rev 04)
 Subsystem: IBM Device [1014:0505]

Even when it's dead, the pointer still moves. X windows is still up, but the keyboard tty is dead (except for power off) and the screen never changes.

xfce4 works O.K., its Gnome-desktop actions that kills it.

Jerry

jerrylamos (jerrylamos) wrote :

Here's the lspci -vvnn

Thanks, Jerry

jerrylamos (jerrylamos) wrote :

Doesn't make sense to me. .xsession-errors says:

x-session-manager[5567]: WARNING: Unable to find provider 'gnome-wm' of required component 'windowmanager'

If I do a "find", there it is:
ls -l /usr/bin/gnome-wm
-rwxr-xr-x 1 root root 4087 2008-09-23 04:18 /usr/bin/gnome-wm

What's Xwindows problem that it can't find gnome-wm? Is gnome telling it to look somewhere else?

Thanks, Jerry

Sebastien Bacher (seb128) wrote :

do you have a /usr/share/gnome/autostart/gnome-wm.desktop too?

jerrylamos (jerrylamos) wrote :

kernel 2.6.27-5.8 on today's daily build, 20081006, fails same way.
MD5 sum check out fine.
CD check for errors none found.
CD boots on Compaq Presario O.K., works fine, for a Beta.

On IBM Thinkpad R31, 2.6.27-5.8 fails just like 2.6.27-4 on Beta Release and also like Alpha 6 failed.

CD Live Boots up, X inititates, brown screen, then black screen with movable pointer. Keyboard is dead.

If I do Ctrl-Alt-F1 as soon as brown screen appears, command line prompt comes up O.K.

Copied xsession-errors, dmesg, lspci -vvnn, Xorg,0.log to USB drive since there are a bunch of error messages. Will attach these following.

Switched back to windows screen with Ctrl-Alt-F7. Full Gnome desktop showed up fine including notification that a USB drive was attached, then a second later the desktop disappeared with the monitor showing the background, a movable pointer, and the keyboard was dead.

Entering this message from previously installed Beta using xfce4 on the Thinkpad. I'm doing daily updates which included 2.6.27-5.8 which fails the same way that the CD Daily live did.

Let me know what other info you would like, or if I can try anything.

Jerry

jerrylamos (jerrylamos) wrote :

Xorg.0.log shows same type of problems

jerrylamos (jerrylamos) wrote :

lspci -vvnn on the Thinkpad R31

jerrylamos (jerrylamos) wrote :

dmesg showing level of kernel

jerrylamos (jerrylamos) wrote :

daemon.log from failed boot

jerrylamos (jerrylamos) wrote :

Sebastian Bacher asked about gnome-wm.desktop which is attached.

jerrylamos (jerrylamos) wrote :

Is there a way to substitute metacity for compiz on Intrepid Ubuntu? Bug 257456 seemed to implicate compiz in the freeze.

Thanks, Jerry

jerrylamos (jerrylamos) wrote :

Removed Compiz with Synaptic. Desktop no longer freezes, however starting Firefox results in message "Could not initialize the applications security components........". Shortly thereafter Firefox disappears.

Any hints on how to remove Compiz but enable applications like Firefox to initialize their security components?

Sure would appear to the "ordinary desktop user" that Compiz freezes the Thinkpad. Any way to use Metacity instead?

Thanks, Jerry

jerrylamos (jerrylamos) wrote :

Updated Compiz today Oct 11 on Intrepid Beta. PC hUpdated Compiz today on Intrepid Beta. PC hangs with black screen and frozen spinner at just the point Gnome should display the desktop.

I'm back to using xfce4 on Ubuntu because I haven't found a clean way to replace Compiz with Metacity. Anyone any hints?

For that matter, any way to back date Compiz to the original Alpha 5 level?
That's dual booted on this R31 & runs O.K.

Jerry

jerrylamos (jerrylamos) wrote :

Workaround for Beta:

Besides:

sudo apt-get remove compiz
sudo apt-get remove compiz-core

I had to edit:

/etc/X11/default-display-manager
#/usr/sbin/gdm

otherwise Firefox gets an authority error and crashes.

switcher also won't load so I start a command line to halt or reboot.

I'll probably find some other bugs as well but at least it's running, first time since initial Alpha 5. An update to Alpha 5 creamed Compiz for the Thinkpad, most likely Compiz since it works without it.

Jerry

jerrylamos (jerrylamos) wrote :

Daily Build 20071014 CD Live still fails. Boots to black screen where Gnome desktop should load.

Found a workaround:
Boot CD Live
Watch for X to initialize
Ctrl-Alt-F1 (timing dependent, might have to do it a few times)
sudo killall gdm
sudo apt-get remove compiz
sudo apt-get remove compiz-core
sudo startx

and away it goes, booting successfully, gnome desktop and allQ
not quite all - switcher fails, reload? don't reload, to get switcher functions just do Alt-F2 and enter the command, sudo halt or sudo reboot or sudo whatever.

Sure could use a CD Live boot option to remove compiz!!

Jerry

Changed in gnome-session:
assignee: desktop-bugs → nobody
status: Incomplete → New
jerrylamos (jerrylamos) wrote :

CD Live 20081016 still boots to black screen.

It will boot using workaround in previous comment.

Install does run because it doesn't use compiz, however the installed Ubunto gets the same fatal hang as CD Live. Boot in rescue mode and remove compiz, then it runs.

Since this bug is rated "low" importance I assume at this late date Release Code will have the same problem? and won't run on IBM Thinkpad R31's. There are a number of posts in Intrepid Ibex Testing & Discussion with different hardware and similar symptoms however I have no way of knowing how many are related to compiz.

Jerry

I can confirm this bug on a IBM Thinkpad X30. Upgrading from 8.04 to 8.10 results in the above mentioned symptoms.

Removing compiz makes it possible to bring up the desktop. By the look of things, compiz does not play nicely with the Intel 82830 GPU/chipset...

/Lennart

jerrylamos (jerrylamos) wrote :

CD Live Intrepid has been too big to fit on a 700 mb CD for the last 3 days so I did this test:

1. Boot installed Intrepid with compiz removed but with all the latest updates from the internet. O.K.
2. sudo apt-get install compiz. Note, Visual Effects are set to none. Still running.
3. Restart, with all the latest updates but with compiz installed in step 2. X comes up, orange screen, and laptop is totally hung up with no keyboard response except power off. Won't boot even with Visual Effects previously set to none.
4. Restart in rescue mode, remove compiz, normal boot O.K. without compiz.
5. Happened to have a Gutsy Ubuntu CD Live handy which booted fine, Visual Effects Normal run fine.

This laptop is dual booted with Alpha 5 NOT UPDATED so I can get the failure with latest updated Beta then boot the Alpha 5 to look at logs & messages from the beta if someone would tell me what is significant in addition to all comments above. I don't think this is a failure of this particular laptop alone by scanning the Intrepid Ibex forums there are several posts with similar failures, some of whom have removed compiz with some benefit.

Thanks for your attention, Jerry

David (david-viertl) wrote :

Just to confirm this bug too.

Affects my Dell Inspiron 1100 Intel celeron 2.4GHz , with an Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset (see attached lspci-vvnn).

Same symptoms with a live CD or a fresh install. Same therapy: remove compiz!

David

Same symptoms, same workaround, but I must also add that the same machine ran Compiz quite nicely on Feisty and Hardy (enabled by default), so I do not believe the hardware is incompatible with Compiz.

I suggest others here try booting from a Hardy desktop CD and see if it runs with 'desktop effects' turned on (GNOME menu > Preferences > Appearance > Visual Effects). Either the 'normal' or 'extra' setting will use Compiz, whereas the 'none' setting uses Metacity (I think).

Losing Compiz is no deal-killer, but it is nice to have.

jerrylamos (jerrylamos) wrote :

Note this bug is similar to Launchpad 259385 which is marked confirmed and lists my workaround in the description. Importance is listed undecided.

Jeffrey Seguerra (jepong) wrote :

the release candidate will be available anytime soon and I hope it'll get fix.

Regarding compiz in hardy heron... I was able to boot and login with desktop effect set by default but I usually turn it off because my system hangs after a short while.

I'm also using a ThinkPad R31.

Jeffrey Seguerra (jepong) wrote :

Release Candidate has been announced... https://wiki.ubuntu.com/IntrepidIbex/RCAnnouncement

Have they fixed compiz already?

Daniël H. (daan-is-here) wrote :

@jepong: no

To post a comment you must log in.